Entering a ridiculously long login/password crashes lightdm

Bug #817186 reported by Jean-Baptiste Lallement on 2011-07-27
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Unassigned
lightdm (Ubuntu)
High
Unassigned

Bug Description

TEST CASE:
1. On the login screen, select an account
2. In the password field enter a very very long string (I entered 0123456789 repeated 100 times which is 1000 chars long)

Result:
The password field freezes (the UI is still working, but the password field is greyed, and never back to normal state) and this crash occurs.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: lightdm 0.9.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-7.8-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
Date: Wed Jul 27 15:00:06 2011
Disassembly: => 0x390999: Cannot access memory at address 0x390999
ExecutablePath: /usr/sbin/lightdm
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
ProcCmdline: lightdm
ProcEnviron: PATH=(custom, no user)
Signal: 5
SourcePackage: lightdm
Stacktrace:
 #0 0x00390999 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0xbff447e0
StacktraceTop: ?? ()
Title: lightdm crashed with signal 5
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

mtime.conffile..etc.lightdm.lightdm.conf: 2011-07-25T23:56:44.233567

Jean-Baptiste Lallement (jibel) wrote :

Stacktrace:
 #0 0x00390999 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0xbff447e0
StacktraceTop: ?? ()

Changed in lightdm (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

lightdm: installed version 0.9.2-0ubuntu3, latest version: 0.9.2-0ubuntu4

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace

I'll try to get a better trace but the problem is still valid and reproducible. Setting back to new.

Changed in lightdm (Ubuntu):
status: Invalid → New
visibility: private → public
summary: - Entering a ridiculously long password crashes lightdm
+ Entering a ridiculously long login/password crashes lightdm
Jean-Baptiste Lallement (jibel) wrote :

Here is the trace.

Changed in lightdm (Ubuntu):
importance: Undecided → High
tags: added: testcase
Changed in lightdm (Ubuntu):
status: New → Fix Released
status: Fix Released → Triaged
Robert Ancell (robert-ancell) wrote :

Fixed in 1.0.2.

Changed in lightdm (Ubuntu):
status: Triaged → Fix Committed
Changed in lightdm:
status: New → Fix Committed
importance: Undecided → High
Changed in lightdm:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.1-0ubuntu4

---------------
lightdm (1.0.1-0ubuntu4) oneiric; urgency=low

  * debian/patches/04_language_not_to_LANG.patch:
  * debian/patches/04_dmrc_set_LANG_only.patch:
    - Replace LANG disabling code with proper fix (LP: #868149)
  * debian/patches/03_launch_dbus.patch:
  * debian/patches/05_gdmflexiserver_not_in_PATH.patch:
    - Refreshed
  * debian/patches/06_accounts_service_timeout.patch:
    - Fix D-Bus timeout when accounts service not installed (LP: #866035)
  * debian/patches/07_long_password_crash.patch:
    - Fix crash with long passwords (LP: #817186)
 -- Robert Ancell <email address hidden> Thu, 06 Oct 2011 15:45:21 +1100

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Deckard (frank-s) wrote :

Sometimes my keyboard starts sending the number '5', as if someone is holding down the key. It stops if I touch another key.
If this happens while I'm away and the screen is locked, then I can't delete the password entry field or press enter to get an invalid password and start over. I can get a prompt via alt+ctrl+1 and sometimes it's enough to kill lightdm, and other times I must hold the power button down until the machine powers down, and make a cold boot. I know my keyboard is broken, but I don't think that it should kill the greeter.

Jakob Sloth Nielsen (jsloth) wrote :

I have the exact same issue as Deckard.
Using Ubuntu 15.10

Deckard (frank-s) wrote :

Update:

Sorry I forgot: Ubuntu 15.10, lightdm 1.16.7

Still the same problem as 2016-02-25:

Sometimes my keyboard starts sending the number '5', as if someone is holding down the key. It stops if I touch another key.
If this happens while I'm away and the screen is locked, then I can't delete the password entry field or press enter to get an invalid password and start over. I can get a prompt via alt+ctrl+1 and sometimes it's enough to kill lightdm, and other times I must hold the power button down until the machine powers down, and make a cold boot. I know my keyboard is broken, but I don't think that it should kill the greeter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers