KDE session does not have shutdown/restart options available if session is started via LightDM

Bug #689242 reported by David Edmundson on 2010-12-12
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Unassigned
kde-workspace (Ubuntu)
High
Aurélien Gâteau
Oneiric
High
Unassigned
Precise
High
Aurélien Gâteau
lightdm (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

---- SRU ----
[Impact]
KDE users using LightDM as a display manager do not get entries in the K menu to shutdown and reboot. Additionally, switching sessions does not work.

[Development Fix]
Fixed upstream in both master and KDE/4.7. The fix mainly consists of updating KDE code to current LightDM DBus interfaces.

[Stable Fix]
Same fix as the development fix, see debdiff.

[Test Case]
- Select LightDM as your display manager
- Start a KDE session
- Open the K menu, go to the "Leave" section
- Notice the lack of "Restart" and "Shut down" items

[Regression Potential]
No expected regression.

---- Original Description ----
I assume this is ConsoleKit related. I do not know if it affects the Gnome desktop too. Will investigate further later.

Julien Lavergne (gilir) wrote :

I can confirmed this with a LXDE session

Changed in lightdm:
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Any update on this?

Yves-Alexis Perez (corsac) wrote :

Not sure it's related but it seems that, starting 3.0, lightDM fails to setup consolekit properly. It's using the vala greeter (since the GTK+ one segfaults)

Yves-Alexis Perez (corsac) wrote :

Some logs:

Apr 20 20:37:45 hidalgo lightdm: PAM pam_open_session: NULL pam handle passed
Apr 20 20:37:45 hidalgo lightdm: PAM pam_getenvlist: NULL pam handle passed
Apr 20 20:37:50 hidalgo lightdm: PAM pam_close_session: NULL pam handle passed
Apr 20 20:37:51 hidalgo polkitd[5033]: started daemon version 0.101 using authority implementation `local' version `0.101'
Apr 20 20:37:51 hidalgo polkitd[5039]: started daemon version 0.101 using authority implementation `local' version `0.101'
Apr 20 20:37:51 hidalgo polkitd[5082]: started daemon version 0.101 using authority implementation `local' version `0.101'

The PAM messages are a bit weird too...

Robert Ancell (robert-ancell) wrote :

Please check 0.3.2 - there was bad logic in 0.3.0 since the change to GDBus which always had can_shutdown() etc returning FALSE.

Anders Kaseorg (andersk) wrote :

I’m seeing this in oneiric with the gnome-classic session. Shutdown, Restart, and Suspend are greyed out when logging in with lightdm; they work fine when logging in with gdm.

Alex Fiestas (afiestas) wrote :

I'm using lightDM 0.3.7 right now with the KDE that should become 4.7 and everything seems to be working fine. Also when I fixed this into master I did backport the change to 4.6, so it should be out now (with 4.6.4), can anybody check this?

Thanks.

Changed in lightdm:
importance: Undecided → High
Changed in lightdm (Ubuntu):
importance: Undecided → High
status: New → Confirmed

To clarify Alex's comment.

This is a KDE bug not a LightDM one. It has been fixed in the very latest versions of KDE. These versions have not reached Kubuntu yet.

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Committed
Changed in lightdm:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

setting to invalid for lightdm since the issue is a KDE one

Changed in lightdm (Ubuntu):
status: Fix Committed → Invalid
Changed in lightdm:
status: Fix Committed → Invalid
Aurélien Gâteau (agateau) wrote :

It is broken in Oneiric right now because LightDM DBus interface got renamed and changed a bit. I submitted an upstream merge-request to fix it: https://git.reviewboard.kde.org/r/102974/

Changed in kdebase-workspace (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Aurélien Gâteau (agateau)
Philip Muškovac (yofel) wrote :

This should be kde-workspace.

affects: kdebase-workspace (Ubuntu) → kde-workspace (Ubuntu)
Scott Kitterman (kitterman) wrote :

This is really a different bug than the original one, but whatever.

It would be nice if system level applications like lightdm didn't make arbitrary, uncoordinated API changes that break other systems.

Robert Ancell (robert-ancell) wrote :

For the record, this was changed in 0.1.2, very early in the development process (as were a number of features that were still being worked out). No API guarantees were made at the time, and this was specified in the release notes. API guarantees have been in place since 0.9.0.

Aurélien Gâteau (agateau) wrote :

Here is a debdiff containing a backport of the code which got committed upstream.

description: updated

The attachment "debdiff for kde-workspace_4.7.2-0ubuntu2" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Felix Geyer (debfx) on 2011-10-29
Changed in kde-workspace (Ubuntu Oneiric):
status: New → Triaged
Felix Geyer (debfx) on 2011-10-29
Changed in kde-workspace (Ubuntu Oneiric):
importance: Undecided → High
Changed in lightdm (Ubuntu Oneiric):
status: New → Incomplete
status: Incomplete → Invalid
Felix Geyer (debfx) wrote :

Thanks for the debdiff!
I've uploaded it to oneiric-proposed, waiting for approval.

Aurélien Gâteau (agateau) wrote :

Thanks for this Felix, and for nominating it for Oneiric (couldn't do it as I lost the credentials to do so for some reason)

Hello David, or anyone else affected,

Accepted kde-workspace into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kde-workspace (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Aurélien Gâteau (agateau) wrote :

Just tested it (sorry for the delay). I can confirm the packages in oneiric-proposed fix the bug.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-workspace - 4:4.7.3a-0ubuntu1

---------------
kde-workspace (4:4.7.3a-0ubuntu1) precise; urgency=low

  [ Romain Perier ]
  * New upstream release
    - Bump kde-sc-dev-latest to 4.7.3

  [ Felix Geyer ]
  * Drop sequence numbers from patch filenames.
  * Remove kubuntu_fix_lightdm_support.diff, merged upstream.

kde-workspace (4:4.7.2-0ubuntu2) oneiric-proposed; urgency=low

  * kubuntu_fix_lightdm_support.diff: update LightDM support to match with
    the version of LightDM shipped with Oneiric (LP: #689242).
 -- Felix Geyer <email address hidden> Thu, 10 Nov 2011 19:30:18 +0100

Changed in kde-workspace (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kde-workspace - 4:4.7.2-0ubuntu2

---------------
kde-workspace (4:4.7.2-0ubuntu2) oneiric-proposed; urgency=low

  * kubuntu_125_fix_lightdm_support.diff: update LightDM support to match with
    the version of LightDM shipped with Oneiric (LP: #689242).
 -- Aurelien Gateau <email address hidden> Wed, 26 Oct 2011 17:08:08 -0400

Changed in kde-workspace (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers