Xorg does not terminate on logout

Bug #1739787 reported by Martin Vogt
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Fix Released
Medium
Unassigned

Bug Description

Hello,

I'm using lightdm from a remote Xorg server.

When I logout the Xorg process does not terminate anymore

This behaviour was introducted between 1.21.1->1.21.2.

1.21.1: works
1.21.2: hangs

I even can kill all userprocesses on the remote host
and Xorg does not terminate.

best regards,

Martin

Revision history for this message
Martin Vogt (mvogt1-c) wrote :

The behaviour was introduced with revision 2441 (revision 2440 works)

http://bazaar.launchpad.net/~lightdm-team/lightdm/trunk/revision/2441

Revision history for this message
Martin Vogt (mvogt1-c) wrote :

The mailinglist posting is here:

https://lists.freedesktop.org/archives/lightdm/2017-December/001098.html

patch attached.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Can you show the lightdm configuration that causes this?

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Using the following configuration:

[Seat:*]
type=xremote
xserver-hostname=<hostname>
xserver-display-number=<display number>

I can reproduce the the critical error (not present in 1.20), but in both cases the daemon stops (since it can't reconnect to the X server).

Or are you using XDMCP?

Revision history for this message
Martin Vogt (mvogt1-c) wrote :

>Or are you using XDMCP?
Yes, I'm using XDMCP.
The X server ist started with -teminate and reconnects after terminate to the
XDMCP chooser.

>I can reproduce the the critical error (not present in 1.20)
(My "fix" moved the signal call a few lines higher)

>Can you show the lightdm configuration that causes this?

(Comments in lightdm.conf removed)

[LightDM]
minimum-vt=1
user-authority-in-system-dir=true

start-default-seat=false
[Seat:*]
xserver-command=X -background none +iglx
greeter-session=lightdm-greeter
session-wrapper=/etc/X11/xinit/Xsession

[XDMCPServer]

enabled=true
[VNCServer]
[SeatDefaults]
xserver-allow-tcp=true
greeter-hide-users=true
greeter-show-manual-login=true

Revision history for this message
Robert Ancell (robert-ancell) wrote :

I think I've fixed this and a number of related bugs in git master (LightDM is now in GitHub - https://github.com/CanonicalLtd/lightdm). Can you please test and see if this works for you?

Changed in lightdm:
importance: Undecided → Medium
status: New → Fix Committed
Revision history for this message
Martin Vogt (mvogt1-c) wrote :

Yes, it works now.
But on RHEL7 I needed the attached patch for compile.

Changed in lightdm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers