lightdm won't start sway or plasma wayland

Bug #1664097 reported by ender
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager

Bug Description

lightdm version: 1.20.0
distribution: archlinux
greeter: both lightdm-gtk-greeter and ligthdm-kde-greeter

When I try to start a session with sway or Plasma with wayland (both wayland sessions) the screen will go black for a couple of seconds then it will return to the login screen. At first I thought lightdm just didn't work with wayland, but then I tried weston, and it worked fine.

[+11056.83s] DEBUG: Greeter requests session sway
[+11056.93s] DEBUG: Writing /home/thayne/.dmrc
[+11057.11s] DEBUG: Seat seat0: Creating display server of type wayland
[+11057.11s] DEBUG: Using VT 8
[+11057.11s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+11057.11s] DEBUG: Seat seat0: Display server ready, running session
[+11057.11s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session5
[+11057.11s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+11057.11s] DEBUG: Session pid=5808: Running command /etc/lightdm/Xsession sway
[+11057.11s] DEBUG: Creating shared data directory /var/lib/lightdm-data/thayne
[+11057.11s] DEBUG: Session pid=5808: Logging to .xsession-errors
[+11057.12s] DEBUG: Activating VT 8
[+11057.18s] WARNING: Error using VT_WAITACTIVE 8 on /dev/tty0: Interrupted system call
[+11057.18s] DEBUG: Seat seat0: Stopping greeter
[+11057.18s] DEBUG: Session pid=5729: Sending SIGTERM
[+11057.18s] DEBUG: Activating login1 session c15
[+11057.18s] WARNING: Error activating login1 session: GDBus.Error:org.freedesktop.login1.NoSuchSession: No session 'c15' known
[+11057.19s] DEBUG: Session pid=5808: Exited with return value 0
[+11057.19s] DEBUG: Seat seat0: Session stopped
[+11057.19s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+11057.19s] DEBUG: Seat seat0: Display server stopped
[+11057.19s] DEBUG: Releasing VT 8


Tags: wayland
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers