Scans all user accounts when not required

Bug #1370852 reported by Robert Ancell on 2014-09-18
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Robert Ancell
1.10
High
Robert Ancell
lightdm (Ubuntu)
High
Robert Ancell
Trusty
High
Robert Ancell
Utopic
High
Robert Ancell

Bug Description

[Impact]
When AccountsService is not present on startup LightDM scans all the user accounts and attempts to access the dmrc file for each user. It does not use any information from the dmrc files. If you have many users and/or the dmrc files are on a slow filesystem this creates a big startup delay.

[Test Case]
1. Start LightDM on a system that doesn't have AccountsService and has many users
Expected result:
LightDM starts quickly
Observed result:
LightDM takes a long time to start

[Regression potential]
Low. We now only access the dmrc files when information from them i s required (lazy load). Tested with regression tests.

Changed in lightdm (Ubuntu Trusty):
importance: Undecided → High
Changed in lightdm (Ubuntu Utopic):
importance: Undecided → High
Changed in lightdm:
importance: Undecided → High
status: New → Triaged
Changed in lightdm (Ubuntu Trusty):
status: New → Triaged
Changed in lightdm (Ubuntu Utopic):
status: New → Triaged
Changed in lightdm:
assignee: nobody → Robert Ancell (robert-ancell)
Changed in lightdm (Ubuntu Trusty):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in lightdm (Ubuntu Utopic):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

This has occurred since LightDM 1.9.8

Dariusz Gadomski (dgadomski) wrote :

Hello Robert,

Thank you for working on this issue. I want you to know that we have a customer waiting for a fix to this bug.

Please let me know if I could provide you help in development and/or testing.

Regards,
Dariusz

Robert Ancell (robert-ancell) wrote :

The linked branch (lp:~robert-ancell/lightdm/dont-scan-all-users) should fix the problem. I'm tidying it up with tests and then will backport to 1.10.

Changed in lightdm:
status: Triaged → Fix Committed
milestone: none → 1.12.0
Changed in lightdm:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.12.0-0ubuntu2

---------------
lightdm (1.12.0-0ubuntu2) utopic; urgency=medium

  * Restore 1.11.9-0ubuntu2, it was reverted by error in the previous upload
 -- Sebastien Bacher <email address hidden> Tue, 30 Sep 2014 11:25:09 +0200

Changed in lightdm (Ubuntu Utopic):
status: Triaged → Fix Released
description: updated
Changed in lightdm (Ubuntu Trusty):
status: Triaged → In Progress
Yves-Alexis Perez (corsac) wrote :

It seems that this change actually broke .dmrc files on Debian.

I'm currently investigating, but it seems that the files (~/.dmrc and /var/cache/lightdm/dmrc/user.dmrc) are not updated anymore with the selected session.

Yves-Alexis Perez (corsac) wrote :

Actually sorry, that's wrong, it's unrelated, it's due to our own patch setting USERS_DIR to /var/lib/lightdm (I don't really understand why, but that's off-topic for this bug).

Hello Robert, or anyone else affected,

Accepted lighdm into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lighdm/1.10.3-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Mathew Hodson (mhodson) on 2014-11-15
Changed in lightdm (Ubuntu Trusty):
status: In Progress → Fix Committed
Robert Ancell (robert-ancell) wrote :

Confirmed fixed in 1.10.3-0ubuntu2

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.10.3-0ubuntu2

---------------
lightdm (1.10.3-0ubuntu2) trusty; urgency=medium

  * Refresh patches
 -- Robert Ancell <email address hidden> Fri, 10 Oct 2014 21:24:51 +1300

Changed in lightdm (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers