lightdm background remains black when valid path given in config file.

Reported by Milan Mikus on 2012-12-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
Light Display Manager
Undecided
Unassigned

Bug Description

After uptadete of my arch instalation I am havin trouble setting background of lightdm. I use lightdm-gtk-greeter package from ARCH AUR repository. After I have upgraded to newest version greeter is started having trouble loading file specicied in lightdm-gtk-greeter.conf . Background remains black althought the file is accesibe and rights should be correct (tested on multiple locations and files). When I change path to color the color is displaied fine.

Xristh (prflr) wrote :

Same here
Alongside This is a consolekit free-only systemd machine 1.4.0 and with liblightdm-qt (qt) at build time

the flags for ./configure --prefix=/usr --sysconfdir=/etc --disable-static --libexecdir=/usr/lib/lightdm --localstatedir=/var --with-greeter-user=lightdm --with-greeter-session=lightdm-gtk-greeter --disable-tests

and in my case using Xfce4 4.10

NO patch applied

i (iiiiii-deactivatedaccount) wrote :

Try removing the alpha channel from the image you want in the background (you can do that in GIMP).

You can check that the image has an alpha channel if you run
file <image>

The one with an alpha channel will show 'RGBA' and after you remove the alpha channel it will show 'RGB'.

i (iiiiii-deactivatedaccount) wrote :

That's still a bug, though.

Xristh (prflr) wrote :

I can reproduce this only if consolekit is NOT installed (aka a pure Systemd)
build without consolekit intalled or remove it beffore the build and run lightdm (without consolekit) trigger this bug
and intall and run lightdm with consolekit solve the problem in MY case

I think that the lack of systemd-logind or anythink related to consolekit 'magic' and the absense of it is the problem

delboy711 (derek-jennings) wrote :

I am seeing the same thing on my Mageia 3 install.
For me it works if the background image is a .png file , but not with a .jpg file.

delboy711 (derek-jennings) wrote :

This patch works for me

--- lightdm/src/lightdm-gtk-greeter.c 2012-08-30 18:39:09.000000000 +0100
+++ lightdm/src/lightdm-gtk-greeter.c 2012-12-20 18:30:03.216355000 +0000
@@ -801,6 +801,7 @@
            g_warning ("Failed to load background: %s", error->message);
         g_clear_error (&error);
         g_free (path);
+ background_pixbuf=gdk_pixbuf_add_alpha (background_pixbuf,FALSE,255,255,255);
     }
     else
         g_debug ("Using background color %s", value);

If the background file does not have an alpha channel, then it will add one.

Same here too.

Lightdm just won't display any background image on my machine (Xubuntu 12.10 x86_64, not a fresh installation). However, setting a background color does work.

lightdm_1.4.0-0ubuntu2
lightdm-gtk-greeter_1.3.1-0ubuntu1

Changed in lightdm:
status: New → Incomplete

Adding an alpha channel does indeed work.

$ convert <input> -alpha on <output>

Simon Steinbeiß (ochosi) wrote :

Fix is in trunk now.

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Changed in lightdm-gtk-greeter:
milestone: none → 1.5.1
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers