[patch] fixes 'Cancel' button press action

Reported by Balwinder S Dheeman on 2012-04-28
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned

Bug Description

On pressing the 'Cancel' button it does not return to users list or user name prompt.

A patch included herewith fixes the problem; please review and merge the changes as soon as possible.

Related branches

Balwinder S Dheeman (bdheeman) wrote :
Lauri Tirkkonen (lotheac) wrote :

Apparently the other bug (#974610), which has more comments, was made duplicate. Quoting comment #3 by brenz there:

>It appears that hitting "cancel" at any point of the login, even before entering a username, will make it impossible to log into the system. "Cancel" does not return you to the Username prompt, and you cannot get focus back to where you enter passwords.

I think that makes this bug pretty severe. Could this get merged soon?

description: updated
Benjamin Long (benjamin-long) wrote :

I've compiled an updated version for my workstations and pushed it out via my custom repository. This patch fixes the issue. Please get this into the package as an update for 12.04 . It's a major bug that needs to be fixed.

Lionel Le Folgoc (mrpouit) wrote :

Thanks, committed (with a slight change to clear the error label).

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
Duane Farnsworth (dkfarns) wrote :

This bug also affects me. However, I tried both the patch and the new release and they both caused my machine to crash before getting to the login in screen. A couple of times I saw an error message that said something like mountall: disconnected from plymouth. I eventually figured out that I could switch to a command line tty when this happened and uninstall the new version.

Balwinder S Dheeman (bdheeman) wrote :

@dkfarns, please check your log files i.e. /var/log/lightdm/* and provide more information like your distro, versions of relevant libs.

Duane Farnsworth (dkfarns) wrote :

@bdheeman, thanks for responding.

I was able to reproduce the problem just a moment ago. I have attached a copy of /var/logs/lightdm/lightdm.log in the state it was in immediately after I was unable to get to a login screen. Perhaps the following line from the log file is the problem?

0.60s] DEBUG: Failed to load session file /usr/share/xgreeters/lightdm-gtk-greeter.desktop: No such file or directory

I just checked; it would seem that file is present on my system though.

I am not sure which libraries are relevant, so I will wait and see if you need to know more. I am happy to supply any needed information though.

Balwinder S Dheeman (bdheeman) wrote :

@dkfarns, Please do check the permissions of all the directories /usr/share/xgreeters should be 755, file lightdm-gtk-greeter.desktop is 644 and the /usr/sbin/lightdm-gtk-greeter is 755.

OTOH, symlinking /usr/share/xgreeters/lightdm-gtk-greeter.desktop to /usr/share/xgreeters/default.desktop can also be helpful.

Duane Farnsworth (dkfarns) wrote :

@bdheeman, thanks for looking into this.

Okay, I feel kind of dumb. I guess when I checked on the location of lightdm-gtk-greeter.desktop I had already reinstalled from the repository.

In fact, when I install from source all directories that were originally under /usr/share are now under /usr/local/share. On the off chance it is relevant, I use checkinstall when installing from source.

I guess the problem is pretty clear. I am not sure what the best solution is.

Matthias Schiffer (neoraider) wrote :

Okay, this is fixed for over a month now. So why isn't the new version yet in the Ubuntu repos?

Lionel Le Folgoc (mrpouit) wrote :

Because I haven't had the time to update the package?

Benjamin Long (benjamin-long) wrote :

If anyone wants a patched amd64 version, it's here:
http://packages.seseco.com/ubuntu/pool/main/l/lightdm-gtk-greeter/lightdm-gtk-greeter_1.1.5-0ubuntu2_amd64.deb
We've been using it here for almost 2 months without any issues. Sorry, I don't have a 32bit version.

Lionel, would it be possible for you to create an updated version greater then mine when you get time to? That way my workstations will pull it automaticlly. :)

Lionel Le Folgoc (mrpouit) wrote :

Unfortunately, the version number for the fix in precise (when I upload) should be 1.1.5-0ubuntu1.1 (quantal already has 1.1.6-0ubuntu1, which is greater)

fernando (fernandof-h) wrote :

Will this be fixed anytime soon?

I use the quantal package (1.1.6-0ubuntu1) as a workaround, it works great with precise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers