X cursor often not shown

Reported by Yves-Alexis Perez on 2011-07-31
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Low
Unassigned
lightdm (Arch Linux)
New
Undecided
Unassigned
lightdm (Debian)
Fix Released
Unknown
lightdm (Ubuntu)
Low
Unassigned

Bug Description

It seems that, since 0.9.2, cursor is often not shown in GTK+ greeter. This is a regression from 0.9.0, afaict, but it might be a GTK+ 3.0 issue too.

Changed in lightdm (Debian):
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I can't confirm that one though, does it happen while you type? or just while doing nothing?

Changed in lightdm (Ubuntu):
importance: Undecided → Low
status: New → Triaged
kraxadmin (kraxadmin) wrote :

I have the same problem with lightdm and I am using archlinux
the bug report resides in:
https://bugs.archlinux.org/task/25596

Robert Ancell (robert-ancell) wrote :

Is this the issue where you can enter text but the blinking cursor does not show? It looks like the same issue in bug 810805.

Yves-Alexis Perez (corsac) wrote :

Any indication what would be the GTK+ version fixing the issue? I'm running 3.0.12 and still have no cursor, for indication.

jeff crissman (jccrissman) wrote :

It is the mouse cursor that does not show, most of the time.
If I move the mouse the cursor will be there once I login, but not visible until then.
The buttons are useless with this happening.
The keyboard cursor works

jeff crissman <email address hidden> writes:

> It is the mouse cursor that does not show, most of the time.
> If I move the mouse the cursor will be there once I login, but not
> visible until then.
>
Yes, I can confirm that -- the problem is strictly confined to lightdm
itself; once the X session has been started, everything works as usual
(X mouse cursor and all).

> The buttons are useless with this happening.
>
Indeed -- I thought this might be a seperate bug, but it indeed may be
connected. When I type a wrong username, I can't click "cancel" (well,
maybe I could, but without a cursor, its very hard to hit the button to
actually try). But worse, even using the keyboard, one can't cancel and
retry with another username -- I tried hitting "tab" to focus the cancel
button, and activate it using "return", but it didn't have any effect.
I'm not sure if "tab" actually changed the focus, but I could try again
(please tell me if you would wish for me to do so). Should this issue
(cancel not working) be filed as a separate issue, or do you think it
might be a side-effect of this bug, and prefer deal with in context of
this bug?

> The keyboard cursor works
>
Yes, entering text into the login box works, keyboard cursor and all,
except if you make a mistake at the username and hit enter, then you are
f*cked as described above -- AFAICS, once you are in this state (having
entered a non-existing username), the only way to rectify the situation
is restarting lightdm or rebooting.

Regards, Rotty
--
Andreas Rottmann -- <http://rotty.yi.org/>

Gour (gour) wrote :

Hi!

Installed Arch on my new netbook yesterday and had same problem as explained in #2.

Sincerely,
Gour

Robert Ancell (robert-ancell) wrote :

Is this confirmed in recent versions?

Changed in lightdm:
importance: Undecided → Low
status: New → Triaged
Hwoarang (hwoarang) wrote :

Yes, this is reproducible in 0.9.7

I seem to have run into this with lightdm 1.0.1-0ubuntu6 (oneiric 64-bit). Doing some poking around I note that restarting lightdm from a terminal (i.e /etc/init.d/lightdm restart or similar) makes the cursor reappear properly again. Further experimentation seems to point to some interaction with the grub splash screen - removing splash from GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub results in the cursor showing up in lightdm every time.

jeff crissman (jccrissman) wrote :

I have GRUB_CMDLINE_LINUX_DEFAULT="quiet"
With lightdm 0.9.7 I have no cursor most of the time

On Mon, Oct 17, 2011 at 3:06 PM, Mark Kirkwood <email address hidden>wrote:

> I seem to have run into this with lightdm 1.0.1-0ubuntu6 (oneiric
> 64-bit). Doing some poking around I note that restarting lightdm from a
> terminal (i.e /etc/init.d/lightdm restart or similar) makes the cursor
> reappear properly again. Further experimentation seems to point to some
> interaction with the grub splash screen - removing splash from
> GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub results in the cursor
> showing up in lightdm every time.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/818852
>
> Title:
> X cursor often not shown
>
> Status in Light Display Manager:
> Triaged
> Status in “lightdm” package in Ubuntu:
> Triaged
> Status in “lightdm” package in Arch Linux:
> New
> Status in “lightdm” package in Debian:
> Confirmed
>
> Bug description:
> It seems that, since 0.9.2, cursor is often not shown in GTK+ greeter.
> This is a regression from 0.9.0, afaict, but it might be a GTK+ 3.0
> issue too.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lightdm/+bug/818852/+subscriptions
>

Hmm, interesting - the trick seems to help with lightdm 1.0.1 (see bug 876520). However over there both of us are running radeon gpus, so there might be another factor in play too. I did wonder if it might be interesting to switch to gdm and see if the mouse cursor is still missing then (would single out the Xorg driver as the culprit).

affects: lightdm → lightdm-gtk-greeter
Changed in lightdm (Debian):
status: Confirmed → Fix Released
Ephraim (thilo) wrote :

Hey,

I see that bug in lightdm 1.1.9 and lightdm-gtk-greeter 1.1.4 on an arm board. Of course there is no grub as it is booted via uboot.
So what exactly was the fix for this? Or what exactly was the problem so I can look for similar problems here?

Ciao
Ephraim

Sean Davis (smd-seandavis) wrote :

Please test this again. With the latest changes to the greeter, GTK, and X this problem should be resolved.

Yves-Alexis Perez (corsac) wrote :

Looks that this one is fixed indeed.

Changed in lightdm-gtk-greeter:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.