Greeter does not remember last session and language per user

Bug #1282139 reported by Maxime Gauduin on 2014-02-19
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
High
Gunnar Hjalmarsson

Bug Description

Hi,

I'm packaging LightDM with the GTK greeter on Arch Linux. I seem to have an issue with the GTK greeter: it won't select the last session used by a particular user when that user is selected in the list. It only remembers the last session used by any user and selects that one by default. The icon in the top bar does not change either when going through users with different last sessions. Reproduced with lightdm 1.8.7 and 1.9.7, and the GTK greeter 1.8.1 as well as latest bzr.

I have tried the Pantheon greeter which works as intended, and I should also mention that ~/.dmrc is correctly modified by LightDM, as well as the AccountsService user file, so permission problems are ruled out.

I never noticed that before since I don't usually have more than one user on my machines, but I am told it has worked correctly in the past.

Can you reproduce this or is it specific to Arch?

(BTW, this is unrelated to the bug report, but could you ship a symbolic 'e' icon for the 'pantheon' session from the elementary guys?)

Maxime Gauduin (alucryd) on 2014-02-19
description: updated
Simon Steinbeiß (ochosi) wrote :

Frankly I don't have so many sessions so I never noticed anything there. We should investigate (and try to fix) that though if it's really not working. There's definitely code in the greeter that *should* handle that...

As to your other suggestion, I added a session-badge for elementary/pantheon. Please let me know if it doesn't work as expected.

Maxime Gauduin (alucryd) wrote :

Thanks for the quick answer. I was in the same boat as you are and never noticed it either.

The pantheon badge is working and looking good, thank you!

Gunnar Hjalmarsson (gunnarhj) wrote :

A similar issue has been reported in bug #1283347.

summary: - Greeter does not remember last session per user
+ Greeter does not remember last session and language per user
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your quick fix, Thaddäus!

I really think this should make it to the Ubuntu archive before Beta 1, so I submitted a merge proposal against the Ubuntu branch.

Changed in lightdm-gtk-greeter (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
milestone: none → ubuntu-14.04-beta-1
status: Confirmed → In Progress
Maxime Gauduin (alucryd) wrote :

Thx for the quick reaction guys, fix works like a charm!

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
Sean Davis (bluesabre) on 2014-03-02
Changed in lightdm-gtk-greeter:
milestone: none → 1.8.2
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm-gtk-greeter - 1.8.1-1ubuntu2

---------------
lightdm-gtk-greeter (1.8.1-1ubuntu2) trusty; urgency=medium

  [ Thaddäus Tintenfisch ]
  * debian/patches/update-session-language.patch:
    - Always update preselected session and language when another
      user is selected (LP: #1282139).
 -- Gunnar Hjalmarsson <email address hidden> Sun, 02 Mar 2014 18:05:00 +0100

Changed in lightdm-gtk-greeter (Ubuntu):
status: In Progress → Fix Released

This bug is still present in greeter 2.0.0 (it shows in a fresh Xubuntu 15.04 install) when the greeter is configured as follows:

[SeatDefaults]
greeter-session=lightdm-gtk-greeter
allow-guest=false
greeter-hide-users=true

I.e., if the list of users is hidden, and the user is requested to type their user name, the greeter does not select the user's last session type, but rather it uses the last session type used by any user.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Pedro: This bug report is closed. Can you please file a new bug report about hidden users? (I assume that would be a wishlist kind of bug.)

imran (imran-shabhai) wrote :

Hi,

I am using ubuntu 14.04 in our environment.Also install lightdm-gtk-greeter 1.8.5 version.My user has getting last user session save and they need to type only password on login screen.But only in one machine user unable to get its username, every time when he start his system he need to type username and password.We are facing this issue from last 2 month.I have tried all setting which posted on internet but it failed.Also system has same hardware configuration and setting is also same in all machine.

Kindly provide any solution.

Gunnar Hjalmarsson (gunnarhj) wrote :

@imran: This is a bug report (closed since long), and It's not obvious to me that you are facing a bug. I'd suggest that you seek help at e.g. http://askubuntu.com/ to start with.

imran (imran-shabhai) wrote :

Hi
Gunnar if this bus was closed,then why i am facing this issue.?

Kindly provide any system level setting which resolved this.

imran (imran-shabhai) wrote :

Hi,

I am also facing problem in ubuntu 14.04 that firefox use too much memory in system.When initially i am starting system and just open 1 to 2 and it takes 400 to 500 MB ram and gradually increase upto 1.5 to 2GB.After my system gets hang.

Kindly provide me suitable solution.I am facing this issue from last 4 month.

imran (imran-shabhai) wrote :

I am waiting for reply.

Kindly provide us solution asap.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers