Password entry box is not defined as invisible in glade definition

Bug #1264771 reported by Ash on 2013-12-29
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Simon Steinbeiß

Bug Description

There is a mistake in the file.
There should be a property defined as <visibility>False</visibility>. This causes the entry box to be treated as a password field. Simply setting invisible_char and invisibale_char_set properties are not enough to cause the entry box to behave as an obscured password field.

Ash (flubba86) wrote :
Simon Steinbeiß (ochosi) wrote :

While I couldn't reproduce your issue, I don't think adding that additional definition can hurt. Fixed in trunk, rev 168.

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
assignee: nobody → Simon Steinbeiß (ochosi)
Ash (flubba86) wrote :

Thanks Simon,

I am still trying to work out why this was only an issue for me, and did not seem to affect anybody else.

It had only started happening on my system about 3 months ago, Im guessing it was a libgtk3 update which caused the change in behaviour, but I searched the gtk+ git commits back through the last year, and also checked the Debian libgtk3 changelog and there is no mention of changing or fixing the entry box password behaviour.

On this GTK3 Docs page ( it clearly states that the only way for an entry box to be displayed as a password field is to have the Visibilty attribute set to False, which was not the case lightdm-gtk-greeter. It actually should never have been displaying correctly obscured at all.

I thought maybe it was something glade related, but there is nothing changed in the entrybox params parsing there either.
My last thought that it was a change in the way that Gtk.Builder constructs the entrybox, but as far as I can thell there is no change there either.

So I am at a loss, but is is working now. Im sure the issue would have cropped up for Ubuntu and Mint users in due time.

Simon Steinbeiß (ochosi) wrote :

I have to agree, it's somewhat of an odd issue.

Well there's more than one way to set an entry to be a password field, and maybe that's also part of the problem (although I don't have an explanation for it).

Anyway, thank YOU for supplying the patch for that bug!

Sean Davis (bluesabre) on 2014-01-08
Changed in lightdm-gtk-greeter:
milestone: none → 1.7.1
Sean Davis (bluesabre) on 2014-01-21
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
Till W. (tillw.) wrote :

Just want to add that I am also affected by this bug. It is reproducible for me. After a fresh reboot, the first login attempt always has a password field without "obfuscation". When I enter a wrong password (or click "log in" leaving the password field empty), I get a correctly "obfuscated" password field on the consecutive login attempts.

I use finger print based authentication (fprint) as well. Maybe this is related to the problem somehow. (Enabled fprint/pam causes an extra message displayed at the login screen right below the password field.)

Simon Steinbeiß (ochosi) wrote :

@Till W.: We need to know what version of the greeter you're using.

Till W. (tillw.) wrote :

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

$ dpkg -l lightdm-gtk-greeter
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
ii lightdm-gtk-greeter 1.6.1-0ubuntu1 amd64 LightDM GTK+ Greeter

Simon Steinbeiß (ochosi) wrote :

As you can see above, this bug was fixed in lightdm-gtk-greeter 1.7.1. Since you're using an older version, it's not surprising you're still seeing it.

Till W. (tillw.) wrote :

Thank you for pointing this out, Simon. I have now upgraded to version 1.8.3-0ubuntu1 (taken from Ubuntu trusty) and can no longer reproduce the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions