switch-to-greeter does not set lock hint

Bug #1264563 reported by Thaddaeus Tintenfisch on 2013-12-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Simon Steinbeiß
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

light-locker is able to lock the current user session automatically on suspend/hibernation and it works as expected. However, after resuming the system lightdm-gtk-greeter displays the "Log In" button instead of the "Unlock" one and does not highlight the current logged in user. This does not seem to affect the login/unlock process and was only tested with hibernation.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: light-locker 1.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.12.7-0ubuntu3
Architecture: i386
CurrentDesktop: XFCE
Date: Fri Dec 27 19:15:50 2013
InstallationDate: Installed on 2013-09-21 (97 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130920)
SourcePackage: light-locker
UpgradeStatus: Upgraded to trusty on 2013-11-08 (49 days ago)

Manually triggering light-locker via light-locker-command works fine (switch to vt8 happens before the system goes to sleep and not afterwards when resuming it).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker (Ubuntu):
status: New → Confirmed

This can be also reproduced by running "dm-tool switch-to-greeter", so it is in fact an issue in the lightdm-gtk-greeter code or in lightdm. The greeter queries lightdm several times to get the status of the lock hint, which is not set when switching to the greeter (SwitchToGreeter).

The following patch for lightdm-gtk-greeter removes these calls:

http://pastebin.ca/2520577

However, setting the lock hint might be the better and cleaner solution, because the user session actually gets locked in this scenario.

summary: - lightdm not aware of session lock
+ switch-to-greeter does not set lock hint
affects: light-locker (Ubuntu) → lightdm (Ubuntu)
Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
Robert Ancell (robert-ancell) wrote :

"switch-to-greeter" does not set the lock hint because it is not the same as "lock" which does set the hint.

You should use "switch-to-greeter" when you want to switch to another session. The greeter should display in an appropriate way for the user to be able to select any other user account and log into a new session. As a side-effect, the existing session becomes locked but this should not be visible to the user.

You should use "lock" when you want to make the computer inaccessible without a password. The greeter should detect the lock hint and display the greeter in an appropriate way so it is easy for the returning user to enter their password and return to their session. The greeter can decide if it will also allow switching to another session.

Robert Ancell (robert-ancell) wrote :

Historical note - "switch-to-greeter" existed before "lock". So it really should be called "switch-user" or "switch-to-greeter-and-show-in-configuration-shown-on-first-boot".

Simon Steinbeiß (ochosi) wrote :

Thanks for your clarification, Robert!
I will try to fix the behavior of the greeter accordingly.

Simon Steinbeiß (ochosi) wrote :

I've tested and pushed the patch/fix to bzr.

Changed in lightdm-gtk-greeter:
status: New → Fix Committed
assignee: nobody → Simon Steinbeiß (ochosi)
Sean Davis (bluesabre) on 2014-01-08
Changed in lightdm-gtk-greeter:
milestone: none → 1.7.1
Sean Davis (bluesabre) on 2014-01-21
Changed in lightdm-gtk-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers