Lists lack zebra-striping

Bug #945430 reported by Jonathan Meek on 2012-03-03
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
Ubuntu theme
Undecided
Andres G. Aragoneses
light-themes
Fix Released
Undecided
Adolfo Jayme
light-themes (Ubuntu)
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Low
Unassigned

Bug Description

We had it before and was taken out in Precise. We need this back. It makes apps like Rhythmbox much easier to handle.

Related branches

Adolfo Jayme (fitojb) wrote :

Zebra-stripping? We had such a thing? Could you post a screenshot?

Changed in light-themes:
status: New → Incomplete
Jonathan Meek (shroudedcloud) wrote :

Please check out this screenshot and compare it to the current rhythmbox: http://cdn.omgubuntu.co.uk/wp-content/uploads/2011/11/Screen-Shot-2011-11-02-at-23.36.32.png

As you can see, the tracklist at the bottom alternates coloring on every other track to break up the monotony. Current 12.04 Light Themes lack this feature.

Cullen Maglothin (cullendm) wrote :

Hoping to get this fixed as well, the new theme really bugs me in this respect. Without the striping, there is no way to tell the difference between entries line by line, making it easy to confuse information.

Changed in light-themes:
status: Incomplete → New
Adolfo Jayme (fitojb) wrote :

OK, I get it now :)

Changed in light-themes:
status: New → Confirmed
Adolfo Jayme (fitojb) wrote :

Hi, do you know it this zebra-stripping was present in Rhythmbox while using Adwaita? I suspect this feature was removed from Rhythmbox itself.

tags: added: regression-release
Jonathan Meek (shroudedcloud) wrote :

As near as I can tell, Rhythmbox did not remove it. Using the elementary theme with Beatbox and Rhythmbox has zebra-stripping present. It is not present using Ambiance or Radiance.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2012-03-16
Changed in light-themes:
status: Confirmed → In Progress
assignee: nobody → Fitoschido (fitoschido)
Adolfo Jayme (fitojb) wrote :
Adolfo Jayme (fitojb) on 2012-03-30
Changed in light-themes:
status: In Progress → Fix Committed
Changed in light-themes:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) wrote :

light-themes (0.1.9-0ubuntu1) precise; urgency=low

  * New upstream snapshot
    - unity-greeter: fixes for buttons/entries
    - Fixes native scrollbars
    - GtkTreeview tweaks
  * debian/control
    - bump standards version to 3.9.3
 -- Ken VanDine <email address hidden> Fri, 06 Apr 2012 11:14:33 -0400

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Released
Andres G. Aragoneses (knocte) wrote :

This is broken again, can someone reopen the bug? (Sorry, either I have no permission to do it, or I don't know how to do it because I'm new to launchpad)

Andrea Cimitan, I subscribed you to this bug because you committed the fix in http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk/revision/220 , however you broke it again in this other change some months later: http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk/revision/234.

What's the rationale of the latter change to modify the Treeview properties? Maybe the treeview part was not intended?
Thanks

Adolfo Jayme (fitojb) wrote :

I believe the zebra effect caused trouble with progress bars in lists, but Andrea should know better :-)

Changed in ubuntu-themes (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Andres G. Aragoneses (knocte) wrote :

I see. Well, Andrea, can you give us some more extra info? (Screenshots of the trouble with progressbars would be grand.) I guess you're on holiday so I won't ping you too much in August :) Thanks

Andres G. Aragoneses (knocte) wrote :

I finally had some time to work on this.

The best testcase to test zebra stiping with the patch that Andrea initially committed (http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk/revision/220) is this.

(Important line to highlight here is: `self.treeview.set_rules_hint(True)`)

Andres G. Aragoneses (knocte) wrote :

The problem comes with treeviews with progress bars. Andrea's r220 patch introduced a visualization glitch for this case.

Attached is a testcase for treeviews with progressbars.

Andres G. Aragoneses (knocte) wrote :

And this is a screenshot of the visual glitch that I explain in previous comment, which is the reason (I guess) for Andrea committing a patch later (http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk/revision/234) that would undo the zebra-striping completely.

Andres G. Aragoneses (knocte) wrote :

And now I have proposed a proper patch that doesn't introduce this visual glitch: https://code.launchpad.net/~knocte/ubuntu-themes/bring-back-zebra-striping/+merge/200429

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-themes at revision 334, scheduled for release in ubuntu-themes, milestone Unknown

Changed in ubuntu-themes:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 13.04+14.04.20140117.1-0ubuntu1

---------------
ubuntu-themes (13.04+14.04.20140117.1-0ubuntu1) trusty; urgency=low

  [ Andrés G. Aragoneses ]
  * Ambiance: support zebra striping for treeviews This is a rework of
    Andrea's patch (committed in r220:
    http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-
    themes/trunk/revision/220) that doesn't introduce a visual glitch on
    progress bars inside treeviews (because of this visual glitch, the
    r220 patch was reverted in r234:
    http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-
    themes/trunk/revision/234 and bug LP#945430 had to be reopened), and
    therefore allows us to have a theme that implements zebra striping
    treeviews when applications choose to use them via
    `self.treeview.set_rules_hint(True)` API. . (LP: #945430)

  [ Lars Uebernickel ]
  * Fix some theming issues in gedit (file browser toolbar and context
    menu font). (LP: #1242984)
  * gedit: make search occurences label readable.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 335
 -- Ubuntu daily release <email address hidden> Fri, 17 Jan 2014 19:27:58 +0000

Changed in ubuntu-themes (Ubuntu):
status: Triaged → Fix Released
Adolfo Jayme (fitojb) wrote :

Thank you, Andrés!

Changed in ubuntu-themes:
assignee: nobody → Andres G. Aragoneses (knocte)
status: Fix Committed → Fix Released
Binhao Qian (gonwan) wrote :

The zebra-striping is still not working in 14.04(Trusty). The patch in comment #16 does not really fix the bug. Just managed to get it work after refering to the original patch. And the visual glitch on progress bars do not occur.

Andres G. Aragoneses (knocte) wrote :

Binhao is right with the fact that this is broken again in Trusty (my fix went at the 13.04/13.10 times, and for those distros it worked, but I guess something got broken with the gtk that comes with trusty... :(

I would be really surprised if your last patch fixes it, because a GtkProgressBar widget *should* have a .progressbar class already.

TomasHnyk (sup) wrote :

Well, it fixes it for me ( i manually edited /usr/share/themes/Ambiance/gtk-3.0/gtk-widgets.css and changed theme and it started to work).

TomasHnyk (sup) wrote :

This still concerns 15.04 the fix in comment #20 fixes this, could it plese be included?

TomasHnyk (sup) wrote :

Hm, I created a new bug lacking priviledges to reopen this one and added a merge proposal with patch from #20 https://bugs.launchpad.net/ubuntu-themes/+bug/1451178

Adolfo Jayme (fitojb) on 2015-05-04
Changed in ubuntu-themes (Ubuntu):
status: Fix Released → Triaged

The attachment "zebra.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
TomasHnyk (sup) wrote :

Any news of this? This is still broken:-(.

TomasHnyk (sup) wrote :

And the patch no longer works on 16.04.

TomasHnyk (sup) wrote :

The functionality got removed in 3.18 but hopefully it will be added back: https://bugzilla.gnome.org/show_bug.cgi?id=757495

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gtk:
status: Confirmed → Expired
TomasHnyk (sup) wrote :

The upstream bug moved to https://gitlab.gnome.org/GNOME/gtk/issues/581 (Launchpad does not seem to know about gitlab).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.