Cannot open ~LOCK~ file with my password

Bug #1313049 reported by Bhaveek Desai on 2014-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lifeograph
Undecided
Unassigned

Bug Description

Lifeograph crashed & when I tried to reopen my encrypted diary, it said there's a ~LOCK~ file as previous session didn't end. All my unsaved changes being in that ~LOCK~ file, I tried to open that in Lifeograph. When it asked for the diary password, I entered my password for the original diary but it didn't work.

How do I retrieve the unsaved changes? The file is in front of me with unsaved data but I just can't open it.

Original password should have worked. Crash may have happened during
writing of the LOCK file. Did you compare the sizes of the two files?

Bhaveek Desai (bhaveekdesai) wrote :

Yes indeed. The lock file is larger than the original file.

Ahmet Öztürk (dmxe) wrote :

What is your Lifeograph version? Does Lifeograph provide any helpful information when refusing the password. Commanline output may also help.

Bhaveek Desai (bhaveekdesai) wrote :

I am using Lifeograph v 1.0.1-1
When I run the application from terminal, gtk box pops up for password. And when I enter the password, the incoorect password message is displayed in the box. There's no output on the terminal.

Unfortunately, that lock file seems to be corrupt. I cannot debug this bug
as I am unable to duplicate it. If you can get a dummy lock file with the
same problem and then send it here, it might help uncover the nature of the
problem and even find a way of recovery.

Ahmet Öztürk (dmxe) on 2014-07-19
Changed in lifeograph:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers