Lifeograph digital diary

Small problems with window sizing in Lifeograph 0.8.1

Reported by SciYY on 2012-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lifeograph
Low
Unassigned

Bug Description

Hi,

I noticed the following problems with window size in 0.8.1 version:

1) It seems that program saves splitters position only approximately. Maybe it depends on concrete settings. Splitter that separates tag area and editing area generally stays on its place, but splitter that separates the list of entries sometimes moves several pixels right (when program starts again). So 'Log out' button tends to hide beyond right end of the window. Maybe it is connected to the window state: normal or maximized. I'm working with maximized the window, but program always starts in normal mode next time. So it saves window size, but not state.

2) Second occurs stably in the runtime. When you have a lot of long multi-line tags (e. g. 5-6) added to your entry, window can increase its width unexpectedly when this entry displays. Window width is increasing on several tens of pixels (right window side hides beyond the screen end). It always occur when all tags arrange to one line. So you can slowly move right splitter to the right and got increasing of the width when tags form one line. Moving splitter left after that gets window size normal (when tags arrange in two lines).

These problems are not very annoying. But just for your info.

Thank you for your program!

Ahmet Öztürk (dmxe) wrote :

Thanks for the report.

The version you use is quite old i.e. superseded by several releases. The root cause of all of your problems but one (see below), I believe, is the problematic entry tag list -a GtkIconView. I worked on this one to the best of my abilities but failed to tame it. So in the current version (0.11) I end up replacing it by a custom widget implementation. Could you, please, try this newer version when it is released, and see if your problems persist?

As to the not saved maximized state, you are right. This, I did not consider necessary. But, I have observed quite a few users preferring maximized mode, so, I will add this to 0.11 final.

Changed in lifeograph:
importance: Undecided → Low
SciYY (yyakhno) wrote :

I checked new 0.11.0 version for these bugs. It seems that at least second of described problems (with tags) completely disappeared. Now window size is not changing during tags rearrangement. By the way: nice graphic changes!

Regarding the problem with window state, I didn't manage to check it completely. I launched Lifeograph on Ubuntu 12.04 under Unity - it always appears maximized here (maybe it is a feature of Unity, I don't know). But it is admissible for me anyway.

It is a quite pity that I didn't manage to install new version on Ubuntu 10.04 on my main computer (because of old GTK version). I really hate new versions of Ubuntu, but it is the other problem indeed :-)

Thank you for your support and your work. Have nice holidays!

Ahmet Öztürk (dmxe) on 2013-06-02
Changed in lifeograph:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers