Zeitgeist Client Library

Segfault if Zeitgeist is not installed

Reported by Alberto Aldegheri on 2011-05-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Synapse
Undecided
Michal Hruby
libzeitgeist
Undecided
Unassigned

Bug Description

I installed synapse on Linux Mint 10 LXDE. When I try to start synapse in the terminal, I get the following error:

$ synapse

** (synapse:3269): WARNING **: desktop-file-service.vala:267: Desktop session type is not recognized, assuming GNOME.
[17:25:46.234066 Info] [UILauncher] Binding activation to <Control>space
(synapse:3269): GtkHotkey-DEBUG: Listener Type: GtkHotkeyX11Listener
[17:25:46.271924 Info] [GuiSynapseWindow] Screen is NOT composited.
Segmentation fault

What can I do to get synapse to play nicely with the LXDE desktop?

Starting program: /usr/bin/synapse
[Thread debugging using libthread_db enabled]

** (synapse:3575): WARNING **: desktop-file-service.vala:267: Desktop session type is not recognized, assuming GNOME.
[New Thread 0xb7ddcb70 (LWP 3578)]
[19:24:19.882682 Info] [UILauncher] Binding activation to <Control>space
(synapse:3575): GtkHotkey-DEBUG: Listener Type: GtkHotkeyX11Listener
[19:24:19.920206 Info] [GuiSynapseWindow] Screen is NOT composited.

Program received signal SIGSEGV, Segmentation fault.
0x00b742c6 in ?? () from /usr/lib/libzeitgeist-1.0.so.0
#0 0x00b742c6 in ?? () from /usr/lib/libzeitgeist-1.0.so.0
#1 0x00b73014 in zeitgeist_data_source_registry_get_data_sources_finish ()
   from /usr/lib/libzeitgeist-1.0.so.0
#2 0x080a10b9 in synapse_zeitgeist_relevancy_backend_check_data_sources_co (
    data=0x8143840) at relevancy-backend-zg.c:307
#3 0x00b72ce8 in ?? () from /usr/lib/libzeitgeist-1.0.so.0
#4 0x00ad357f in g_simple_async_result_complete ()
   from /usr/lib/libgio-2.0.so.0
#5 0x00b805bc in ?? () from /usr/lib/libzeitgeist-1.0.so.0
#6 0x00ad357f in g_simple_async_result_complete ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libgio-2.0.so.0
#7 0x011d79c8 in ?? () from /usr/lib/libeggdbus-1.so.0
#8 0x005e5831 in ?? () from /lib/libdbus-1.so.3
#9 0x005d3976 in ?? () from /lib/libdbus-1.so.3
#10 0x005d6b82 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
#11 0x005af39d in ?? () from /usr/lib/libdbus-glib-1.so.2
#12 0x00c24855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#13 0x00c28668 in ?? () from /lib/libglib-2.0.so.0
#14 0x00c28ba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#15 0x003071d9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x08056c85 in synapse_ui_launcher_main (argv=0xbffff9c4, argv_length1=1)
    at synapse-main.c:760
#17 0x08056cc0 in main (argc=1, argv=0xbffff9c4) at synapse-main.c:789
(gdb)

Alberto Aldegheri (albyrock87) wrote :

I need the version of the packages related to:
synapse
libzeitgeist
zeitgeist

Changed in synapse-project:
status: New → Incomplete

How do I do this? I included all of the output available.

Alberto Aldegheri (albyrock87) wrote :

Look into the Package Manager Synaptics (the one you use to install software), and look at the version of the installed package :)

Download full text (3.7 KiB)

Sorry. Stupid question. Here is the info:

synapse~0.2.6~bzr433~maverick1
libzeitgeist-10.0-0
zeitgeist is not installed.

I installed synapse on my LM 10 LXDE system with:

$ sudo apt-get --no-install-recommends install synapse

The system is on my Zepto Znote V11a netbook. I installed synapse with no recommends on this system, because I experienced monitor flickering problems on my self built AMD powered desktop box. Those problems went away when I uninstalled (sudo apt-get remove --purge, sudo deborphan) everything related to synapse and then reinstalled synapse with no recommends. Information about the AMD system is here:

Samsung SyncMaster 930BF LCD monitor

$ lspci
00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:09.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port E)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller (rev 40)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:15.0 PCI bridge: ATI Technologies Inc Device 43a0
00:15.1 PCI bridge: ATI Technologies Inc Device 43a1
00:15.2 PCI bridge: ATI Technologies Inc Device 43a2
00:15.3 PCI bridge: ATI Technologies Inc Device 43a3
00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 220] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 03)
04:06.0 Multimedia controller: Philips Semiconductors SAA71...

Read more...

Alberto Aldegheri (albyrock87) wrote :

Ok, the problem is that Zeitgeist is required :)
So if you install zeitgeist, it should be fine!

Cheers. Synapse now works on my LM 10 LXDE system.

Julien Lavergne (gilir) wrote :

I though zg was not needed but only optional ? The zg plugin should not desactivated itself in this case ?

Alberto Aldegheri (albyrock87) wrote :

Julien, this is a special case:
- libzeitgeist => installed
- zeitgeist => not installed
And this is crazy, I think that the error is in libzeitgeist, not in Synapse..

But maybe I'm wrong.. I'm not 100% sure..

Michal Hruby (mhr3) wrote :

Looks like libzg bug, adding bug task.

Michal Hruby (mhr3) on 2011-06-06
Changed in synapse-project:
status: Incomplete → Confirmed
assignee: nobody → Michal Hruby (mhr3)
summary: - Segfault in Linux Mint 10 LXDE
+ Segfault if Zeitgeist is not installed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions