Nautilus quicklist should have the "Open a New Window" entry at the top of the list

Reported by John Lea on 2012-04-26
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
libunity
Low
Unassigned
libunity (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

The quicklist should be formatted as follows:

-----------------------
Open a new window
---------
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
[nautilus bookmark]
etc... (all nautilus bookmarks should be displayed)
---------
Home Folder
---------
Unlock from Launcher
Quit
-----------------------

Tags: udp Edit Tag help
John Lea (johnlea) on 2012-04-26
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
Changed in unity:
status: New → Triaged
Changed in ayatana-design:
status: New → Triaged
tags: added: udp
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → backlog
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Dmitry Shachnev (mitya57) wrote :

The quicklist is provided by Nautilus, so this bug has nothing to do with Unity.

affects: unity (Ubuntu) → nautilus (Ubuntu)
Changed in unity:
status: Triaged → Invalid

Another thing related to the quicklist is that the shortcuts shouldn't be alphabetically sorted, but the order should correspond to the order in the Places sidebar.
Right now, we are confronted with 3 different orders:
- Quicklist: everything alphabetically ("Computer" folders and bookmarks).
- Places sidebar: Bookmarks (sorted by the user), "Computer" shortcuts (fixed order: Home, then alphabetical order, then File System and Rubbish Bin), "Network".
- Bookmarks menu: "Computer folders" in no logical order, and then bookmarks as sorted by the user.

John Lea (johnlea) on 2012-09-19
Changed in ayatana-design:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

@Dmitry: the issue is that unity defines the order of the items it seems

The "Open in New Window" is coming from a static .desktop entry, the bookmarks added dynamically from libunity, I'm not sure there is a way to customize the order...

@Unity team: is that possible with the current implementation?

affects: unity → libunity
Changed in libunity:
milestone: backlog → none
status: Invalid → New
Doug McMahon (mc3man) wrote :

Not sure how many users actually care about this ...
I guess you're not allowed to create ~/.config/gtk-3.0/bookmarks file when a user account is created?
If you could then same could be achieved by, - Ex. here

file:///home/doug A New Window
file:///home/doug/Documents
file:///home/doug/Music
file:///home/doug/Pictures
file:///home/doug/Videos
file:///home/doug/Downloads

Sebastien Bacher (seb128) wrote :

@Doug: thanks for the suggestion, not sure if we should/could create a file like that but it seems hackish in any case, I would prefer unity to provide the flexibility since other apps will likely get the same issue

On 12/03/2012 01:03 PM, Sebastien Bacher wrote:
> @Doug: thanks for the suggestion, not sure if we should/could create a
> file like that but it seems hackish in any case, I would prefer unity to
> provide the flexibility since other apps will likely get the same issue
>
Understood - only mentioned because user accounts always get a default
~/.gtk-bookmarks file but nautilus no longer uses it

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers