unity-applications-daemon crashed with SIGSEGV in dee_sequence_model_free_row()

Bug #916356 reported by Chenheting on 2012-01-14
This bug affects 639 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
Unity Distro Priority
Critical
Unassigned
libunity
Fix Released
High
Michal Hruby
unity-lens-applications
Undecided
Unassigned
libunity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Critical
Canonical Desktop Experience Team
Precise
Critical
Canonical Desktop Experience Team

Bug Description

When I start up ubuntu 12.04, I got this bug report

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Sat Jan 14 10:50:58 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111212)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_SG:en
 LANG=en_SG.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fe201352e38: mov 0x0(%rbp,%r14,8),%rdi
 PC (0x7fe201352e38) ok
 source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to precise on 2012-01-13 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Chenheting (chenheting) wrote :
visibility: private → public

StacktraceTop:
 dee_sequence_model_free_row (self=<optimized out>, iter=0x1100e10) at dee-sequence-model.c:981
 dee_sequence_model_remove (self=0x1261270, iter_=0x1100e10) at dee-sequence-model.c:482
 g_closure_invoke (closure=0x126dc00, return_value=0x0, n_param_values=2, param_values=0x1291560, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.8/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=<optimized out>, emission_return=0x0, instance_and_params=0x1291560) at /build/buildd/glib2.0-2.31.8/./gobject/gsignal.c:3302
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=0x7fff9b8edc68) at /build/buildd/glib2.0-2.31.8/./gobject/gsignal.c:3033

Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
summary: - unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
+ unity-applications-daemon crashed with SIGSEGV in
+ dee_sequence_model_free_row()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
importance: Medium → Critical
tags: added: bugpattern-needed
Changed in unity-lens-applications (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: rls-mgr-p-tracking
Michal Hruby (mhr3) on 2012-02-14
tags: added: apport-request-retrace
John Belton (jbelton1950) wrote :

This crash happened when I tried to open a game, I haven't tried to open anything else using the Dash, the others wer opened from the Launcher.
John

Package: unity-lens-applications 5.2.0-0ubuntu1
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon

tags: removed: apport-request-retrace
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-02-28
Changed in libunity:
status: New → In Progress
assignee: nobody → Michal Hruby (mhr3)
Changed in libunity (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-02-28
Changed in libunity:
milestone: none → 5.6.0
Michal Hruby (mhr3) on 2012-02-28
Changed in libunity:
importance: Undecided → High
Michal Hruby (mhr3) on 2012-02-28
Changed in unity:
importance: Undecided → High
milestone: none → 5.6.0
status: Confirmed → Fix Committed
assignee: nobody → Michal Hruby (mhr3)
Changed in libunity:
status: In Progress → Fix Committed
Alexey Ivanov (alexey-ivanov) wrote :

On nouveau bug too.

Peter Silva (peter-bsqt) wrote :

typed ''burn'' looking for brasero, it showed it under applications lens, but hung (while dumping core.)
started up brasero from terminal window, was ok. really just dash crash.

Didier Roche (didrocks) on 2012-03-12
Changed in libunity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 5.6.0-0ubuntu1

---------------
libunity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - dash home lens does not include recent files... (LP: #946980)
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 11:48:54 +0100

Changed in libunity (Ubuntu Precise):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.6.0-0ubuntu1

---------------
unity-lens-applications (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Can't launch applications from the launcher (LP: #938505)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - non-existent icons are referenced: category-available and category-
      installed (LP: #932212)
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 11:52:14 +0100

Changed in unity-lens-applications (Ubuntu Precise):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
John Belton (jbelton1950) wrote :

It looks like this has returned with vengance, updating this morning asked for a reboot and after entering password the display clears then seems to freeze, no interface at all, I can open the terminal via CTRL+ALT+F1 but I can't see where to go to get the interface running. I'm not sure how to report the system status from there and am using my normal 11.10 system to report this, it may have been reported under another bug but without reading all those since Thursday (the last date updated the failed system) so any advice will be investigated. Thanks
John

Tomas Gustavsson (tomasg) wrote :

Hmm, everything works fine for me after todays upgrades.

After The most recent updates, My entire Homepage seems to be very unstable
and flickers like a strobe light... Everything seems to work fine It just
doesn't seem to render fine... It might be just my netbook, but does anyone
else have any instability on their desktop??
On Mar 25, 2012 2:01 PM, "Tomas Gustavsson" <email address hidden> wrote:

> Hmm, everything works fine for me after todays upgrades.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (926880).
> https://bugs.launchpad.net/bugs/916356
>
> Title:
> unity-applications-daemon crashed with SIGSEGV in
> dee_sequence_model_free_row()
>
> Status in LibUnity:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Released
> Status in Unity Applications Lens:
> Fix Released
> Status in “libunity” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity-lens-applications” package in Ubuntu:
> Fix Released
> Status in “libunity” source package in Precise:
> Fix Released
> Status in “unity” source package in Precise:
> Fix Released
> Status in “unity-lens-applications” source package in Precise:
> Fix Released
>
> Bug description:
> When I start up ubuntu 12.04, I got this bug report
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: unity-lens-applications 5.0.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
> Uname: Linux 3.2.0-8-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 1.90-0ubuntu2
> Architecture: amd64
> Date: Sat Jan 14 10:50:58 2012
> ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20111212)
> ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANGUAGE=en_SG:en
> LANG=en_SG.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7fe201352e38: mov 0x0(%rbp,%r14,8),%rdi
> PC (0x7fe201352e38) ok
> source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA region
> (needed readable region)!
> destination "%rdi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity-lens-applications
> StacktraceTop:
> ?? () from /usr/lib/libdee-1.0.so.4
> ?? () from /usr/lib/libdee-1.0.so.4
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: unity-applications-daemon crashed with SIGSEGV in
> g_closure_invoke()
> UpgradeStatus: Upgraded to precise on 2012-01-13 (0 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/libunity/+bug/916356/+subscriptions
>

jalpesh (jalpesh-rajani) wrote :
Download full text (5.7 KiB)

Same issue on my machine in ubuntu 3d but works fine in 2d
On Mar 25, 2012 11:15 AM, "Philip Noseworthy" <email address hidden>
wrote:

> After The most recent updates, My entire Homepage seems to be very unstable
> and flickers like a strobe light... Everything seems to work fine It just
> doesn't seem to render fine... It might be just my netbook, but does anyone
> else have any instability on their desktop??
> On Mar 25, 2012 2:01 PM, "Tomas Gustavsson" <email address hidden> wrote:
>
> > Hmm, everything works fine for me after todays upgrades.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (926880).
> > https://bugs.launchpad.net/bugs/916356
> >
> > Title:
> > unity-applications-daemon crashed with SIGSEGV in
> > dee_sequence_model_free_row()
> >
> > Status in LibUnity:
> > Fix Released
> > Status in Unity:
> > Fix Released
> > Status in Unity Distro Priority:
> > Fix Released
> > Status in Unity Applications Lens:
> > Fix Released
> > Status in “libunity” package in Ubuntu:
> > Fix Released
> > Status in “unity” package in Ubuntu:
> > Fix Released
> > Status in “unity-lens-applications” package in Ubuntu:
> > Fix Released
> > Status in “libunity” source package in Precise:
> > Fix Released
> > Status in “unity” source package in Precise:
> > Fix Released
> > Status in “unity-lens-applications” source package in Precise:
> > Fix Released
> >
> > Bug description:
> > When I start up ubuntu 12.04, I got this bug report
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 12.04
> > Package: unity-lens-applications 5.0.0-0ubuntu1
> > ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
> > Uname: Linux 3.2.0-8-generic x86_64
> > NonfreeKernelModules: fglrx
> > ApportVersion: 1.90-0ubuntu2
> > Architecture: amd64
> > Date: Sat Jan 14 10:50:58 2012
> > ExecutablePath:
> /usr/lib/unity-lens-applications/unity-applications-daemon
> > InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> > (20111212)
> > ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
> > ProcEnviron:
> > SHELL=/bin/bash
> > PATH=(custom, no user)
> > LANGUAGE=en_SG:en
> > LANG=en_SG.UTF-8
> > SegvAnalysis:
> > Segfault happened at: 0x7fe201352e38: mov
> 0x0(%rbp,%r14,8),%rdi
> > PC (0x7fe201352e38) ok
> > source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA
> region
> > (needed readable region)!
> > destination "%rdi" ok
> > SegvReason: reading NULL VMA
> > Signal: 11
> > SourcePackage: unity-lens-applications
> > StacktraceTop:
> > ?? () from /usr/lib/libdee-1.0.so.4
> > ?? () from /usr/lib/libdee-1.0.so.4
> > g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> > ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> > g_signal_emit_valist () from
> > /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> > Title: unity-applications-daemon crashed with SIGSEGV in
> > g_closure_invoke()
> > UpgradeStatus: Upgraded to precise on 2012-01-13 (0 days ago)
> > UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> >
> > To manage notifications about this bug go to:
> > https://bu...

Read more...

Download full text (8.7 KiB)

Same problem here, but only with one user's account. My account is fine.

2012/3/25 jalpesh <email address hidden>

> Same issue on my machine in ubuntu 3d but works fine in 2d
> On Mar 25, 2012 11:15 AM, "Philip Noseworthy" <email address hidden>
> wrote:
>
> > After The most recent updates, My entire Homepage seems to be very
> unstable
> > and flickers like a strobe light... Everything seems to work fine It just
> > doesn't seem to render fine... It might be just my netbook, but does
> anyone
> > else have any instability on their desktop??
> > On Mar 25, 2012 2:01 PM, "Tomas Gustavsson" <email address hidden> wrote:
> >
> > > Hmm, everything works fine for me after todays upgrades.
> > >
> > > --
> > > You received this bug notification because you are subscribed to a
> > > duplicate bug report (926880).
> > > https://bugs.launchpad.net/bugs/916356
> > >
> > > Title:
> > > unity-applications-daemon crashed with SIGSEGV in
> > > dee_sequence_model_free_row()
> > >
> > > Status in LibUnity:
> > > Fix Released
> > > Status in Unity:
> > > Fix Released
> > > Status in Unity Distro Priority:
> > > Fix Released
> > > Status in Unity Applications Lens:
> > > Fix Released
> > > Status in “libunity” package in Ubuntu:
> > > Fix Released
> > > Status in “unity” package in Ubuntu:
> > > Fix Released
> > > Status in “unity-lens-applications” package in Ubuntu:
> > > Fix Released
> > > Status in “libunity” source package in Precise:
> > > Fix Released
> > > Status in “unity” source package in Precise:
> > > Fix Released
> > > Status in “unity-lens-applications” source package in Precise:
> > > Fix Released
> > >
> > > Bug description:
> > > When I start up ubuntu 12.04, I got this bug report
> > >
> > > ProblemType: Crash
> > > DistroRelease: Ubuntu 12.04
> > > Package: unity-lens-applications 5.0.0-0ubuntu1
> > > ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
> > > Uname: Linux 3.2.0-8-generic x86_64
> > > NonfreeKernelModules: fglrx
> > > ApportVersion: 1.90-0ubuntu2
> > > Architecture: amd64
> > > Date: Sat Jan 14 10:50:58 2012
> > > ExecutablePath:
> > /usr/lib/unity-lens-applications/unity-applications-daemon
> > > InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> > > (20111212)
> > > ProcCmdline:
> /usr/lib/unity-lens-applications/unity-applications-daemon
> > > ProcEnviron:
> > > SHELL=/bin/bash
> > > PATH=(custom, no user)
> > > LANGUAGE=en_SG:en
> > > LANG=en_SG.UTF-8
> > > SegvAnalysis:
> > > Segfault happened at: 0x7fe201352e38: mov
> > 0x0(%rbp,%r14,8),%rdi
> > > PC (0x7fe201352e38) ok
> > > source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA
> > region
> > > (needed readable region)!
> > > destination "%rdi" ok
> > > SegvReason: reading NULL VMA
> > > Signal: 11
> > > SourcePackage: unity-lens-applications
> > > StacktraceTop:
> > > ?? () from /usr/lib/libdee-1.0.so.4
> > > ?? () from /usr/lib/libdee-1.0.so.4
> > > g_closure_invoke () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> > > ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> > > g_signal_emit_valist () from
> > > /usr/lib/x86_64-linux-gnu/libgobject-2...

Read more...

Jim (jimvernon) wrote :

You could try renaming the .gconf and .config/dconf folders.

I don't understand. Rename to what? How does it help?

2012/3/25 Jim <email address hidden>

> You could try renaming the .gconf and .config/dconf folders.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (933971).
> https://bugs.launchpad.net/bugs/916356
>
> Title:
> unity-applications-daemon crashed with SIGSEGV in
> dee_sequence_model_free_row()
>
> Status in LibUnity:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Released
> Status in Unity Applications Lens:
> Fix Released
> Status in “libunity” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity-lens-applications” package in Ubuntu:
> Fix Released
> Status in “libunity” source package in Precise:
> Fix Released
> Status in “unity” source package in Precise:
> Fix Released
> Status in “unity-lens-applications” source package in Precise:
> Fix Released
>
> Bug description:
> When I start up ubuntu 12.04, I got this bug report
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: unity-lens-applications 5.0.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
> Uname: Linux 3.2.0-8-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 1.90-0ubuntu2
> Architecture: amd64
> Date: Sat Jan 14 10:50:58 2012
> ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20111212)
> ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANGUAGE=en_SG:en
> LANG=en_SG.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7fe201352e38: mov 0x0(%rbp,%r14,8),%rdi
> PC (0x7fe201352e38) ok
> source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA region
> (needed readable region)!
> destination "%rdi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity-lens-applications
> StacktraceTop:
> ?? () from /usr/lib/libdee-1.0.so.4
> ?? () from /usr/lib/libdee-1.0.so.4
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: unity-applications-daemon crashed with SIGSEGV in
> g_closure_invoke()
> UpgradeStatus: Upgraded to precise on 2012-01-13 (0 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/libunity/+bug/916356/+subscriptions
>

--
Pablo Almeida
http://www.google.com/profiles/pabloalmeidaff9

Jim (jimvernon) wrote :

Rename them to .gconf.old and dconf.old. Then log out and log back in again. This should cause gnome/Unity to revert to default settings.

Wow, thanks. This really solved the problem. :)

2012/3/25 Jim <email address hidden>

> Rename them to .gconf.old and dconf.old. Then log out and log back in
> again. This should cause gnome/Unity to revert to default settings.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (933971).
> https://bugs.launchpad.net/bugs/916356
>
> Title:
> unity-applications-daemon crashed with SIGSEGV in
> dee_sequence_model_free_row()
>
> Status in LibUnity:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Released
> Status in Unity Applications Lens:
> Fix Released
> Status in “libunity” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity-lens-applications” package in Ubuntu:
> Fix Released
> Status in “libunity” source package in Precise:
> Fix Released
> Status in “unity” source package in Precise:
> Fix Released
> Status in “unity-lens-applications” source package in Precise:
> Fix Released
>
> Bug description:
> When I start up ubuntu 12.04, I got this bug report
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: unity-lens-applications 5.0.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
> Uname: Linux 3.2.0-8-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 1.90-0ubuntu2
> Architecture: amd64
> Date: Sat Jan 14 10:50:58 2012
> ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64
> (20111212)
> ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANGUAGE=en_SG:en
> LANG=en_SG.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7fe201352e38: mov 0x0(%rbp,%r14,8),%rdi
> PC (0x7fe201352e38) ok
> source "0x0(%rbp,%r14,8)" (0x00000000) not located in a known VMA region
> (needed readable region)!
> destination "%rdi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity-lens-applications
> StacktraceTop:
> ?? () from /usr/lib/libdee-1.0.so.4
> ?? () from /usr/lib/libdee-1.0.so.4
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: unity-applications-daemon crashed with SIGSEGV in
> g_closure_invoke()
> UpgradeStatus: Upgraded to precise on 2012-01-13 (0 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/libunity/+bug/916356/+subscriptions
>

--
Pablo Almeida
http://www.google.com/profiles/pabloalmeidaff9

Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: libunity (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers