HUD Actions Fail to Show

Bug #1065556 reported by Robert Carr on 2012-10-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
WebApps: libunity-webapps
Critical
Robert Carr
libunity-webapps (Ubuntu)
High
Unassigned

Bug Description

Yep.

Related branches

Robert Carr (robertcarr) on 2012-10-11
visibility: private → public
Robert Carr (robertcarr) on 2012-10-11
Changed in libunity-webapps:
status: Confirmed → Fix Committed
Changed in libunity-webapps (Ubuntu):
milestone: none → quantal-updates
importance: Undecided → Critical
importance: Critical → High
Robert Carr (robertcarr) wrote :

Fixed in revision r795 to libunity-webapps. Related to change of blacklisted shell windows in window activity tracker.

Steps to verify:
After applying r795 and ensuring webapps system is restarted (in this case closing all browser windows should be enough), browse to an integrated webapp with expected HUD integration, i.e. www.reddit.com.
On reddit the subreddit selection bar (along the very top of the page) should be searchable via the HUD.

Regression potential:
Very low, fix is just adding a string (unity-launcher instead of previously launcher) to a blacklist.

Robert Carr (robertcarr) wrote :

This is a funny bug because it relates to the opening of the HUD window itself. Thus the libunity-webapps traced tests which excercise the action system via DBus failed to catch it. Likewise inspection from hud testing tools (i.e. hud-gtk) makes it appear things work.

This is a clear case for running our autopilot tests continuously.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity-webapps - 2.4.1-0ubuntu2

---------------
libunity-webapps (2.4.1-0ubuntu2) quantal-proposed; urgency=low

  * debian/patches/lp_1065556.patch
    - Fixed HUD Actions fail to show (LP: #1065556)
 -- Ken VanDine <email address hidden> Thu, 11 Oct 2012 12:28:17 -0400

Changed in libunity-webapps (Ubuntu):
status: New → Fix Released
Robert Carr (robertcarr) on 2012-10-22
Changed in libunity-webapps:
status: Fix Committed → Fix Released
autra (autra) wrote :

I still experienced this on version 2.4.1-0ubuntu3.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers