ubuntu-webapps-update-index crashed with SIGSEGV in unity_webapps_url_db_insert_url_prepare_statement()

Bug #1061677 reported by Nocchy on 2012-10-04
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
WebApps: libunity-webapps
Medium
Maxim Ermilov
libunity-webapps (Ubuntu)
Medium
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity-webapps-service 2.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic i686
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Thu Oct 4 16:55:05 2012
ExecutablePath: /usr/bin/ubuntu-webapps-update-index
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcCmdline: ubuntu-webapps-update-index
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 TERM=xterm
 LANG=it_IT.UTF-8
SegvAnalysis:
 Segfault happened at: 0x804a2d1: mov (%edi),%eax
 PC (0x0804a2d1) ok
 source "(%edi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libunity-webapps
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: ubuntu-webapps-update-index crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Nocchy (giannipetino) wrote :

StacktraceTop:
 unity_webapps_url_db_insert_url_prepare_statement (record=0xe7d4b20, url=0xe3958f0 "https://read.amazon.com/*", url_db=0x0) at ../unity-webapps-url-db.c:40
 unity_webapps_url_db_insert_url (url_db=0x0, url=0xe3958f0 "https://read.amazon.com/*", record=record@entry=0xe7d4b20) at ../unity-webapps-url-db.c:133
 package_info_done (channel=0x9de5050, condition=G_IO_HUP, user_data=user_data@entry=0x0) at ubuntu-webapps-update-index.c:107
 g_io_unix_dispatch (source=source@entry=0x9de5400, callback=0x8049950 <package_info_done>, user_data=0x0) at /build/buildd/glib2.0-2.34.0/./glib/giounix.c:167
 g_main_dispatch (context=0x9de7c00) at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:2715

Changed in libunity-webapps (Ubuntu):
importance: Undecided → Medium
summary: ubuntu-webapps-update-index crashed with SIGSEGV in
- g_main_context_dispatch()
+ unity_webapps_url_db_insert_url_prepare_statement()
tags: removed: need-i386-retrace
tags: added: running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity-webapps (Ubuntu):
status: New → Confirmed
Changed in libunity-webapps:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
information type: Private → Public
Changed in libunity-webapps:
importance: Undecided → Medium
Maxim Ermilov (zaspire) on 2012-11-16
Changed in libunity-webapps:
assignee: Alexandre Abreu (abreu-alexandre) → nobody
assignee: nobody → Maxim Ermilov (zaspire)
Maxim Ermilov (zaspire) on 2012-11-19
Changed in libunity-webapps:
status: New → Fix Committed
Maxim Ermilov (zaspire) on 2012-11-19
Changed in libunity-webapps:
milestone: none → 2.4.3
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity-webapps - 2.4.3daily12.11.28-0ubuntu1

---------------
libunity-webapps (2.4.3daily12.11.28-0ubuntu1) raring; urgency=low

  [ Robert Bruce Park ]
  * -debian/patches/lp_1065556.patch
  * Inline packaging.

  [ Ken VanDine ]
  * Automatic snapshot from revision 795 (bootstrap)

  [ Didier Roche ]
  * debian/*symbols:
    - remove now unexported private symbols

  [ Alex Launi ]
  * Firefox 16.0.1 Crash Report [@
    unity_webapps_available_application_get_application_domain ] (LP:
    #1068495)

  [ Chris Coulson ]
  * Firefox 16.0.1 Crash Report [@
    unity_webapps_available_application_get_application_domain ] (LP:
    #1068495)

  [ Maxim Ermilov ]
  * ubuntu-webapps-update-index crashed with SIGSEGV in
    unity_webapps_url_db_insert_url_prepare_statement() (LP: #1061677)
  * Youtube sound menu integration doesn't behave correctly (LP:
    #1038491)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 862
 -- Automatic PS uploader <email address hidden> Wed, 28 Nov 2012 05:01:36 +0000

Changed in libunity-webapps (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers