Webapps launchers have incorrect window matching (pips)

Reported by Alan Pope ㋛ on 2012-10-01
96
This bug affects 26 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
WebApps: libunity-webapps
High
Alexandre Abreu
bamf (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Raring
Undecided
Unassigned

Bug Description

[Impact]

Wrong 'pip' count for webapps launchers.

[Test Case]

Set chromium as default browser (just open it and tick 'yes' when prompted)
Open chromium, and leave that window open
Click the Amazon icon in the launcher

Expected:-
Two icons in the launcher, one Amazon, one Chromium.
Amazon having a pip for being open on the left and a 'focus' pip on the right, chromium having a pip on the left only.

Actual:-
Two chromium icons in the launcher.
One chromium has a pip, additionally Amazon launcher has a focus pip.

See screenshot.

[Regression Potential]
Rare incorrect window matching for chrome-based applications, or wrong webapps matching.

 _
ProblemType: BugDistroRelease: Ubuntu 12.10
Package: unity 6.6.0+bzr2742stagingubuntu0+786 [origin: LP-PPA-sil2100-prerelease]
ProcVersionSignature: Ubuntu 3.5.0-16.24-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CrashDB: unity
Date: Mon Oct 1 10:38:27 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bashSourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~abreu-alexandre/bamf/fix-chromeless-matching-for-webapps
Superseded for merging into lp:bamf/0.4
Marco Trevisan (Treviño): Needs Fixing on 2013-04-16
Alexandre Abreu: Resubmit on 2013-02-21
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-02-21
lp:~3v1n0/bamf/fix-chromeless-matching-for-webapps
Merged into lp:bamf/0.4 at revision 530
PS Jenkins bot: Approve (continuous-integration) on 2013-04-16
Brandon Schaefer: Approve on 2013-04-16
Alexandre Abreu: Pending requested 2013-04-16
Marco Trevisan (Treviño): Pending requested 2013-04-16
Alan Pope ㋛ (popey) wrote :
Omer Akram (om26er) on 2012-10-01
Changed in unity:
status: New → Confirmed
affects: unity → libunity-webapps
Changed in libunity-webapps:
importance: Undecided → High
Alan Pope ㋛ (popey) wrote :

Tried also with the U1MS webapp, and the pip on the left of the U1MS icon only appears after you have logged in, gone through 2 factor auth (if applicable) and finally get to the store.

Alan Pope ㋛ (popey) wrote :

http://www.youtube.com/watch?v=8e0jVxu4zZI video showing it more clearly (apologies for muffled sound at the start, I had my finger over the mic hole).

Steven Roose (stevenroose) wrote :

This bug is really keeping me from using WebApps, no matter how badly I want it, please fix this!

Alex Launi (alexlauni) on 2012-10-26
Changed in libunity-webapps:
assignee: nobody → Alex Launi (alexlauni)
Alex Launi (alexlauni) on 2012-10-26
Changed in libunity-webapps:
assignee: Alex Launi (alexlauni) → Alexandre Abreu (abreu-alexandre)
Alex Launi (alexlauni) on 2012-10-30
Changed in bamf:
status: New → Confirmed
Changed in libunity-webapps:
status: Confirmed → In Progress
Changed in bamf:
status: Confirmed → In Progress
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Omer Akram (om26er) on 2013-01-04
Changed in bamf:
importance: Undecided → High
Changed in bamf:
assignee: Alexandre Abreu (abreu-alexandre) → Marco Trevisan (Treviño) (3v1n0)
Changed in libunity-webapps:
assignee: Alexandre Abreu (abreu-alexandre) → Marco Trevisan (Treviño) (3v1n0)
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in bamf:
milestone: none → 0.4.0
Changed in libunity-webapps:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 530, scheduled for release in bamf, milestone 0.4.0

Changed in bamf:
status: In Progress → Fix Committed
Changed in libunity-webapps:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in bamf (Ubuntu):
status: New → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.4.0daily13.05.02-0ubuntu1

---------------
bamf (0.4.0daily13.05.02-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - Update the libwnck-3-dev dependency to 3.4.5

  [ Marco Trevisan (Treviño) <mail@3v1n0.net>, Alexandre Abreu ]
  * Webapps launchers have incorrect window matching (pips) (LP:
    #1059475)

  [ Marco Trevisan (Treviño) ]
  * Coverity SECURE_TEMP - CID 10450 (LP: #1100551)
  * Matcher leaks memory when rematching a new desktop file (LP:
    #1169990)
  * Coverity DEADCODE - CID 10447 (LP: #1100554)
  * Coverity REVERSE_INULL - CID 12653 (LP: #1100553)
  * Webapps launchers have incorrect window matching (pips) (LP:
    #1059475)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 533
 -- Ubuntu daily release <email address hidden> Thu, 02 May 2013 22:59:03 +0000

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
description: updated
description: updated
description: updated
Changed in libunity-webapps:
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Raring):
status: New → Confirmed
Changed in bamf:
status: Fix Committed → Fix Released
Greg Lynch (gregalynch) wrote :

Should this fix have showed up in software updater by now? I still haven't seen it there. Or is there a patch I need to download manually?

Robert Bruce Park (robru) wrote :

It's currently only fixed in saucy. We haven't completed the SRU into raring yet (this is on my big backlog of things to do since I've been away for 3 weeks).

Hello Alan, or anyone else affected,

Accepted bamf into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bamf/0.4.0daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed

I installed bamfdaemon from raring-proposed and this issue is not fixed.

$ apt-cache policy bamfdaemon
bamfdaemon:
  Installed: 0.4.0daily13.06.19~13.04-0ubuntu1
  Candidate: 0.4.0daily13.06.19~13.04-0ubuntu1
  Version table:
 *** 0.4.0daily13.06.19~13.04-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.0daily13.04.03-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

tags: added: verification-failed
removed: verification-needed
Omar Campagne (ocampagne) wrote :

I had the same issue but this upgrade fixed it after log out -> in.

If webapp is added as a launcher in Unity, first the Chromium icon appears besides it and then disappears, leaving "control"
to the appropriate launcher.
If launched from dash or messaging menu, the Chromium icon appears and then "transforms" into
the appropriate icon.

Possibly unrelated, I must add I had previously upgraded also chromium unity extensions from raring-proposed, mentioning just in case.

$ apt-cache policy bamfdaemon
bamfdaemon:
  Installed: 0.4.0daily13.06.19~13.04-0ubuntu1
  Candidate: 0.4.0daily13.06.19~13.04-0ubuntu1
  Version table:
 *** 0.4.0daily13.06.19~13.04-0ubuntu1 0
        500 http://es.archive.ubuntu.com/ubuntu/ raring-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.4.0daily13.04.03-0ubuntu1 0
        500 http://es.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

tags: added: verification-done

Yes, it was the unity-chromium-extension package that caused this to fail for me. After updating that, this works now.

tags: removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.4.0daily13.06.19~13.04-0ubuntu1

---------------
bamf (0.4.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Makefile.am.gtests, Makefile.am.coverage: add missing entries to
    allow building in jenkins. (LP: #1192216)
  * Makefile.am.gtests: kill the launched dbus-daemon after running the
    tests. (LP: #1088696)

  [ Łukasz 'sil2100' Zemczak ]
  * Automatic snapshot from revision 540

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 541

bamf (0.4.0daily13.05.31~13.04-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Releasing Bamf-0.4.0
  * libbamf: BamfApplication: cache MimeTypes and ApplicationType on
    favorite and sticky apps. (LP: #1183871)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 536

bamf (0.4.0daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - Update the libwnck-3-dev dependency to 3.4.5

  [ Timo Jyrinki ]
  * Set Vcs-Bzr url to 0.4 for this raring branch

  [ Marco Trevisan (Treviño) <mail@3v1n0.net>, Alexandre Abreu ]
  * Webapps launchers have incorrect window matching (pips) (LP:
    #1059475)

  [ Marco Trevisan (Treviño) ]
  * Coverity SECURE_TEMP - CID 10450 (LP: #1100551)
  * Matcher leaks memory when rematching a new desktop file (LP:
    #1169990)
  * Coverity DEADCODE - CID 10447 (LP: #1100554)
  * Coverity REVERSE_INULL - CID 12653 (LP: #1100553)
  * Webapps launchers have incorrect window matching (pips) (LP:
    #1059475)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 533
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 02:01:50 +0000

Changed in bamf (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers