unity-webapps-context-daemon crashed with SIGSEGV in g_closure_invoke()

Bug #1029949 reported by Siddhanathan Shanmugam on 2012-07-27
322
This bug affects 59 people
Affects Status Importance Assigned to Milestone
WebApps: libunity-webapps
High
Alex Launi
libunity
Fix Released
High
Alex Launi
6.0
Fix Released
High
Timo Jyrinki
libunity (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]

A common crash seen for example while closing Chromium from Launcher.

[Test case]

Run automated tests or try to reproduce the crash manually by closing Chromium.

[Regression potential]

Low, fixes a segfault from non-null terminated array.

---

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity-webapps-service 1.8.0-0quantal2 [origin: LP-PPA-webapps-preview]
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu5
Architecture: amd64
CrashCounter: 1
CrashDB: libunity_webapps
Date: Fri Jul 27 19:14:29 2012
ExecutablePath: /usr/lib/libunity-webapps/unity-webapps-context-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcCmdline: /usr/lib/libunity-webapps/unity-webapps-context-daemon Launchpad launchpad.net icon://launchpad [Invalid\ UTF-8]
SegvAnalysis:
 Segfault happened at: 0x7fbf5dd2ded6: movlpd (%rdi),%xmm1
 PC (0x7fbf5dd2ded6) ok
 source "(%rdi)" (0x0000000b) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libunity-webapps
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
ThirdParty: True
Title: unity-webapps-context-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to quantal on 2012-07-24 (2 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

visibility: private → public
David King (amigadave) on 2012-10-02
Changed in libunity-webapps:
importance: Undecided → High
status: New → Confirmed
Alex Launi (alexlauni) wrote :

Believe this crash is arising inside libunity, in the sound menu's blacklist functionality. Likely a list modification during iteration issue.

Changed in libunity-webapps:
assignee: nobody → Alex Launi (alexlauni)
Alex Launi (alexlauni) wrote :
Changed in libunity:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alex Launi (alexlauni)
Changed in libunity-webapps:
status: Confirmed → Invalid
Changed in libunity:
status: Confirmed → In Progress
Changed in libunity:
status: In Progress → Fix Committed

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in libunity (Ubuntu):
status: New → Invalid
Download full text (7.2 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.7.1-5ubuntu1 required, but 1:4.7.2-2ubuntu1 is available
libavahi-common3 version 0.6.31-1ubuntu1 required, but 0.6.31-1ubuntu2 is available
libxcb-util0 version 0.3.8-2 required, but 0.3.8-2build1 is available
fontconfig version 2.8.0-3ubuntu9 required, but 2.10.1-0ubuntu3 is available
libcolord1 version 0.1.21-1 required, but 0.1.21-1ubuntu2 is available
libxfixes3 version 1:5.0-4ubuntu4 required, but 1:5.0-4ubuntu5 is available
libgdk-pixbuf2.0-common version 2.26.1-1ubuntu1 required, but 2.26.4-0ubuntu1 is available
libgtk-3-common version 3.5.8-0ubuntu2 required, but 3.6.0-0ubuntu3.1 is available
libacl1 version 2.2.51-8ubuntu1 required, but 2.2.51-8ubuntu2 is available
libgpg-error0 version 1.10-3 required, but 1.10-3.1ubuntu1 is available
libdconf1 version 0.13.4-0ubuntu2 required, but 0.14.0-0ubuntu2 is available
libatspi2.0-0 version 2.5.4-0ubuntu1 required, but 2.6.0-0ubuntu1 is available
libfontconfig1 version 2.8.0-3ubuntu9 required, but 2.10.1-0ubuntu3 is available
debconf version 1.5.45ubuntu1 required, but 1.5.46ubuntu1 is available
unity-webapps-service version 1.8.0-0quantal2 required, but 2.4.1-0ubuntu3.1 is available
outdated debug symbol package for unity-webapps-service: package version 2.4.1-0ubuntu3.1 dbgsym version 2.4.1-0ubuntu2
libk5crypto3 version 1.10.1+dfsg-1 required, but 1.10.1+dfsg-2 is available
libavahi-client3 version 0.6.31-1ubuntu1 required, but 0.6.31-1ubuntu2 is available
libwnck-3-0 version 3.4.2-1 required, but 3.4.3-0ubuntu1 is available
libproxy1 version 0.4.7-0ubuntu4 required, but 0.4.7-0ubuntu6 is available
libxcb-shm0 version 1.8.1-1 required, but 1.8.1-1ubuntu1 is available
glib-networking version 2.33.3-0ubuntu1 required, but 2.34.0-0ubuntu1 is available
libnotify4 version 0.7.5-1 required, but 0.7.5-1build1 is available
libgdk-pixbuf2.0-0 version 2.26.1-1ubuntu1 required, but 2.26.4-0ubuntu1 is available
libwnck-3-common version 3.4.2-1 required, but 3.4.3-0ubuntu1 is available
libkrb5-3 version 1.10.1+dfsg-1 required, but 1.10.1+dfsg-2 is available
libunity-webapps0 version 1.8.0-0quantal2 required, but 2.4.1-0ubuntu3.1 is available
outdated debug symbol package for libunity-webapps0: package version 2.4.1-0ubuntu3.1 dbgsym version 2.4.1-0ubuntu2
libxcb-render0 version 1.8.1-1 required, but 1.8.1-1ubuntu1 is available
glib-networking-common version 2.33.3-0ubuntu1 required, but 2.34.0-0ubuntu1 is available
libpcre3 version 1:8.30-5 required, but 1:8.30-5ubuntu1 is available
libcomerr2 version 1.42.4-3ubuntu1 required, but 1.42.5-1ubuntu2 is available
libdatrie1 version 0.2.5-3 required, but 0.2.5-3build1 is available
libunity9 version 5.92.0-0ubuntu1 required, but 6.10.0-0ubuntu1 is available
outdated debug symbol package for libunity9: package version 6.10.0-0ubuntu1 dbgsym version 6.8.0-0ubuntu2
libp11-kit0 version 0.12-3ubuntu1 required, but 0.13-1 is available
libcairo-gobject2 version 1.12.3+...

Read more...

tags: removed: need-amd64-retrace
description: updated
Changed in libunity (Ubuntu):
status: Invalid → Confirmed
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.12.0-0ubuntu1

---------------
libunity (6.12.0-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Fix crash when adding or removing players from the blacklist.
      (LP: #1029949)
 -- Timo Jyrinki <email address hidden> Thu, 08 Nov 2012 08:28:18 +0200

Changed in libunity (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu Quantal):
status: New → Confirmed

Hello Siddhanathan, or anyone else affected,

Accepted libunity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libunity/6.12.0-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libunity (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.12.0-0ubuntu0.1

---------------
libunity (6.12.0-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release.
    - Fix crash when adding or removing players from the blacklist.
      (LP: #1029949)
 -- Timo Jyrinki <email address hidden> Thu, 08 Nov 2012 08:28:18 +0200

Changed in libunity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2013-09-02
Changed in libunity:
status: Fix Committed → Fix Released
milestone: none → 7.1.0
To post a comment you must log in.