[UI FFE] Notify user of missing MP3 support

Bug #733327 reported by dobey on 2011-03-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libubuntuone
High
dobey
libubuntuone (Ubuntu)
High
dobey

Bug Description

We need to check for MP3 support and provide a user interface to allow the user to install support in libubuntuone, so that all music players that have an extension for our store will get the same support, and not need duplicate code in multiple languages.

Without this UI change, users without the proper MP3 codec already installed will not be given a clear and easy way to use the Ubuntu One music store in Banshee or Rhythmbox on Natty.

Message to ubuntu-doc: https://lists.ubuntu.com/archives/ubuntu-doc/2011-March/015503.html
Message to ubuntu-translators: https://lists.ubuntu.com/archives/ubuntu-translators/2011-March/004559.html

Related branches

dobey (dobey) on 2011-03-11
Changed in libubuntuone:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → In Progress
tags: added: u1-natty-beta
Changed in libubuntuone (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Rodney Dawes (dobey)
milestone: none → ubuntu-11.04-beta-1
Changed in libubuntuone (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
summary: - Notify user of missing MP3 support
+ [FFE] Notify user of missing MP3 support
description: updated
description: updated
description: updated
Changed in libubuntuone (Ubuntu):
status: Confirmed → New
importance: Medium → Undecided
summary: - [FFE] Notify user of missing MP3 support
+ [UI FFE] Notify user of missing MP3 support

Does Banshee provide anything like this already?

dobey (dobey) wrote :

No it has no way to provide install of a specific codec package from an additional repository.

Changed in libubuntuone (Ubuntu):
importance: Undecided → High
Kate Stewart (kate.stewart) wrote :

Based on no objections received from threads started on docs, and translators (and this is a good thing to get fixed).

Approved.

dobey (dobey) on 2011-04-05
Changed in libubuntuone:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2011-04-05
Changed in libubuntuone (Ubuntu):
status: New → Confirmed
dobey (dobey) on 2011-04-07
Changed in libubuntuone:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 0.9.2-0ubuntu1

---------------
libubuntuone (0.9.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Distribution series hardcoded for codec installation (LP: #693536)
    - [UIFE] Notify user of missing MP3 suupport (LP: #733327)
    - Music purchased from U1MS not appear in music library (LP: #604699)
 -- Rodney Dawes <email address hidden> Thu, 07 Apr 2011 11:33:11 -0400

Changed in libubuntuone (Ubuntu):
status: Confirmed → Fix Released
tags: removed: u1-natty-beta
Dennis Baudys (thecondordb) wrote :

Hi!

I'm from the German Ubuntu Translators Team. I'd like to know, where this new string can be found because I'm not quite sure, if it is already translated in German. Or is this string not translateable with Launchpad?

Thanks in advance.

Dennis

dobey (dobey) wrote :

Hi Dennis, the strings should automatically appear in Launchpad for Ubuntu soon after the new version was released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers