Show text prior to loading the main store

Bug #530247 reported by Matt Griffin on 2010-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libubuntuone
Medium
Rodrigo Moya
libubuntuone (Ubuntu)
Low
Ken VanDine

Bug Description

Currently, clicking the Ubuntu One link in Rbox shows a white screen until the store loads. Display "Ubuntu One Music Store" in Rbox until the store screen loads.

Related branches

Changed in rhythmbox-ubuntuone-music-store:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: desktop+ music-store u1-lucid
Stuart Langridge (sil) on 2010-03-03
Changed in rhythmbox-ubuntuone-music-store:
status: New → Confirmed
importance: Undecided → Low
Stuart Langridge (sil) wrote :

This is way hard to fix. WebKit "commits" as soon as it gets the first byte from the remote server, and that "commit" turns the screen white. So pre-loading a nice screen won't help. In order to fix this, the U1 widget would have to contain *two* webviews, one of which loads the "pre-loading" screen, and the other of which loads the real page, and then when the real page loads, we swap the widgets. This involves some serious re-plumbing of how everything works.

Stuart Langridge (sil) on 2010-03-03
affects: rhythmbox-ubuntuone-music-store → libubuntuone
Stuart Langridge (sil) wrote :

We also need to put HTML files in the data/ directory, and then have a function to calculate a uri for a file in that directory and load it into a widget. This means that we can have a variety of files in there (for "connecting to the store", "error connecting", etc) and because they're loaded off the filesystem, they can contain images and styling and so on.

Changed in libubuntuone:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodrigo Moya (rodrigo-moya)
importance: Low → Medium
Changed in libubuntuone:
status: Confirmed → In Progress
Changed in libubuntuone:
status: In Progress → Fix Committed
Changed in libubuntuone (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Low
milestone: none → ubuntu-10.04-beta-2
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 0.2.101-0ubuntu1

---------------
libubuntuone (0.2.101-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - Only show context menu if environment variable defined (LP: #527688)
    - Export library path from music store widget (LP: #536957)
    - Show a temporary view when loading the initial store page (LP: #530247)
 -- Ken VanDine <email address hidden> Tue, 23 Mar 2010 15:50:24 -0400

Changed in libubuntuone (Ubuntu):
status: Triaged → Fix Released
Changed in libubuntuone:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers