winbind 4.3.8 has an ntlm_auth that breaks evolution-ews

Bug #1573494 reported by Simon Law on 2016-04-22
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsoup
Fix Released
Critical
libsoup2.4 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Marc Deslauriers
Wily
Undecided
Marc Deslauriers
Xenial
Undecided
Marc Deslauriers

Bug Description

See https://bugzilla.redhat.com/show_bug.cgi?id=1327072 and https://bugzilla.gnome.org/show_bug.cgi?id=765106 for the fix to libsoup.

I think evolution-ews also might need a rebuild.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: winbind 2:4.3.8+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Apr 22 02:34:28 2016
InstallationDate: Installed on 2016-04-15 (7 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
RelatedPackageVersions:
 nautilus 1:3.20.0-0ubuntu1~xenial2
 gvfs 1.28.1-1ubuntu1
SambaClientRegression: Yes
SourcePackage: samba
UpgradeStatus: Upgraded to xenial on 2016-04-21 (0 days ago)

Simon Law (sfllaw) wrote :
Changed in samba:
importance: Unknown → Critical
status: Unknown → Fix Released
affects: samba → libsoup
Changed in libsoup2.4 (Ubuntu Trusty):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → Confirmed
Changed in libsoup2.4 (Ubuntu Wily):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → Confirmed
Changed in libsoup2.4 (Ubuntu Xenial):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → Confirmed
no longer affects: samba (Ubuntu)
Marc Deslauriers (mdeslaur) wrote :

I've put updated libsoup packages that fix this issue in the security team PPA here:

https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+packages

I'd appreciate if someone could test them to see if they fix evolution-ews NTLM authentication and comment here. If they test ok, I'll release them.

Thanks!

Simon Law (sfllaw) wrote :

I tested libsoup2.4-1_2.52.2-1ubuntu0.1_amd64.deb and you've fixed the bug.

This also seems to affect the gnome3-staging PPA, I'll see if I can file/link a bug there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsoup2.4 - 2.50.0-2ubuntu0.1

---------------
libsoup2.4 (2.50.0-2ubuntu0.1) wily-security; urgency=medium

  * debian/patches/new_samba_compat.patch: fix regression in NTLM
    authentication caused by Samba security update (LP: #1573494)

 -- Marc Deslauriers <email address hidden> Fri, 22 Apr 2016 10:12:58 -0400

Changed in libsoup2.4 (Ubuntu Wily):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsoup2.4 - 2.44.2-1ubuntu2.1

---------------
libsoup2.4 (2.44.2-1ubuntu2.1) trusty-security; urgency=medium

  * debian/patches/new_samba_compat.patch: fix regression in NTLM
    authentication caused by Samba security update (LP: #1573494)

 -- Marc Deslauriers <email address hidden> Fri, 22 Apr 2016 10:14:24 -0400

Changed in libsoup2.4 (Ubuntu Trusty):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsoup2.4 - 2.52.2-1ubuntu0.1

---------------
libsoup2.4 (2.52.2-1ubuntu0.1) xenial-security; urgency=medium

  * debian/patches/new_samba_compat.patch: fix regression in NTLM
    authentication caused by Samba security update (LP: #1573494)

 -- Marc Deslauriers <email address hidden> Fri, 22 Apr 2016 10:10:48 -0400

Changed in libsoup2.4 (Ubuntu Xenial):
status: Confirmed → Fix Released
Simon Law (sfllaw) wrote :

This bug was in libsoup.

Changed in evolution-ews (Ubuntu):
status: New → Invalid
Changed in evolution-ews (Ubuntu Trusty):
status: New → Invalid
Changed in evolution-ews (Ubuntu Wily):
status: New → Invalid
Changed in evolution-ews (Ubuntu Xenial):
status: New → Invalid
Changed in libsoup2.4 (Ubuntu):
status: New → Fix Released
Changed in samba (Ubuntu Trusty):
status: New → Invalid
Changed in samba (Ubuntu Wily):
status: New → Invalid
Changed in samba (Ubuntu Xenial):
status: New → Invalid
Marc Deslauriers (mdeslaur) wrote :

Thanks for testing it Simon!

Simon Law (sfllaw) wrote :

@ricotz: It looks like you'll need to rebuild the Xenial packages in the gnome3-staging PPA. Thanks! ☺

no longer affects: evolution-ews (Ubuntu Xenial)
no longer affects: evolution-ews (Ubuntu Wily)
no longer affects: evolution-ews (Ubuntu Trusty)
no longer affects: evolution-ews (Ubuntu)
no longer affects: samba (Ubuntu Xenial)
no longer affects: samba (Ubuntu Trusty)
no longer affects: samba (Ubuntu Wily)
affects: samba (Fedora) → samba
Changed in samba:
importance: Unknown → Undecided
status: Unknown → New
affects: samba → ubuntu-translations
no longer affects: ubuntu-translations
affects: ubuntu-gnome → ubuntu-translations
no longer affects: ubuntu-translations
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.