libqtdbustest fails to build against Qt 5.2 on x86

Bug #1262638 reported by Timo Jyrinki on 2013-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libqtdbustest
Critical
Pete Woods
libqtdbustest (Ubuntu)
Undecided
Unassigned

Bug Description

Tests are failing:

https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+sourcepub/3740903/+listing-archive-extra

This is one of the current blockers in getting the dependency chain rebuilt against Qt 5.2, see https://lists.launchpad.net/ubuntu-phone/msg05681.html for more info.

Related branches

Pete Woods (pete-woods) wrote :

There are two things failing in here. Valgrind is detecting both:

1) An uninitialised value jump.
2) A variety of "possible" leaks inside Google Test

Each of these things seems to be out of my control. I think this is one of the few projects under CI that's running its tests under Valgrind. Anyway, the easy fix is to add some suppressions for the Google Test ones. They're probably false positives. However I think it's unlikely that these failures are caused by the new Qt version. More likely by something else, (new google test?).

Matthias Klose (doko) wrote :

I did rebuild valgrind for glibc-2.18. this did fix the test failure on amd64, but not i386.

Pete Woods (pete-woods) on 2014-01-02
Changed in libqtdbustest:
assignee: nobody → Pete Woods (pete-woods)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libqtdbustest at revision 29, scheduled for release in libqtdbustest, milestone Unknown

Changed in libqtdbustest:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqtdbustest - 0.2+14.04.20140303.1-0ubuntu1

---------------
libqtdbustest (0.2+14.04.20140303.1-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Valgrind is not present on all architectures. (LP: #1263926,
    #1263925, #1262638)
  * Valgrind doesn't like dlopens (LP: #1287135)
 -- Ubuntu daily release <email address hidden> Mon, 03 Mar 2014 13:02:05 +0000

Changed in libqtdbustest (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers