libqtdbustest, libusermetrics, unity-voice valgrind errors on Qt 5.2.1

Bug #1287135 reported by Timo Jyrinki on 2014-03-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libqtdbusmock
Critical
Pete Woods
libqtdbustest
Critical
Pete Woods
libusermetrics
Fix Released
Critical
Pete Woods
unity-voice
Critical
Pete Woods
libqtdbusmock (Ubuntu)
Undecided
Pete Woods
libqtdbustest (Ubuntu)
Undecided
Pete Woods
libusermetrics (Ubuntu)
Undecided
Pete Woods
unity-voice (Ubuntu)
Undecided
Pete Woods

Bug Description

For some reason the armhf build of libqtdbustest is giving valgrind errors with Qt 5.2.1, even though it succeeds on other architectures (i386, amd64, powerpc):

https://launchpad.net/~ci-train-ppa-service/+archive/landing-006/+sourcepub/3950873/+listing-archive-extra

It also built fine the last time lp:libqtdbustest was updated: https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+sourcepub/3807018/+listing-archive-extra

The complete earlier Qt 5.2(.1) rebuild is available for testing at:
https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2

Related branches

description: updated
tags: added: qt5.2
Changed in libqtdbustest:
assignee: nobody → Pete Woods (pete-woods)
Timo Jyrinki (timo-jyrinki) wrote :

Similarly with libqtdbusmock:

Changed in libqtdbusmock:
importance: Undecided → Critical
assignee: nobody → Pete Woods (pete-woods)
Timo Jyrinki (timo-jyrinki) wrote :

and libusermetrics: https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+build/5653675

Setting all Pete's branches to land via the Qt 5.2 landing silo.

Pete Woods (pete-woods) on 2014-03-03
Changed in libusermetrics:
assignee: nobody → Pete Woods (pete-woods)
status: New → In Progress
Changed in libqtdbustest:
status: New → In Progress
Changed in libqtdbusmock:
status: New → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

One more, unity-voice!

Regarding the valgrind problems themselves: "< pete-woods> Mirv: just so you know, I don't think these problems are due to Qt 5.2, I think it's upgrades to glibc that cause it"

summary: - libqtdbustest valgrind errors on Qt 5.2.1
+ libqtdbustest, libusermetrics, unity-voice valgrind errors on Qt 5.2.1
Pete Woods (pete-woods) on 2014-03-03
Changed in unity-voice:
assignee: nobody → Pete Woods (pete-woods)
status: New → In Progress
Changed in libusermetrics:
importance: Undecided → Critical
Changed in unity-voice:
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libqtdbustest (Ubuntu):
status: New → Confirmed
Pete Woods (pete-woods) on 2014-03-03
Changed in libqtdbustest (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Timo Jyrinki (timo-jyrinki) wrote :

Marking as Fix Committed to clean bug list, and all have also landed to the landing PPA so will be Fix Released when the landing PPA will be published.

Changed in libqtdbusmock:
status: In Progress → Fix Committed
Changed in libqtdbustest:
status: In Progress → Fix Committed
Changed in libusermetrics:
status: In Progress → Fix Committed
Changed in unity-voice:
status: In Progress → Fix Committed
Pete Woods (pete-woods) on 2014-03-05
Changed in libqtdbusmock (Ubuntu):
status: New → In Progress
Changed in libqtdbustest (Ubuntu):
status: Confirmed → In Progress
Changed in libusermetrics (Ubuntu):
status: New → In Progress
Changed in unity-voice (Ubuntu):
status: New → In Progress
Changed in libqtdbusmock (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Changed in libusermetrics (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Changed in unity-voice (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Changed in libqtdbusmock (Ubuntu):
status: In Progress → Fix Committed
Changed in libqtdbustest (Ubuntu):
status: In Progress → Fix Committed
Changed in libqtdbusmock (Ubuntu):
status: Fix Committed → In Progress
Changed in libqtdbustest (Ubuntu):
status: Fix Committed → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

Just to make clear, all of this has landed to the landing-006 PPA and is ready to be copied to archives.

Changed in libqtdbusmock (Ubuntu):
status: In Progress → Fix Committed
Changed in libqtdbustest (Ubuntu):
status: In Progress → Fix Committed
Changed in libusermetrics (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-voice (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-voice - 0.1+14.04.20140304-0ubuntu1

---------------
unity-voice (0.1+14.04.20140304-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Disable Valgrind on ARM (LP: #1287135)
 -- Ubuntu daily release <email address hidden> Tue, 04 Mar 2014 05:32:41 +0000

Changed in unity-voice (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqtdbustest - 0.2+14.04.20140303.1-0ubuntu1

---------------
libqtdbustest (0.2+14.04.20140303.1-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Valgrind is not present on all architectures. (LP: #1263926,
    #1263925, #1262638)
  * Valgrind doesn't like dlopens (LP: #1287135)
 -- Ubuntu daily release <email address hidden> Mon, 03 Mar 2014 13:02:05 +0000

Changed in libqtdbustest (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libusermetrics - 1.1.1+14.04.20140305-0ubuntu1

---------------
libusermetrics (1.1.1+14.04.20140305-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Disable Valgrind on ARM (LP: #1287135)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Wed, 05 Mar 2014 09:26:29 +0000

Changed in libusermetrics (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqtdbusmock - 0.2+14.04.20140304-0ubuntu1

---------------
libqtdbusmock (0.2+14.04.20140304-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Valgrind is not present on all architectures. (LP: #1263925,
    #1263926)
  * Disable Valgrind on ARM (LP: #1287135)
 -- Ubuntu daily release <email address hidden> Tue, 04 Mar 2014 05:30:00 +0000

Changed in libqtdbusmock (Ubuntu):
status: Fix Committed → Fix Released
Changed in libqtdbustest:
status: Fix Committed → Fix Released
Changed in libqtdbusmock:
status: Fix Committed → Fix Released
Changed in libusermetrics:
status: Fix Committed → Fix Released
Changed in unity-voice:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers