encoding problem with German umlauts

Bug #916994 reported by ambossarm on 2012-01-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libpar2
Medium
Andreas Moog

Bug Description

Running under different distros ubuntu, debian, ARCHLinux I have the problem with broken files that have German umlauts like öäü. I have to use wine and multipar or quickpar to repair the files. unrar works fine after that.

The shell displays the umlauts ok with "ls", par2* commands show an questionsmark in a square, like a broken unicode char.
I fear that the filenames are encoded with cp1252. But that should be no problem, because the par-files have the same name.

Andreas Moog (ampelbein) on 2012-03-04
Changed in libpar2:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Andreas Moog (amoog)
Sander Jonkers (jonkers) wrote :

I can confirm the problem with par2cmdline.

Based on your comment, I tried wine & multipar, and that works on the archive

    wine par2j.exe verify *3.par2

just handles the filenames with umlauts without problems.

Sander Jonkers (jonkers) wrote :

There is an interesting comment on http://forum.ubuntuusers.de/topic/par2-problem-mit-umlauten/#post-1917996 :

par2 r myfile.par2 myfile.*

That works for my files with umlauts: first par2 says "missing", but then it seems to go on with the files added with myfile.*, and it seems to work.

I *think* the more universal command is:

par2 r myfile.par2 *.rar

Can others verify/test this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers