no more notification using revision 34

Bug #586715 reported by arno_b on 2010-05-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Thunderbird Indicator
High
Unassigned

Bug Description

Using revision 34, I have no more notification of the received emails (it worked before using revision 30).
The error console says:
Error : this.indicatorStream is undefined
Source File : chrome://libnotifypopups/content/overlay.js
Line : 166

Using thunderbird 3.1 RC1 on ubuntu 10.04

arno_b (arno.b) wrote :

By no more notification, I mean: no green icon; no popup notification.

summary: - no more notifications using revision 34
+ no more notification using revision 34
Adam (aftereffex) wrote :

Hi arno_b,

I encountered the same error you did.

I took a look at the code, and created the following patch which fixes part of the problem. Unfortunately, I can't figure out why the icon doesn't turn green and the menu button show the current number of unread messages, but the patch does fix the problem with the popup indicator.

@libnotify-mozilla developers: is this project being actively developed? Integration with libnotify still doesn't work in the latest release of Thunderbird.

Ruben Verweij (ruben-verweij) wrote :

Thank you for your bug report. Could you please test this with the latest version from trunk? I believe it is fixed now. Just open a terminal, install bazaar if you don't have it (sudo apt-get install bzr) and type bzr branch lp:libnotify-mozilla to get the latest code. Now run the build.sh file and a .xpi should be created which you can install in Thunderbird. Thanks in advance!
Also, this project is still being developed, but I'm a student and often find it hard to find the time to do this. ;)

Changed in libnotify-mozilla:
assignee: nobody → Ruben Verweij (ruben-verweij)
importance: Undecided → High
status: New → In Progress
arno_b (arno.b) wrote :

Unfortunately this issue still occurs with the last revision (37).
Here is the message from the error console:
Erreur : this.indicatorStream is undefined
Fichier Source : chrome://libnotifypopups/content/overlay.js
Ligne : 167

Feature "test notification" works well.

Thomas Hannigan (headofbucket) wrote :

I've got the same issue with 0.2. Found this in the logs, Might help?

Traceback (most recent call last):
  File "/home/buckethead<email address hidden>/python/indicator.py", line 7, in <module>
    import indicate
ImportError: No module named indicate

Ruben Verweij (ruben-verweij) wrote :

Could someone please test this again with the latest version from trunk? Just open a terminal, install bazaar if you don't have it (sudo apt-get install bzr) and type bzr branch lp:libnotify-mozilla to get the latest code. Now run the build.sh file and a .xpi should be created which you can install in Thunderbird. Also, make sure that python-indicate is installed (should be on a default installation of Ubuntu, as far as I know). Thanks in advance!

Changed in libnotify-mozilla:
status: In Progress → Incomplete
arno_b (arno.b) wrote :

The issue is still here. I have the following messages:
[tbindicator]: Flag changed: Status
[tbindicator]: Flag changed: Status
[tbindicator]: Remove this message please!
[tbindicator]: hide indicator: Courrier entrant (Triskell)
[tbindicator]: index: 0
[tbindicator]: cmd: hide::Courrier entrant (Triskell)
[tbindicator]: Flag changed: msgLoaded
[tbindicator]: Flag changed: Status
[tbindicator]: Indicator for new message!
[tbindicator]: init send indicator
[tbindicator]: true
[tbindicator]: Bubble for new message!
[tbindicator]: handleNewMailReceive
[tbindicator]: not displaying message
[tbindicator]: Flag changed: Status
Erreur : tbindicator is null
Fichier Source : chrome://tbindicator/content/overlay.js
Ligne : 307
[tbindicator]: Flag changed: Status
[tbindicator]: Remove this message please!
[tbindicator]: hide indicator: Courrier entrant (Triskell)
[tbindicator]: index: -1
[tbindicator]: Flag changed: msgLoaded

I will try wiyh a clean profile and with an other computer.

Ruben Verweij (ruben-verweij) wrote :

I have recently made some fixed again to the code. Could someone please test if this bug still occurs with the latest trunk version? Thanks in advance!

Shrijit Nair (shrijith1) wrote :

Trunk Version works perfectly! TB 3.12, Ubuntu 10.04

arno_b (arno.b) wrote :

It works for me too \o/
TB-64bits 3.1.2 ubuntu 10.04

Changed in libnotify-mozilla:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers