ath3k bluetooth adapter cannot load firmware

Reported by Alexander Hall on 2012-04-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libmtp
Unknown
Unknown
libmtp (Debian)
Fix Released
Unknown
libmtp (Ubuntu)
Undecided
Unassigned

Bug Description

Have the latest linux-firmware, and linux-image. On boot (or on first connection of BT adapter), it is unable to load the provided firmware to the device:

[ 158.352293] usb 4-2: new full-speed USB device number 2 using uhci_hcd
[ 159.681747] Bluetooth: Atheros AR30xx firmware driver ver 1.0
[ 164.706080] Bluetooth: Can't change to loading configuration err
[ 164.706173] ath3k: probe of 4-2:1.0 failed with error -110
[ 164.706255] usbcore: registered new interface driver ath3k

lsusb output:
Bus 004 Device 002: ID 0cf3:3000 Atheros Communications, Inc. AR3011 Bluetooth (no firmware)

This is fixed in libmtp 1.1.3; libmtp-dev from Debian unstable should be synced in order to fix this issue; there are no ubuntu only patches on the current build included with 12.04

Additonal sync request info can be found here:
https://bugs.launchpad.net/ubuntu/+source/libmtp/+bug/975222/comments/11 (description of changes since 12.4 build)
https://bugs.launchpad.net/ubuntu/+source/libmtp/+bug/975222/comments/12 (build log)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image 3.2.0.22.24
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ahall 1798 F.... pulseaudio
Date: Fri Apr 6 10:57:46 2012
HibernationDevice: RESUME=UUID=d9a2d5b9-f8b9-4851-a60a-7aeb32cd0971
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Hewlett-Packard HP Pavilion dv6700 Notebook PC
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=29806a0e-3742-4e63-b441-7b06a74c1231 ro quiet splash vt.handoff=7
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-04-01 (4 days ago)
dmi.bios.date: 06/16/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.58
dmi.board.name: 30D2
dmi.board.vendor: Quanta
dmi.board.version: 79.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.58:bd06/16/2008:svnHewlett-Packard:pnHPPaviliondv6700NotebookPC:pvrRev1:rvnQuanta:rn30D2:rvr79.2E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6700 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Alexander Hall (compuguy1088) wrote :
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Brad Figg (brad-figg) on 2012-04-06
Changed in linux (Ubuntu):
status: New → Confirmed
Alexander Hall (compuguy1088) wrote :

I have had the issue since I bought the BT adapter, on Ubuntu 11.10. The linux-firmware package 1.75 (pushed as a result of this bug posting: https://bugs.launchpad.net/linux/+bug/714862). I am not aware of a kernel version not having this problem (on my primary laptop). The odd thing is that this bt adapter works without the -110 error on another computer (HP 110-3000 netbook).

Alexander Hall (compuguy1088) wrote :

Based on this comment. The issue with the bluetooth adapter seems to be related to libmtp: https://bugs.launchpad.net/linux/+bug/714862/comments/53

no longer affects: linux-firmware (Ubuntu)
Changed in libmtp (Debian):
status: Unknown → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Alexander Hall (compuguy1088) wrote :

Based on information from the debian bug report, the kernel (ubuntu or mainline) doesn't matter. It's tied to udev rules implemented by the package "libmtp-runtime". I removed the package, and the bluetooth adapter works properly on boot.

no longer affects: linux (Ubuntu)
Alexander Hall (compuguy1088) wrote :

I've also removed the linux kernel from the bug, because is not the offending package.

tags: removed: needs-upstream-testing
Alexander Hall (compuguy1088) wrote :

Most likely, upgrading the package from 1.1.2 to 1.1.3 would solve the issues with the udev rules in libmtp-runtime (located in: /lib/udev/mtp-probe):
http://sourceforge.net/projects/libmtp/files/libmtp/1.1.3/

tags: added: upgrade-software-version
tags: added: patch
Alessio Treglia (quadrispro) wrote :

Dear release managers,

please sync libmtp 1.1.3-1 from Debian unstable in order to fix this bug.

Thanks in advance.

Alessio Treglia (quadrispro) wrote :

diff of debian/changelog since the latest version available in Precise:

libmtp (1.1.3-1) unstable; urgency=low

   * New upstream bugfix release:
     - Soname libmtp.so.9.0.3 - binary compatible.
     - Probably nailed the bugs in the Samsung Galaxy Tab S2 family
       of devices. Ignacio Martinez helped us fixing this!
     - Build fixes by Alessio Treglia and others.
     - A horde of new devices in the database.
   * Remove patches applied upstream:
     - 0001-broken_object_info.patch
     - 0002-devicedb_updates.patch
     - 2001-pkgconfig_requires.patch
   * Refresh 1001-kfreebsd_hurd_ftbfs.patch.
   * Refresh symbols file.
   * Update debian/copyright.

 -- Alessio Treglia <email address hidden> Tue, 03 Apr 2012 08:45:30 +0200

libmtp (1.1.2-4) unstable; urgency=low

   * libmtp requires either libusb or libusb-1.0 to build, but libmtp.pc
     does not update the Requires field accordingly. (Closes: #666713)
   * Build depend on auto{conf,make,tools-dev}.
   * Bump Standards.

 -- Alessio Treglia <email address hidden> Sun, 01 Apr 2012 12:13:02 +0200

libmtp (1.1.2-3) unstable; urgency=low

   * Port libmtp-dev to Architecture: any.
   * Set libmtp-dev depends on libusb-1.0-0-dev on Linux and on libusb-dev
     on non-linux. Thanks to Aaron for the report! (Closes: #665272)
   * 0001-broken_object_info.patch (taken from upstream git):
     - src/device-flags.h: New DEVICE_FLAG_BROKEN_GET_OBJECT_INFO,
       some devices return bad data on GetObjectInfo.
     - src/ptp.c: Properly handle bad data returned by GetObjectInfo.
   * Several updates to the devices DB (taken from upstream git):
     - Attempt to fix issues with SonyEricsson LT15i (LP: #902962)
     - New devices:
       + Transformer Prime (an unknown version)
       + HP Touchpad
       + Another Acer Iconia Tab
       + Nook Color
       + Sony Tablet S1
       + Sony NWZ-B163F
       + Sony ST15i Xperia Mini
       + Toshiba Thrive
       + NEC FOMA N01A
       + Some Archos devices
     - Consolidate bug flags for many devices.

 -- Alessio Treglia <email address hidden> Sat, 31 Mar 2012 11:12:37 +0200

Alessio Treglia (quadrispro) wrote :

The buildlog is attached

description: updated
description: updated
Martin Pitt (pitti) wrote :

Neither the upstream nor the Debian bug have a confirmation that this works with 1.1.3-1. Has this version actually been tested wtih this player?

Otherwise this looks fairly good, nice to have some more supported devices.

Alessio Treglia (quadrispro) wrote :

Although it should work, unfortunately I cannot confirm this really works since I don't have any such device.
However if ubuntu-release agrees, I would go ahead sync'ing the package from Debian sid: I'm just waiting for your ACK.

Martin Pitt (pitti) wrote :

The other changes are bug fixes and new devices, approved.

Changed in libmtp (Ubuntu):
status: New → Triaged
Alessio Treglia (quadrispro) wrote :

$ syncpackage -b 975222 -d unstable libmtp

Now waiting for the sync to be done.

Changed in libmtp (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Sync accepted. This should hopefully fix this bug, if not, please reopen. Thanks!

Changed in libmtp (Ubuntu):
status: Fix Committed → Fix Released
walterav (walterav) wrote :

I can confirm this fix works for the following device:
ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth, "Trust usb 3.0 mini usb adapter"

After re-installing the removed 1.1.2-2 version of libmtp-runtime by its updated 1.1.3.1 version by just updating/upgrading from the default precise repository, the adapter works fine!

Gabriel Coimbra (synamics) wrote :

The same occurs at the ath9k driver, someone report it!!

Changed in libmtp (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.