File signatures missing in metalink4

Bug #1466506 reported by Hubert Tarasiuk on 2015-06-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libmetalink
High
Tatsuhiro Tsujikawa

Bug Description

I am using libmetalink 0.1.2.

I am trying to parse XML file with PGP signature (sample for Curl attached).
After calling metalink_parse_file, the resulting metalink_t structure has value 0x0 on files[0]->signature field.

I tried other Metalink4 files with same result.

I did not check Metalink3 files.

Let me know if you need any more information.

Thank you for assistance.

Hubert Tarasiuk

Revision history for this message
Hubert Tarasiuk (hubert-tarasiuk) wrote :
Revision history for this message
Tatsuhiro Tsujikawa (t-tujikawa) wrote :

Thank you for reporting this bug.
Fix committed via r155.

Changed in libmetalink:
assignee: nobody → Tatsuhiro Tsujikawa (t-tujikawa)
importance: Undecided → High
milestone: none → libmetalink-0.1.3
status: New → Fix Committed
Changed in libmetalink:
milestone: libmetalink-0.1.3 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers