Support FD.o Desktop Actions spec

Bug #942042 reported by Ted Gould on 2012-02-27
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Ted Gould
libindicator
Fix Released
High
Ted Gould
libindicator (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

We should be using the FD.o Desktop actions instead of our homebrew.

http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s08.html

Related branches

Ted Gould (ted) on 2012-02-27
Changed in libindicator:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Ted Gould (ted) on 2012-02-27
Changed in unity:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Changed in libindicator:
status: Confirmed → In Progress
milestone: none → 0.4.93
Changed in libindicator (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 0.4.92-0ubuntu2

---------------
libindicator (0.4.92-0ubuntu2) precise; urgency=low

  * Backport support for the fdo desktop action spec, that's required
    to get unity lists to work with the new syntax (lp: #942042)
 -- Sebastien Bacher <email address hidden> Fri, 02 Mar 2012 12:08:09 +0100

Changed in libindicator (Ubuntu):
status: Fix Committed → Fix Released
Ted Gould (ted) on 2012-03-02
Changed in libindicator:
status: In Progress → Fix Committed
Ted Gould (ted) on 2012-03-07
Changed in libindicator:
status: Fix Committed → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-09
Changed in unity:
milestone: none → 5.6.0
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Dmitry Shachnev (mitya57) wrote :

@Ted: Currently in Thunderbird we have a "TargetEnvironment=Messaging Menu;Unity" line which makes the shortcut visible in Messaging Menu. Is there a way to do that with the FDo compliant desktop file (the static way, I know about the dynamic one)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers