Jenkins build failure: parse err in gen-indicate-interface.xml.c

Bug #931759 reported by Allan LeSage on 2012-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libindicate
Fix Released
Critical
Charles Kerr

Bug Description

Jenkins build failing, apparently choking on an xml config file? Marking up to high priority as we'd like to get this build going--if you find that Jenkins' configuration is at fault pls. ping alesage.

Related branches

Allan LeSage (allanlesage) wrote :
Ted Gould (ted) wrote :

Something funny has to be happening with the basename. Not sure what. I've attached a branch that should print it out in the build log. Can you run with that branch so we can get more data please?

Changed in libindicate:
status: New → Incomplete
Ted Gould (ted) on 2012-02-17
Changed in libindicate:
importance: High → Critical
Changed in libindicate:
status: Incomplete → New
Olli Ries (ories) on 2012-03-01
Changed in libindicate:
status: New → Triaged
assignee: nobody → charles (charlesk)
Charles Kerr (charlesk) wrote :

I'm able to reproduce from trunk this with these steps:

  $ cd indicator-appmenu
  $ mkdir -p build/gtk3/
  $ cd build/gtk3/
  $ ../../configure --srcdir=$PWD/../.. --prefix=/usr
  $ make
  $ make check

hud.interface.c is being built in indicator-appmenu/build/gtk3/src/, but POTFILES doesn't know to look for it there -- it's looking in indicator-appmenu/src/ instead.

This raises an interesting (to me, at least) question about how to get POTFILES.in to understand where to look for files generated from BUILT_SOURCES. However, there is a much faster solution to this ticket: there's nothing in hud.interface.c that needs translation, so removing it from POTFILES.in resolves the problem.

Charles Kerr (charlesk) wrote :

The previous comment was intended for Bug #938986

Charles Kerr (charlesk) wrote :

Allan, two questions:

1. that second log doesn't seem to have the extra information that would show up from ted's branch. Are you certain that libindicate-3.log was generated from the correct branch?

2. would it be possible for you to attach the file "gen-indicate-interface.xml.c" that's generated by a failed build?

Changed in libindicate:
status: Triaged → In Progress
Allan LeSage (allanlesage) wrote :
Allan LeSage (allanlesage) wrote :

Generated by just catting the file during make.

Charles Kerr (charlesk) wrote :

Status update: lp:~charlesk/libindicate/lp-931759 gets us most of the way there but it's still a work in progress -- there are several build failures here :)

1. Allan found the basename fix by comparing to some of the other indicator builds; the fix was to add notdir

2. There were mono build issues that were resolved in the same way that they were libappindicator by lp:~charlesk/libappindicator/lp-931764 and are described at https://code.launchpad.net/~charlesk/libappindicator/lp-931764/+merge/96277/comments/207910

3. Lastly, there is a packaging issue at the very end of the build that Allan is looking into.

Allan LeSage (allanlesage) wrote :

Item #3 in Charles' comment is fixed, the ball is turning green; just re-applied a prior fix from https://bugs.launchpad.net/ubuntu/+source/libindicate/+bug/632746 which apparently snuck out of our codebase. Charles' changes and mine have been merged into a single merge request at https://code.launchpad.net/~allanlesage/libindicate/lp931759 ; forgive me Charles for stealing your merge-request.

Charles Kerr (charlesk) wrote :

Fix committed in http://bazaar.launchpad.net/~indicator-applet-developers/libindicate/trunk.0.7/revision/446

Allan, my bzr-fu isn't strong enough yetretroactively change my "bzr rm; bzr add" modifications to "bzr mv", so I patched by hand instead of merging...

But for the record (Olli ;) -- Allan & I worked tag-team on this and bug #931764 together for about 6 hours yesterday, this was definitely a 50-50 effort

Changed in libindicate:
status: In Progress → Fix Committed
Ted Gould (ted) on 2012-03-21
Changed in libindicate:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in libindicate:
milestone: none → 0.6.91
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers