libgrip: multitouch gesture library for GTK

Multi-touch rotates the wrong way

Reported by Alexander Hunziker on 2011-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgrip
Undecided
Unassigned
eog (Ubuntu)
Medium
Chase Douglas

Bug Description

I am using an Apple Magic Trackpad with my Ubuntu system. I can rotate images in eog using the trackpad by performing a "turn" gesture. However, the image is rotated in the wrong direction.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eog 3.1.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Tue Sep 13 11:44:00 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: eog
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (0 days ago)

Related branches

Stephen M. Webb (bregma) wrote :

I can see this antirotation too.

Changed in eog (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report.

Sorry Chase, assigning to you because I'm not sure what component or team to subscribe there, could you triage it?

Changed in eog (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
importance: Undecided → Medium
affects: eog (Ubuntu) → libgrip (Ubuntu)
Stephen M. Webb (bregma) on 2011-09-23
Changed in libgrip:
status: New → Confirmed
Chase Douglas (chasedouglas) wrote :

This is fairly obvious when you have an image that doesn't look similar depending on which way you rotate it :). That was why I never really saw this issue.

This does not occur in evince, so it's likely not an issue with libgrip. Thus, I'm returning the bug to eog. A small patch to change rotation direction should fix this up.

affects: libgrip (Ubuntu) → eog (Ubuntu)
Changed in libgrip:
status: Confirmed → Invalid
Changed in eog (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.1.92-0ubuntu2

---------------
eog (3.1.92-0ubuntu2) oneiric; urgency=low

  * Fix rotation gesture direction (LP: #848799)
 -- Chase Douglas <email address hidden> Fri, 23 Sep 2011 11:06:08 -0700

Changed in eog (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers