Transition to gstreamer 1.0

Bug #1085118 reported by Iain Lane on 2012-11-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Miro
Unknown
Unknown
libgnome-media-profiles
New
Medium
gnome-dvb-daemon (Ubuntu)
Undecided
Unassigned
gnome-media (Ubuntu)
Undecided
Unassigned
gnomeradio (Ubuntu)
Undecided
Unassigned
goobox (Ubuntu)
Undecided
Unassigned
gtkpod (Debian)
Fix Released
Unknown
gtkpod (Ubuntu)
Undecided
Unassigned
libgnome-media-profiles (Ubuntu)
Undecided
Unassigned
miro (Debian)
Fix Released
Unknown
miro (Ubuntu)
Undecided
Unassigned
rhythmbox-radio-browser (Ubuntu)
Undecided
Unassigned
totem-plugin-arte (Ubuntu)
Undecided
Nicolas Delvaux

Bug Description

Some core libraries have been transitioned to build against gstreamer 1.0 API in Raring now.

This will cause problems when applications which still use the old 0.10 (deprecated) API and a transitioned library in the same process. In the worse case you'll experience crashes.

Such applications need to transition to the GStreamer 1.0 API.

http://cgit.freedesktop.org/gstreamer/gstreamer/tree/docs/random/porting-to-1.0.txt
http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gstreamer/html/index.html

Iain Lane (laney) wrote :

Seb said he'd look at gnome-media

Changed in gnome-media (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
status: New → In Progress

I made patch for transition to gstreamer 1.0 API, but, because gnomeradio use libgnome-media-profiles to get audio formats for recording, I prefer to wait with until gnome-media adds new audio formats profiles for gstreamer 1.0 to registry.

Changed in gnomeradio (Ubuntu):
assignee: nobody → POJAR GEORGE (geoubuntu)
status: New → In Progress

Patch for libgnome-media-profiles

Changed in gnomeradio (Ubuntu):
status: In Progress → Confirmed
Changed in gnomeradio (Ubuntu):
assignee: POJAR GEORGE (geoubuntu) → nobody
Changed in libgnome-media-profiles (Ubuntu):
status: New → Confirmed

libgnome-media-profiles Port to GStreamer 1.0 API

Nicolas Delvaux (malizor) wrote :

Do you know if Debian plan to do the same transition soon (at least in experimental)?
If possible, I would prefer fixing this in Debian and then let the update reach Ubuntu in the usual way.

totem-plugin-arte just needs two change in its dependencies (gstreamer0.10-plugins-bad becomes gstreamer1.0-plugins-bad and gstreamer0.10-ffmpeg becomes gstreamer1.0-libav). Otherwise, it already works.

Changed in totem-plugin-arte (Ubuntu):
status: New → Confirmed
assignee: nobody → Nicolas Delvaux (malizor)
Sebastien Bacher (seb128) wrote :

@POJAR GEORGE: thanks for the work, I'm sponsoring the libgnome-media-profiles update

Sebastien Bacher (seb128) wrote :

@Nicolas: not sure when Debian plan to transition, they are currently frozen for their next release

Sebastien Bacher (seb128) wrote :

@POJAR GEORGE:

> until gnome-media adds new audio formats profiles for gstreamer 1.0 to registry.

not sure that's going to happen, libgnome-media-profile is being replaced, you should be able to use directly GstEncodingProfile, see http://git.gnome.org/browse/sound-juicer/commit/?id=862e7756ca714ad873afcab9b603e5ca8e59b862 for an example of transition from GnomeMediaProfile to GstEncodingProfile

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnome-media-profiles - 3.0.0-1ubuntu1

---------------
libgnome-media-profiles (3.0.0-1ubuntu1) raring; urgency=low

  * debian/patches/02-gstreamer-1.0.patch
    - Port to GStreamer-1.0 API. (LP: #1085118)
  * debian/control.in:
    - Bump Standards-Version to 3.9.3. No further changes.
    - Update Maintainer field to Ubuntu Core Developers.
    - Build-Depends: libgstreamer1.0-dev, libgstreamer-plugins-base1.0-dev.
 -- POJAR GEORGE <email address hidden> Sun, 02 Dec 2012 15:07:49 +0000

Changed in libgnome-media-profiles (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-dvb-daemon (Ubuntu):
status: New → Confirmed
Changed in goobox (Ubuntu):
status: New → Confirmed
Changed in gtkpod (Ubuntu):
status: New → Confirmed
Changed in miro (Ubuntu):
status: New → Confirmed
Changed in rhythmbox-radio-browser (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnomeradio - 1.8-2ubuntu6

---------------
gnomeradio (1.8-2ubuntu6) raring; urgency=low

  * debian/patches/gnomeradio-build.patch: Fix build in amd64, due to casting
    gpointers to (gint). Now we use the GPOINTER_TO_INT macro wherever it's
    needed.
  * debian/patches/gnomeradio-set_pulse_role.patch: Set the pulse media role.
    (LP: #1079573)
  * debian/patches/gnomeradio-eos_message.patch: Send EOS before we stop
    recording. (LP: #1079625)
  * debian/patches/gnomeradio-presets.patch: Added option for sorting preset
    stations with up or down arrow buttons. (LP: #1082274)
  * debian/patches/gnomeradio-station_list.patch: Added option to export/import
    list of preset stations to/from xml file. (LP: #69791)
  * debian/patches/gnomeradio-gstreamer-1.0.patch: Port to GStreamer 1.0 API.
    (LP: #1085118)
  * Update debian/patches/gnomeradio-record_information: Get information about
    audio profile.
  * debian/control: Build-Depends: libgstreamer1.0-dev,
    libgstreamer-plugins-base1.0-dev, libxml2-dev.
 -- POJAR GEORGE <email address hidden> Fri, 16 Nov 2012 07:16:10 +0000

Changed in gnomeradio (Ubuntu):
status: Confirmed → Fix Released
Changed in libgnome-media-profiles:
importance: Unknown → Medium
status: Unknown → New
Iain Lane (laney) wrote :

I had to cherry-pick https://gitorious.org/totem-plugin-arte/mainline/commit/7553f2a6eb3bae7acd398d843c5b9004682e5cf0, but I'm going to upload -arte.

Thanks for the info Nicolas. I expect you'll get this fix in Debian through the new upstream so I won't forward it on explicitly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem-plugin-arte - 3.1.2-1ubuntu1

---------------
totem-plugin-arte (3.1.2-1ubuntu1) raring; urgency=low

  * Switch dependencies for GStreamer 1.0 (LP: #1085118)
  * debian/patches/totem-3.6: Totem's add_to_playlist_and_play lost its third
    argument (add_to_recent). Upstream cherry-pick
    (7553f2a6eb3bae7acd398d843c5b9004682e5cf0)
 -- Iain Lane <email address hidden> Mon, 10 Dec 2012 14:32:24 +0000

Changed in totem-plugin-arte (Ubuntu):
status: Confirmed → Fix Released
Nicolas Delvaux (malizor) wrote :

Thanks Iain.
I'm currently looking for a sponsor to upload the new release on Debian experimental (gstreamer1.0 transition seems to happen there too).
https://mentors.debian.net/package/totem-plugin-arte

I planned to ask to sync the package in Ubuntu when it will be available in Debian, but you were too quick. :-)

On Mon, Dec 10, 2012 at 07:22:48PM -0000, Nicolas Delvaux wrote:
> Thanks Iain.
> I'm currently looking for a sponsor to upload the new release on Debian experimental (gstreamer1.0 transition seems to happen there too).
> https://mentors.debian.net/package/totem-plugin-arte
>
> I planned to ask to sync the package in Ubuntu when it will be available
> in Debian, but you were too quick. :-)

Oh cool, I see totem has indeed been transitioned there. That's nice. I
can look and sponsor the package for you tomorrow if all is well.
Cheers :-)

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Iain Lane (laney) wrote :

sponsored to exp, thank you. You'lll be able to request the sync soon.

Nicolas Delvaux (malizor) wrote :

Thanks again Iain :-)

Changed in gnome-media (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
status: In Progress → Triaged
Changed in gtkpod (Debian):
status: Unknown → Fix Released
Changed in miro (Debian):
status: Unknown → New
Colin Watson (cjwatson) wrote :

gnome-media was removed from Debian a while back, and I've just removed it from Ubuntu too.

Changed in gnome-media (Ubuntu):
status: Triaged → Won't Fix
Changed in miro (Debian):
status: New → Fix Released
Laurent Bigonville (bigon) wrote :

Goobox uses gst 1.0 already

Changed in goobox (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :
Download full text (8.8 KiB)

This bug was fixed in the package gnome-dvb-daemon - 1:0.2.91~git20170110-2

---------------
gnome-dvb-daemon (1:0.2.91~git20170110-2) unstable; urgency=medium

  * debian/copyright: Update the copyright file

 -- Laurent Bigonville <email address hidden> Mon, 27 Feb 2017 21:02:05 +0100

gnome-dvb-daemon (1:0.2.91~git20170110-1) unstable; urgency=medium

  [ Emilio Pozuelo Monfort ]
  * New upstream release.
    - Ported to libgee-0.8. Closes: #753861.
    - Ported to GStreamer 1.0. Closes: #785816.
    - Ported to Python 3.
  * Updated (build-)dependencies.

  [ Michael Biebl ]
  * Remove Debian menu entries.

  [ Andreas Henriksson ]
  * Add gstreamer1.0-tools build-dependency
    - as configure.ac requires 'gst-inspect-1.0'.
  * Add gstreamer1.0-plugins-bad build-dependency
    - as configure.ac requires 'tsparse' plugin.
  * Add debian/patches/gstreamer-mpegts-1.0-vapi.patch
    - vapi/gstreamer-mpegts-1.0.vapi is missing in tarball.
  * debian/rules: switch from dh_python2 to dh_python3

  [ Laurent Bigonville ]
  * New GIT snapshot
    - Now build grilo plugin, rename totem-plugins-dvb-daemon to
      grilo-plugins-dvb-daemon
  * debian/control.in: Drop gnome-icon-theme from the dependencies, do not
    force an icon theme and rely on the one installed by the metapackages
  * Switch from cdbs to dh sequences
  * debian/control.in: Bump debhelper compatibility version to 10
  * debian/control.in: Bump Standards-Version to 3.9.8 (no further changes)
  * Drop debian/patches/gstreamer-mpegts-1.0-vapi.patch, not needed anymore
  * Add debian/patches/fix-icon-logo.patch: Fix some cosmetic issues
  * debian/control.in: Make gnome-dvb-client depends against dtv-scan-tables
    instead of dvb-apps

 -- Laurent Bigonville <email address hidden> Wed, 22 Feb 2017 11:45:51 +0100

gnome-dvb-daemon (1:0.2.10-1) unstable; urgency=low

  [ Jeremy Bicha ]
  * New upstream release
  * debian/control.in:
    - Update homepage and add Vcs fields
    - Build with default valac. Closes: #709693

  [ Michael Biebl ]
  * debian/rules: Include gnome-get-source.mk for the "get-orig-source"
    target.

 -- Michael Biebl <email address hidden> Mon, 26 Aug 2013 22:52:19 +0200

gnome-dvb-daemon (1:0.2.9-1) unstable; urgency=low

  * New upstream release

 -- Sebastian Reichel <email address hidden> Mon, 21 May 2012 16:59:08 +0200

gnome-dvb-daemon (1:0.2.8-1) unstable; urgency=low

  * New upstream release (Closes: #667059)
  * Bump Debian Standards Version to 3.9.3
  * Switch from DEP5 to Debian Copyright Format 1.0

 -- Sebastian Reichel <email address hidden> Wed, 04 Apr 2012 21:27:24 +0200

gnome-dvb-daemon (1:0.2.7-2) unstable; urgency=low

  * Tighten dependencies between the packages (Closes: #652576)
  * Use Arch: all for gnome-dvb-client, since it's written in python

 -- Sebastian Reichel <email address hidden> Tue, 20 Dec 2011 23:31:18 +0100

gnome-dvb-daemon (1:0.2.7-1) unstable; urgency=low

  * New upstream release
     - adds Gnome 3 compatibility (Closes: #650073)
     - fixes miredo bug (Closes: #627349)
  * Bump Debian Standards Version to 3.9.2
  * Update watch file
  * debian/copyright: Use DEP5 Format

 -- Sebastian Reichel <email address hidden> Thu, 15 Dec 2011 02:58:39 ...

Read more...

Changed in gtkpod (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-dvb-daemon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.