Debconf interactions no longer working

Bug #1627757 reported by Larry Price on 2016-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Libertine
Status tracked in Devel
Devel
Medium
Larry Price
Trunk
Medium
Larry Price
libertine (Ubuntu)
Medium
Larry Price

Bug Description

Yakkety, libertine trunk, python3-lxc 2.0.4.

To reproduce:

* Create a container
* Enable multiarch
* In the GUI, install "steam"
* Navigate to the PackageInfoView
* In the informational section, you are prompted to agree to TOS
* Type "1" to disagree or "2" to agree and hit Return

Nothing happens. The QProcess believes that it has sent the bytes to the process, but it seems that the container never gets it.

Related branches

Larry Price (larryprice) on 2016-09-26
Changed in libertine:
importance: Undecided → Medium
status: New → Triaged
Larry Price (larryprice) wrote :

I'm fairly certain this is directly related to a bug I've filed with lxc where attach_wait permanently steals stdin from the python process (https://github.com/lxc/lxc/issues/1137).

After digging through the python-lxc code a bit, it's unclear to me why this might be happening. Also considering that the bug I filed has been completely ignored, I think we'll need to find a workaround instead of relying on a real fix upstream.

I'm going to investigate possibly pushing the attach_wait command into its own process, and then redirecting stdin/stdout as possible.

Changed in libertine:
status: Triaged → In Progress
assignee: nobody → Larry Price (larryprice)
Larry Price (larryprice) wrote :

Lots more research later, I've found that this is only happening on yakkety. I created a xenial container and tried to install steam, and was able to complete the install just fine. I've also noted that there are some strange characters that show up in the yakkety install details. I do not know if this has to do with versions of apt, versions of the steam deb, or something else entirely. This could be caused by the fact that yakkety is not currently supported by steam.

Larry Price (larryprice) wrote :

Mystery solved - the issue actually stems from using the "readline" frontend in general. If we instead fallback to the "teletype" frontend, everything works fine.

¯\_(ツ)_/¯

Will push a fix and cli update shortly.

Fix committed into lp:libertine at revision 307, scheduled for release in libertine, milestone Unknown

Changed in libertine:
status: In Progress → Fix Committed
Changed in libertine (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Larry Price (larryprice)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine - 1.4.2+16.10.20161003-0ubuntu1

---------------
libertine (1.4.2+16.10.20161003-0ubuntu1) yakkety; urgency=medium

  [ Chris Townsend ]
  * Add a new update_apt_cache method and call that when needed, especially
    when installing new packages. (LP: #1625627)
  * Install matchbox-window-manager instead of the matchbox metapackage in
    a container. (LP: #1628563)

  [ Larry Price ]
  * Remove bad status update preventing archive removal from container.
  * Make debconf interactions work correctly from GUI. (LP: #1627757)
  * Fix crash on start in Unity 7 when launching from the dash.
    (LP: #1620016)

 -- Christopher Townsend <email address hidden> Mon, 03 Oct 2016 19:50:24 +0000

Changed in libertine (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.