Container's apt cache should be updated before installing new packages

Bug #1625627 reported by Christopher Townsend on 2016-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Libertine
Status tracked in Devel
Devel
Medium
Christopher Townsend
Trunk
Medium
Christopher Townsend
libertine (Ubuntu)
Medium
Christopher Townsend

Bug Description

When installing new packages, the container's apt cache should be updated first to avoid issues where package versions are out of date and the package install fails.

Related branches

Changed in libertine (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Fix committed into lp:libertine at revision 303, scheduled for release in libertine, milestone Unknown

Changed in libertine:
status: In Progress → Fix Committed
Changed in libertine (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Christopher Townsend (townsend)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine - 1.4.2+16.10.20161003-0ubuntu1

---------------
libertine (1.4.2+16.10.20161003-0ubuntu1) yakkety; urgency=medium

  [ Chris Townsend ]
  * Add a new update_apt_cache method and call that when needed, especially
    when installing new packages. (LP: #1625627)
  * Install matchbox-window-manager instead of the matchbox metapackage in
    a container. (LP: #1628563)

  [ Larry Price ]
  * Remove bad status update preventing archive removal from container.
  * Make debconf interactions work correctly from GUI. (LP: #1627757)
  * Fix crash on start in Unity 7 when launching from the dash.
    (LP: #1620016)

 -- Christopher Townsend <email address hidden> Mon, 03 Oct 2016 19:50:24 +0000

Changed in libertine (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers