[enhancement] Support copy-paste between X and Mir

Bug #1471998 reported by Robert Ancell on 2015-07-06
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Libertine
Status tracked in Devel
Devel
Medium
Christopher Townsend
Trunk
Medium
Christopher Townsend
Mir
Fix Released
High
Brandon Schaefer
content-hub (Ubuntu)
Medium
Unassigned
libertine (Ubuntu)
Medium
Christopher Townsend
mir (Ubuntu)
Undecided
Unassigned
qtmir (Ubuntu)
High
Daniel d'Andrada
qtubuntu (Ubuntu)
High
Daniel d'Andrada

Bug Description

X applications should be able to paste from Mir applications and vice versa.

Related branches

Changed in xorg-server (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Robert Ancell (robert-ancell)
tags: added: xmir
Changed in xorg-server (Ubuntu):
status: In Progress → Triaged
assignee: Robert Ancell (robert-ancell) → nobody
Changed in xorg-server (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

The Unity 8 interface:
- Use libcontent-hub
- On X selection ownership initiate a transfer to "pasteboard"
- Charge the transfer with content pulled from the X client
- Monitor pasteboard for available content (not implemented yet)
- Pull content from content hub when X client pastes
- Mir will provide cookies for authentication (not implemented yet)

Robert Ancell (robert-ancell) wrote :

Can implement copy from Unity 8 to XMir with current libcontent-hub API, cannot implement copy from X to Unity 8.
However, a new object will be implemented in libcontent-hub that contains "pasteboard" specific methods that will need to switch to when it is implemented.

tags: added: enhancement
summary: - Support copy-paste between X and Mir
+ [enhancement] Support copy-paste between X and Mir
Changed in xorg-server (Ubuntu):
importance: Medium → Low
Changed in mir:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in mir:
milestone: none → 0.19.0
Changed in mir:
milestone: 0.19.0 → 0.20.0

The work needed for this needs to land in 0.19 (or so im told?). Should i keep this at 0.19? Or just leave at 0.20 until its landed then move it to 0.19?

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.20.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
milestone: 0.20.0 → 0.19.0
Daniel van Vugt (vanvugt) wrote :

When we discussed this last week it become apparent that reading/writing the X clipboard may not require any work in the X server. So not sure if Xmir needs touching at all for this.

Changed in xorg-server (Ubuntu):
status: Triaged → Incomplete
assignee: Robert Ancell (robert-ancell) → nobody
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

mir (0.19.0+16.04.20160128-0ubuntu1) xenial; urgency=medium

Changed in mir:
status: Fix Committed → Fix Released
Changed in mir (Ubuntu):
status: New → Fix Released
Christopher Townsend (townsend) wrote :

Adding Libertine to this as it will have a new "pasted" daemon that handles the transfer of pasteboard content between Xmir and content-hub.

Changed in libertine (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Christopher Townsend (townsend) wrote :

Invalidating the xmir part of this since this is going to be handled using the pasted daemon, content-hub, and support in Qt.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
Changed in content-hub (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Changed in qtubuntu (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in libertine:
milestone: 1.3 → 1.4
Changed in qtubuntu (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Daniel d'Andrada (dandrader)
tags: removed: xmir
no longer affects: xorg-server (Ubuntu)
no longer affects: unity8 (Ubuntu)
Michał Sawicz (saviq) on 2016-07-29
Changed in qtmir (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in qtubuntu (Ubuntu):
importance: Medium → High
Changed in qtmir (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Changed in libertine (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → 13
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.63+16.10.20160831-0ubuntu1

---------------
qtubuntu (0.63+16.10.20160831-0ubuntu1) yakkety; urgency=medium

  [ Daniel d'Andrada ]
  * Use content-hub for clipboard services (LP: #1471998)

 -- Ken VanDine <email address hidden> Wed, 31 Aug 2016 01:51:46 +0000

Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine - 1.4+16.10.20160901.1-0ubuntu1

---------------
libertine (1.4+16.10.20160901.1-0ubuntu1) yakkety; urgency=medium

  [ Chris Townsend ]
  * Add a background process that allows copying & pasting between an X app,
    another X app, and native Unity 8 apps. (LP: #1471998)

 -- Ken VanDine <email address hidden> Thu, 01 Sep 2016 20:06:21 +0000

Changed in libertine (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.8+16.10.20160831-0ubuntu1

---------------
qtmir (0.4.8+16.10.20160831-0ubuntu1) yakkety; urgency=medium

  [ Daniel d'Andrada ]
  * DBusFocusInfo: added isSurfaceFocused(serializedId)
  * Use content-hub for clipboard services (LP: #1471998)
  * Don't link tests against LTTng

 -- Ken VanDine <email address hidden> Wed, 31 Aug 2016 01:52:12 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in content-hub (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers