Desktop Apps scope empty

Bug #1617545 reported by Michal Predotka on 2016-08-27
110
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Penk Chen
Libertine Scope
Undecided
Unassigned

Bug Description

bq M10 rc-proposed
After today's (27 August 2016) update of the system I find the Desktop Apps scope empty.

dinamic (dinamic6661) wrote :

Same on mx4, also the store doesn.t load

Seth (seth-ciango) wrote :

Same for Meizu Pro 5.

Víctor R. Ruiz (vrruiz) wrote :

This regression was introduced in image 176. It doesn't happen in 175.

Changed in libertine-scope:
status: New → Confirmed
Víctor R. Ruiz (vrruiz) wrote :

scope-registry.log at http://paste.ubuntu.com/23102841/

Exception #4: unity::ResourceException: libubuntu-app-launch.so.2: cannot open shared object file: No such file or directory

I guess that scopes depend on this dropped dependency.

 === Dropped Packages ===
  libubuntu-app-launch2:armhf

Víctor R. Ruiz (vrruiz) wrote :

I can confirm that installing libubuntu-app-launch2 fixes the problem.

eDeviser (wolle3) wrote :

I am using the Nexus 4 with OTA 12 and it is the same as described above: The Desktop Apps Scope is empty.

To Create the Container I used:
`libertine-container-manager create --id libCont --name "myLibCont"`

To Install an App I used:
`libertine-container-manager install-package --id libCont --package leafpad`

Nevertheless no Apps are shown in that scope, even after a reboot.

Christopher Townsend (townsend) wrote :

Yes, it appears libubuntu-app-launch2 was removed from the image and replaced with libubuntu-app-launch3 without anyone notifying us of this change, which in turn broke the Desktop Apps scope:(

We will have to switch the runtime dependency to libubuntu-app-launch3 and get a new package out.

Emanuele Sorce (tronfortytwo) wrote :

Me too. On bq aquaris E5, rc ver 410 and 411

Christopher Townsend (townsend) wrote :

Ok so the click package from the Store is built against libubuntu-app-launch2, but that has recently been dropped from rc-proposed images. The image now has libubuntu-app-launch3, so a new click package needs to be made and published.

But here in lies the problem. Due to limitations in the Store, if we upload and publish a new version, users still using the stable channel will then have a broken Desktop Apps scope because the stable image does not have libubuntu-app-launch3.

As a compromise, I'm making the version of the Desktop Apps Scope available for download for users of rc-proposed. You can get it here: http://people.canonical.com/~townsend/libertine-scope/libertine-scope.ubuntu_1.3.2.1_armhf.click

Once you get his on your device, install it in a terminal by doing:
$ pkcon install-local --allow-untrusted /path/to/libertine-scope.ubuntu_1.3.2.1_armhf.click

Michal Predotka (mpredotka) wrote :

How will this be resolved after OTA-13? If I install the click package now on rc-proposed, will it be compatible with OTA-13. If I do not install the package, will it somehow fix itself after OTA-13?

Larry Price (larryprice) wrote :

The click provided by townsend should continue to work without a hitch on OTA-13.

Once OTA-13 hits, we'll push the new click to the store so it's publicly available, though you shouldn't have to reinstall it at that time unless we roll a new version.

Stephen M. Webb (bregma) wrote :

@mpredotka the same rebuilt click will be rolled into the custom overlay tarball from which rc channels are built, so the problem will be resolved on those channels soon. The stable releases are simply promoted from the release candidate channels, so there will be no problem in OTA-13, except for those who have manually installed the Desktop Apps scope from the store. To that end, we will manually make the rebuilt click available in the store on release of OTA-13.

We can not make the rebuilt click available in the store before the release of OTA-13, because anyone who upgrades the scope will then have a broken image. We *can* make the click available for sideloading to those who currently have a broken system while using one of the release candidate channels.

Michal Predotka (mpredotka) wrote :

Thank you guys for the explanation and again for providing the click package.

Pat McGowan (pat-mcgowan) wrote :

Requires new custom tarballs for frieza and turbo

Changed in canonical-devices-system-image:
assignee: nobody → Penk Chen (penk)
importance: Undecided → Critical
milestone: none → 13
status: New → In Progress
tags: added: regression-proposed
eDeviser (wolle3) wrote :

Hello.

Did I understand right, that this bug does just affect the RC-Channel?

Well I am running a stable channel (OTA12) at my Nexus 4 and I have the same issue:
Desktop Apps scope empty

I created the containers with: ´libertine-container-manager create --id example-container --name "Example Container"´

And then installed Desktop Apps with: `libertine-container-manager install-package --id example-container --package leafpad`

@eDeviser,

Have you refreshed the Desktop Apps scope by dragging it down and letting go?

I'm pretty sure you may be hitting some other unknown issue as this
issue in this particular bug only affects users on rc-proposed. Could
you attach the output of ~/.cache/upstart/scope-registry.log to the bug
please?

On 08/30/2016 01:50 PM, Lukas Hofstätter wrote:
> Yes, I refreshed the scope and I did some reboots.
>
> On Tuesday, August 30, 2016 7:27:28 PM CEST, Christopher Townsend
> <email address hidden> wrote:
>> @eDeviser,
>>
>> Have you refreshed the Desktop Apps scope by dragging it down and
>> letting go?
>>
>
>
>

eDeviser (wolle3) wrote :

Here is my logfile:

Phablet@ubuntu-phablet:~$ cat .cache/upstart/scope-registry.log
aa_getcon failed, errno = 13
[2016-08-30 10:01:43.042] INFO: Registry: RegistryObject::ScopeProcess::exec(): Process for scope: "libertine-scope.ubuntu_libertine-scope" started
[2016-08-30 10:02:45.511] INFO: Registry: RegistryObject::ScopeProcess::on_process_death(): Process for scope: "libertine-scope.ubuntu_libertine-scope" exited
WARNING: QApplication was not created in the main() thread.
[2016-08-30 12:23:22.219] INFO: Registry: RegistryObject::ScopeProcess::exec(): Process for scope: "clickscope" started
Scope::preview() called.
[2016-08-30 12:24:02.387] INFO: Registry: RegistryObject::ScopeProcess::on_process_death(): Process for scope: "clickscope" exited
WARNING: QApplication was not created in the main() thread.
[2016-08-30 12:26:39.757] INFO: Registry: RegistryObject::ScopeProcess::exec(): Process for scope: "clickscope" started
Scope::preview() called.
2016-08-30 12:27:09,967 - WARNING - No default department set in the .desktop file and no entry in the database for "dekko.dekkoproject"
2016-08-30 12:27:09,992 - WARNING - No default department set in the .desktop file and no entry in the database for "stattautohl.edeviser"
[2016-08-30 12:27:50.004] INFO: Registry: RegistryObject::ScopeProcess::on_process_death(): Process for scope: "clickscope" exited
aa_getcon failed, errno = 13
[2016-08-30 19:49:08.399] INFO: Registry: RegistryObject::ScopeProcess::exec(): Process for scope: "libertine-scope.ubuntu_libertine-scope" started

By the way: I am running ubuntu-touch/stable/bq-aquaris.en channel. May this makes a different?

I would not recommend that channel for an N4. Your results will be unpredictable using that channel.

The recommended stable channel for N4 is ubuntu-touch/stable/ubuntu.

Pat McGowan (pat-mcgowan) wrote :

actually chris that channel is fine for the n4, it just brings in some scopes and Here bits

Michal Predotka (mpredotka) wrote :

I'm happy to notice the apps are visible in the scope again. I haven't install the click package from comment #9. Just checked the scope after todays update and apps were there.
Thank you developers!

eDeviser (wolle3) wrote :

Well, for me (remember I am at the stable channel) it had helped to destroy the containers and to create a new one and to install the apps again in it.

Pat McGowan (pat-mcgowan) wrote :

FIxed in the tarballs for M10 and MX5

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
K1773R (k1773r) wrote :

Nexus is also affected!

Larry Price (larryprice) on 2016-10-03
Changed in libertine-scope:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers