Greeter menus show icons, but shouldn't

Bug #927236 reported by Dylan McCall on 2012-02-05
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Undecided
Michael Terry
Unity Greeter
Fix Released
Undecided
Unassigned
libdbusmenu (Ubuntu)
Undecided
Unassigned
unity-greeter (Ubuntu)
Low
Michael Terry

Bug Description

Steps to reproduce:
 - Use unity-greeter as a login screen (NOT in test mode)
 - Open the Network indicator while connected to a network
 - Notice the icon for "Connection Information"
 - Click "Connection Information"
 - Notice the icon on the dialog's Close button.
 - Right click any label or text field and notice the icons in the context menu

If you are unable to follow the above steps, try similar steps with the Power indicator, clicking the menu item for a battery.

Gtk in LightDM is showing icons in menus and buttons! This is something that is usually turned off: there is a key in gsettings, "menus-have-icons" under org.gnome.desktop.interface. It defaults to off, and having it on is inconsistent and hideously ugly (because it is even inconsistent within LightDM). This setting should be the same as in an Ubuntu session: off.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-greeter 0.2.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 5 09:28:08 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110906)
SourcePackage: unity-greeter
UpgradeStatus: Upgraded to precise on 2012-02-04 (1 days ago)

Dylan McCall (dylanmccall) wrote :
Changed in unity-greeter (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
description: updated
Michael Terry (mterry) on 2012-09-10
Changed in unity-greeter (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

OK, there are two things going on here.

1) When we run gnome-settings-daemon, we weren't enabling the xsettings plugin, which translates those gsettings keys into actually useful X settings.

2) Fixing the above works for the dialogs that nm-applet throws up. But for the nm-applet menu itself, it looks like we have to fix an issue with libdbusmenu-gtk not proxying those X settings changes across the dbus wire. Looking into that.

Changed in unity-greeter (Ubuntu):
status: Confirmed → In Progress
Michael Terry (mterry) on 2012-09-10
summary: - GTK is configured to show menu icons
+ Greeter menus show icons, but shouldn't
Michael Terry (mterry) on 2012-09-11
Changed in unity-greeter:
status: New → Fix Committed
Changed in dbusmenu:
status: New → Confirmed
Changed in libdbusmenu (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2012-09-13
Changed in dbusmenu:
status: Confirmed → Incomplete
status: Incomplete → Fix Committed
Michael Terry (mterry) on 2012-09-17
Changed in unity-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.3-0ubuntu1

---------------
unity-greeter (12.10.3-0ubuntu1) quantal; urgency=low

  * New upstream release
    - Rearrange some UI bits (LP: #1049231, LP: #1049235, LP: #1049236,
      LP: #1049239)
    - After a remote login error, do not use cache when trying same user
      again
    - When no users and no manual entry, force manual entry to appear
      (LP: #1044251)
    - When switching between monitors, re-adjust user names (LP: #1043604)
    - Center remote login help dialog
    - Use the xsettings plugin to apply icons-in-menus gsetting
      (LP: #927236)
  * debian/unity-greeter.pkla:
    - Fix policykit file to not be order-dependent and spell out the
      NetworkManager permissions instead of using a wildcard.
      LP: #1048522
  * debian/control:
    - Add some Build-Depends for new test suite
  * debian/patches/01_add_remote_login_help_icon.patch:
    - Drop, remote login help icon is included upstream
  * debian/patches/02_use_remote_login_hint.patch:
    - Update to apply again
 -- Michael Terry <email address hidden> Mon, 17 Sep 2012 13:31:13 -0400

Changed in unity-greeter (Ubuntu):
status: In Progress → Fix Released
todaioan (alan-ar06) on 2012-09-18
Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
Michael Terry (mterry) on 2012-09-18
Changed in libdbusmenu (Ubuntu):
status: Fix Released → Confirmed
Charles Kerr (charlesk) on 2012-09-20
Changed in dbusmenu:
status: Fix Committed → Fix Released
assignee: nobody → Charles Kerr (charlesk)
assignee: Charles Kerr (charlesk) → Michael Terry (mterry)
milestone: none → 12.10.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 12.10.1-0ubuntu1

---------------
libdbusmenu (12.10.1-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Honor changes to GtkSettings' gtk-menu-images value (LP: #927236)
    - don't display an underscore on menuitimes containing a '&' (LP: #994564)
    - set the widget for the accelerator even if there isn't a mnemonic
      (LP: #982656)
    - Some platforms don't have valgrind, so treat those unit tests separately
    - make headers match independent of the build directory
    - constify some public API calls
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 19:22:52 +0200

Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers