Monodevelop doesn't show its menu in the panel

Bug #606470 reported by zp on 2010-07-16
118
This bug affects 24 people
Affects Status Importance Assigned to Milestone
DBus Menu
Confirmed
Medium
Unassigned
monodevelop (Ubuntu)
Undecided
Unassigned

Bug Description

Monodevelop: Installed: 2.2.1+dfsg-1ubuntu2
appmenu-gtk: Installed: 0.1.1-0lucid1
indicator-appmenu: Installed: 0.0.8-0lucid1

This is in Unity.

description: updated
Jorge Castro (jorge) on 2010-07-16
Changed in indicator-appmenu:
status: New → Confirmed
affects: indicator-appmenu → appmenu-gtk
Cody Russell (bratsche) on 2010-07-20
Changed in appmenu-gtk:
importance: Undecided → Wishlist
Cody Russell (bratsche) wrote :

So, this is not something that I will be able to fix for Meerkat.

It looks like Monodevelop is creating menus dynamically rather than populating the menu when the app first starts. I didn't look at this in much detail yet, but it seems like menus are all defined using Mono.Addins and I'm not quite sure when they get created yet.

I don't really have time to invest into this right now since appmenus are intended for UNE, not desktop, and Monodevelop is not an application targeted at UNE. But anyone in the community is, of course, more than welcome to hack on this if they're interested in it. :)

If you press the mnemonic for one of the menus (i.e. "alt-v" for "view"), that menu appears in app-menu (just the one you pressed the mnemonic for). This bug was also in gnome2-globalmenu. Just leaving this here in case it helps.

Cody Russell (bratsche) on 2010-09-30
Changed in appmenu-gtk:
assignee: nobody → Cody Russell (bratsche)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop - 2.4+dfsg-3ubuntu2

---------------
monodevelop (2.4+dfsg-3ubuntu2) maverick; urgency=low

  * debian/patches/no_appmenu:
    - no appmenu for monodevelop (thanks bratsche) (LP: #606470)
 -- Didier Roche <email address hidden> Thu, 30 Sep 2010 17:39:26 +0200

Changed in monodevelop (Ubuntu):
status: New → Fix Released
Dario Bertini (berdario) wrote :

I looked at the patch, and it's only a workaround: for monodevelop it doesn't fix the stated bug of "doesn't show its menu in the panel"

I think it's better to not display this as "fix released": this way when browsing monodevelop bugs in ubuntu it'll show up...

On the other hand, Since I'm personally interested in solving this bug i was already looking forward to gather info to fix it...

i started with https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu ...and unfortunately i stopped there (both dbusmenu-dumper and current-menu aren't able to find the menu... maybe i'll fix a bug about that, but i'm not yet sure about it, i would like to test them a little bit more)

Cody, from your july message i see that you have definitely some insight on the cause of the bug, and you said also that anyone is welcome to come and try to fix the bug...
it's that still so, or are you working directly on it now?
(Obviously i'd like to help, but i have other duties and cannot guarantee anything)

In case, how do you think it should be fixed?
Inside monodevelop, making it fire a dbus message (i've not yet looked into the exact mechanism that it's been used, so sorry for my imprecision) each time that it adds an item to the menu?
Inside gtk/appmenu-gtk, to get this working in every other application that is creating menu dinamically like monodevelop?

Thank you for any guidance

Changed in monodevelop (Ubuntu):
status: Fix Released → Confirmed
Cody Russell (bratsche) on 2010-10-06
Changed in appmenu-gtk:
status: In Progress → Confirmed
Cody Russell (bratsche) wrote :

Hi Dario,

No, I am not working on this bug really.. because appmenu is mostly targeted towards netbook UI, monodevelop isn't a high priority for me to fix right now.

I guess what needs to be figured out is to what extent they're still using gtk menu infrastructure and how much they're building on top of it. If too much of the data is kept at the managed layer, there's nothing we can do without modifying monodevelop. Once I find some more time (after higher priority bugs are fixed) then I can try taking a look at what information I can introspect from them on our side.

/ Cody

The bug is still present in natty, where AppMenu is used by default: monodevelop shows just its menu, without populating the global menu bar.

Ted Gould (ted) on 2011-02-10
affects: appmenu-gtk → dbusmenu
Changed in dbusmenu:
assignee: Cody Russell (bratsche) → nobody
importance: Wishlist → Medium
tags: added: parser

On my machine with Ubuntu 11.04 and Monodevelop 2.6 beta3 the menu doesn't show at all. I found a workaround described here: https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu: setting UBUNTU_MENUPROXY to the empty string causes the menu to appear inside of monodevelop.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package monodevelop - 2.6+dfsg-1

---------------
monodevelop (2.6+dfsg-1) experimental; urgency=low

  * [7c7e1e1] Update watch file to point to Xamarin-hosted MonoDevelop.
  * [c1bd155] Imported Upstream version 2.6+dfsg
  * [9b44935] Disable Ubuntu Appmenu for monodevelop (thanks bratsche) (LP: #606470)
  * [21473bc] Refresh system nunit patch.

 -- Jo Shields <email address hidden> Sat, 10 Sep 2011 14:24:16 +0100

Changed in monodevelop (Ubuntu):
status: Confirmed → Fix Released
RobinJ (robinj) wrote :

What do you mean "Fixed"... Still occurs in Ubuntu 12.04 LTS with MonoDevelop 2.8.

fyksen (fredrik-fyksen) wrote :

Still occurs with ubuntu 13.10. Any fix?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers