[firefox] Extension causes context/drop down menus to disappear

Reported by Yaohan Chen on 2012-08-11
216
This bug affects 35 people
Affects Status Importance Assigned to Milestone
libdbusmenu-qt
Medium
Unassigned
libdbusmenu-qt (Gentoo Linux)
New
Undecided
Unassigned
libdbusmenu-qt (Ubuntu)
Medium
Unassigned

Bug Description

For anyone looking into fixing this: see comment#4

Symptom:
With the Global Menu Integration enabled, sometimes drop down and context menus inside Firefox will stop working. They show up for a moment and immediately disappear. This includes context menus of tab buttons and web pages, and drop down menus opened from toolbar buttons. The problem lasts until Firefox is restarted.

To reproduce:
With Global Menu Integration enabled, toggle the Navigation toolbar (View - Toolbars - Navigation Toolbar).
This is one way I've found that always reproduces the problem. Whether the toolbar was toggled on or off, it triggers the problem for me. It happens even when this is the only enabled extension, and does not happen when it is disabled.

Sometimes the problem also seems to be triggered by opening a new tab but I haven't found a pattern in that.

Environment:
Firefox 14.0.1
Global Menu Integration 3.2.6 package at https://aur.archlinux.org/packages.php?ID=55724
KDE 4.9.00
Arch Linux

description: updated
description: updated
description: updated
Willem Sonke (willem-sonke) wrote :

Same problem here. It also happens in Thunderbird.

Furthermore, when the popup menus don't work, also drag-and-drop doesn't work anymore. So tabs cannot be reordered, etc.

The bug appears almost always in less than 15 minutes when I'm using Firefox or Thunderbird. I never hide any toolbar, so indeed there also must be some other reason.

Willem Sonke (willem-sonke) wrote :

This is strange.

When using the View > Toolbars > Navigation Toolbar option in the (global) menu, the bug appears (as described in the first post). But when I right-click on a toolbar, and then select Navigation Toolbar (i.e. not with the global menu) to do exactly the same thing, the bug doesn't appear.

But as I wrote above, this is certainly not the only way to trigger the bug. I'll try to find another reproducable way to trigger it.

By the way: using Firefox and Thunderbird 15 on KDE 4.9.00, Kubuntu 12.04.

Changed in globalmenu-extension:
status: New → Confirmed
Thaodan (theodorstormgrade) wrote :

Same here using the same setttings as the bug report author but with Firefox 15.01 (with kde patch, https://aur.archlinux.org/packages.php?ID=32598) and with KDE 4.9.1.

Chris Coulson (chrisccoulson) wrote :

Reassigning this to libdbusmenu-qt. It's because it sends the wrong timestamp with events (it uses the system time rather than the X event timestamp). This breaks mouse grabs in Firefox because the last event timestamp ends up being way in the future.

http://bazaar.launchpad.net/~agateau/libdbusmenu-qt/trunk/view/head:/src/dbusmenuimporter.cpp#L276

no longer affects: globalmenu-extension
Jacopo Di Battista (jacopeta) wrote :

I have the same bug with kubuntu 12.04 and kde 4.8.5.... please is there a solution ???? please explain me how to fix it. this bug is very annoying. it is present from version 14 of firefox... when i used 13.0.1 it was no present.

Changed in libdbusmenu-qt:
status: New → Confirmed
Omer Akram (om26er) on 2012-10-15
description: updated
Changed in libdbusmenu-qt:
importance: Undecided → Medium
Changed in libdbusmenu-qt (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - Extension causes context/drop down menus to disappear
+ [firefox] Extension causes context/drop down menus to disappear
Thaodan (theodorstormgrade) wrote :

Any way to fix this without breaking other applications?

superlex (e-lex) wrote :

Hi.
No solution or workaround for this bug?

Joseph Yasi (joe-yasi) wrote :

Changing the timestamp to CurrentTime from X instead of the system current time fixes the problem for me. I don't know if this is the correct solution for Qt, but it's working for me.

Yaohan Chen (yaohan-chen) wrote :

Joseph Yasi's patch fixes the problem for me too.

Joseph Yasi (joe-yasi) wrote :

I've revised the patch to use the QX11Info::appTime() method for querying the X time. This is probably better than the using the X define.

superlex (e-lex) wrote :

It seems to work for me too (Arch Linux).
Thanks.

The attachment "use-qx11info-apptime.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Maik Bode (maikibode) wrote :

How do I apply the patch? I don't know what to do with the text file.
Thanks for help.

Maik Bode (maikibode) wrote :

Okay, that's redundant now as a general software update solved the problem automatically.
To the ones that participated in this: Thank you for your work!

Willem Sonke (willem-sonke) wrote :

I fully updated my system and indeed Firefox 19 came in (version 19.0+build1-0ubuntu0.12.04.1), but the problem still persists for me.

Was the patch applied already?

superlex (e-lex) wrote :

@Maik
Could you explain me?
Now with the last bzr libdbusmenu-qt patch is no more needed?

@Willem
You need libdbusmenu-qt source, then in source dir

patch -Np1 -i ./patch_name.patch

There are many different ways.
You could also edit src/dbusmenuimporter.cpp by hand adding string with "+" and removing strings with "-"

Maik Bode (maikibode) wrote :

@superlex
I'm using the latest Kubuntu version and today the automatic update program installed some updates for Firefox. I think it was a general update of the program, but 'firefox-globalmenu' was part of the update. I hope this helps you ...

superlex (e-lex) wrote :

With libdbusmenu-qt bzr v. 239 and firefox-globalmenu 3.7.1 the problem persists.

No problem with Yoseph's patch

Tom Kuther (gimpel) wrote :

The patch from #10 fixes the issue here, and doens't break anything else so far.
Please commit.

Thanks!

Joseph Yasi (joe-yasi) wrote :

Here's an updated patch for the version that is currently in raring with support for Qt5.

Joseph Yasi (joe-yasi) wrote :

I updated the patch to be a little cleaner for detecting Qt 5.0 and 5.1 as well as X11. It will default back to the system time in the no X11 case now.

Mark (mark-wege) wrote :

Since my update to Firefox 22.0+build2-0ubuntu0.13.04.2~ppa1 a few days ago the bug has returned (running Kubuntu Raring). There may be another cause that I am not aware of.

libdbusmenu-qt2 and libdbusmenu-qt2:i386 are on 0.9.2daily13.03.28-0ubuntu1.

Joseph Yasi (joe-yasi) wrote :

It's because the patch still hasn't been applied to the official libdbusmenu-qt package.

Iain Lane (laney) wrote :

Hi Joseph,

libdbusmenu-qt is maintained on Launchpad in bzr - could you propose a merge against the branch lp:libdbusmenu-qt and get it reviewed by the guys that write the software?

Thanks for your work!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu-qt - 0.9.2+13.10.20130826-0ubuntu1

---------------
libdbusmenu-qt (0.9.2+13.10.20130826-0ubuntu1) saucy; urgency=low

  [ Joe Yasi ]
  * This fixes bug #1035755, [firefox] Extension causes context/drop
    down menus to disappear. The patch uses the correct X11 event
    timestamp instead of the system time. (LP: #1035755)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 248
 -- Ubuntu daily release <email address hidden> Mon, 26 Aug 2013 10:07:36 +0000

Changed in libdbusmenu-qt (Ubuntu):
status: Confirmed → Fix Released
Adam Porter (alphapapa) wrote :

I'm on Raring, and I had this bug many months ago, but I turned off the global menu extension and was able to keep using Firefox.

Recently Firefox began having the same bug again, and I couldn't figure out why. I even removed firefox-globalmenu, but it kept happening. Then I noticed that there is no longer an extension listed for it in Firefox, and then I noticed that firefox-globalmenu suddenly became a transitional package--i.e. it's built into the Firefox package, and there's no way to disable it anymore.

So that leaves me with two choices:

a. Restart Firefox many times per day.
b. Turn off global menu for all applications.

Neither of these are good choices.

Thankfully, the libdbusmenu-qt2 package for Saucy works in Raring and seems to solve this bug.

Now I'm left with two questions:

1. When is the Raring package going to be upgraded? It's essential that it is upgraded: this is a major regression that popped up without warning in the middle of Raring's lifecycle.

2. Why was the globalmenu package merged into the main Firefox package? Why is there no way to disable the global menu for Firefox? This resulted in Firefox's context menus suddenly failing to work at all, with no apparent explanation. On top of that, I had explicitly disabled the global menu for Firefox, but this merge caused it to return without my consent and without any way to disable it!

Joseph Yasi (joe-yasi) wrote :

You can turn it off by setting ui.use_unity_menubar = false in about:config

Adam Porter (alphapapa) wrote :

Thank you, Joseph. This should be made the default for all package upgrades and new installs until this bug is conclusively fixed.

By the way, using libdbusmenu-qt2 0.9.2+13.10.20130826-0ubuntu1 (version number bloat, anyone?) from Saucy has NOT fixed the bug. After a few hours, the menus have stopped working again, immediately after I opened a menu from the add-on bar. The menu's outline is visible for a split second longer than it was when it was failing before, but it still fails, and I still have to restart Firefox.

Joseph Yasi (joe-yasi) wrote :

I've been using this fix for months with no problems. Are you running into this bug: https://bugs.launchpad.net/libdbusmenu-qt/+bug/779344 ?

On Thu, Sep 5, 2013 at 8:31 AM, Joseph Yasi <email address hidden> wrote:
> I've been using this fix for months with no problems. Are you running
> into this bug: https://bugs.launchpad.net/libdbusmenu-qt/+bug/779344 ?

Yes, I experience that bug. But I still have this bug too. I had to
disable the globalmenu in Firefox.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers