Lernid identifies with nickserv, should use server password

Bug #838557 reported by Elizabeth K. Joseph
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lernid
Wishlist
John S. Gruber

Bug Description

Lernid identifies with nickserv when connecting, as a result users who use a password and have a cloak show the join/quit/join message of host changing upon connect:

19:40:00 -!- grantbow [~grantbow@75-101-62-95.dsl.static.sonic.net] has joined #ubuntu-classroom-chat
19:40:02 -!- grantbow [~grantbow@75-101-62-95.dsl.static.sonic.net] has quit [Changing host]
19:40:02 -!- grantbow [~grantbow@unaffiliated/grantbow] has joined #ubuntu-classroom-chat

If you use a server password instead you won't see this behavior.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Thanks for the bug report, Lyz! Thanks for your help the other night testing Lernid, as well.

How big a problem is this?

I tried to read up and saw on the "interwebs" that some IRC networks, like freenode, can use the server password to identify nicks, but others don't. Is that true? If so, what should we do about this to allow it to interoperate with other networks in the future? (There was a suggestion in the recent lernid events blueprint that the network be an event parameter).

A check-mark to say where the password should be directed, perhaps?

Revision history for this message
Mohammad AbuShady (coalwater) wrote : Re: [Bug 838557] Re: Lernid identifies with nickserv, should use server password

I don't know exactly what's a server password but what I do is identify
after connect but before joining the channel, this way the change host
message can't be seen by others.
On Sep 7, 2011 5:40 AM, "John S. Gruber" <email address hidden> wrote:
> Thanks for the bug report, Lyz! Thanks for your help the other night
> testing Lernid, as well.
>
> How big a problem is this?
>
> I tried to read up and saw on the "interwebs" that some IRC networks,
> like freenode, can use the server password to identify nicks, but others
> don't. Is that true? If so, what should we do about this to allow it to
> interoperate with other networks in the future? (There was a suggestion
> in the recent lernid events blueprint that the network be an event
> parameter).
>
> A check-mark to say where the password should be directed, perhaps?
>
> --
> You received this bug notification because you are subscribed to Lernid.
> https://bugs.launchpad.net/bugs/838557
>
> Title:
> Lernid identifies with nickserv, should use server password
>
> Status in Lernid:
> New
>
> Bug description:
> Lernid identifies with nickserv when connecting, as a result users who
> use a password and have a cloak show the join/quit/join message of
> host changing upon connect:
>
> 19:40:00 -!- grantbow [~grantbow@75-101-62-95.dsl.static.sonic.net] has
joined #ubuntu-classroom-chat
> 19:40:02 -!- grantbow [~grantbow@75-101-62-95.dsl.static.sonic.net] has
quit [Changing host]
> 19:40:02 -!- grantbow [~grantbow@unaffiliated/grantbow] has joined
#ubuntu-classroom-chat
>
> If you use a server password instead you won't see this behavior.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lernid/+bug/838557/+subscriptions

Changed in lernid:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Lyz--

It appears that, right now, it wouldn't be possible to supply the password as a server password. It looks like a new two-step sign-on is in the cards for now. See LP: #850419.

Would it be reasonable to delay all chatroom connections (where a password is supplied) until a nickserv exchange is completed? (I think it would add about 4 seconds to the connection time). Basically, this is what coalwater describes. If telepathy-idle is ever enhanced to recognize the locked nick condition we could probably revisit this.

coalwater--

During the server sign-on steps at the very beginning of the connection being established there is an opportunity to supply a password to the server through telepathy, which would use the "PASSWORD pw" statement. Different irc clients call this different things. If sent there, and if it were always correct, a later exchange with nickserv would not be needed, and the cloak would be ok from the beginning (if I understand correctly). At the very beginning the three things potentially sent to the server are:
PASS password
USER userid 8 :Full name
NICK nick
(Current line 1061 in telepathy-idle src/idle-connection.c)

Revision history for this message
Mohammad AbuShady (coalwater) wrote :

Well xchat uses that same method, connect to server, contact nickserv, and wait then after nickserv confirms it opens the channels saved as favorite, If the sever password is not possible for any reason i would think it's ok to do this same method but also so a small progress box, like connecting, identifying, joining classroom, then close box when all is done, it would keep the user from getting bored lol.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

With the new login method targetted for 0.8.5, we are trying to do the rename as soon as we connect to the server. I think this is improved, but it may depend on how fast things happen within telepathy, the network, and the server. I think this is improved. Please resurrect it if I'm wrong.

Changed in lernid:
milestone: none → 0.8.5
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers