Connect window looks like it is frozen

Bug #806804 reported by grofaty
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lernid
Medium
Unassigned

Bug Description

I have installed Lernid 0.8.1.4 from Lernid PPA on Ubuntu 11.04. At logon "Choose an event" window there is label "Connection to the classroom may take up to one minute" info. When clicking on "Connect" button it is confusing this window does not disappear, it just looks like Lernid has frozen, it just stays opened. If it is not too hard to implement, I would prefer removing "Connection to the classrom may take up to one minute" label and when clicking on Connect button "Choose an event" window should hide immediately and instead "Connecting to event..." info displayed in status-bar. Just like Firefox design when "Waiting..." is displayed.

Related branches

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Grof: For how long did it seem to freeze? We sure don't want a freeze, of course.

Your suggestion about the "one minute" line doesn't seem to me to cover the bug the line was trying to fix. People were getting anxious that it was taking a long time to join the classroom. It takes a lot longer than firefox takes to load a page and folks get anxious unless they realise that it is normal to take a while to join the classroom. We can't shorten the join time, but we can set expectations.

Revision history for this message
grofaty (grofaty) wrote :

It is not such a big problem. It took for couple of seconds. First I thought that I miss-clicked the button, so I clicked one more time. Then I though it has frozen, then I have realized it is probably just working.

My suggestion to remove confusion is when Connect button is clicked the login window just hides and in status bar writes info like "Connecting...". This is way more standard approach. But for know I think this is not a major issue, maybe just tag this bug report with low priority.

Revision history for this message
Elizabeth K. Joseph (lyz) wrote :

The "freeze" time isn't that long on my super powerful desktop, but it's pretty long (over 5 seconds) on my little low-power netbook so it does end up feeling like something is wrong.

I like the idea of some kind of status bar saying it's connecting if such a thing is possible

Revision history for this message
John S. Gruber (jsjgruber) wrote :

I have in my notes that grofaty is using Natty, so he shouldn't be running into the web page slowness problem. His experience is probably like your EK.

I think I see a little slowness on natty myself, just a couple of seconds. I'll check it out to see if there is anything I can do.

Thanks again to you both.

Changed in lernid:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
grofaty (grofaty) wrote :

I have an old notebook running Ubuntu 11.04 inside a virtual machine, so in my case it is probably slow because of hardware slowness. There can be several problems why there can be a delay in connecting, I think the main problem is design principle that any window where some button is clicked should be hidden. I prefer status bar info, because this is most commonly used method.

Changed in lernid:
importance: Low → Medium
Revision history for this message
Mohammad AbuShady (coalwater) wrote :

I noticed that this problem is more clear when the session has slides attached with it, if the slides are gonna take like 10 or 15 seconds to download, lernid freezes for that long till the download is finished, what's even more annoying is that when i closed lernid and reopened it it had to download the slides again, guess it was more clear with me cause my internet connection isn't that fast.
it would be good if we downloadin in /tmp and check if the file exists before downloading, it would be nice, but for the whole freezing thing i think it won't be possible to solve without creating a separate thread ( i think )

Changed in lernid:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers