Lernid does not bring focus to the slide view when a slide is shown

Bug #793788 reported by Jono Bacon
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lernid
Critical
John S. Gruber

Bug Description

When I originally wrote Lernid and the instructor changes to a new slide (e.g. [SLIDE 20), Lernid would bring focus to the slide view to ensure the user notices the slide change. This has since been changed to not bring focus to the slide view. As such, if you are looking at the schedule and the slide changes, many users don't see the change. We have already seen this in user testing.

As such, I propose:

 * When a slide change command is parsed, Lernid automatically focuses on the slide view.

Related branches

Revision history for this message
Jono Bacon (jonobacon) wrote :

Marking as Critical because I see problem as a serious usability issue in Lernid (people not seeing the slides change).

Changed in lernid:
status: New → Confirmed
importance: Undecided → High
importance: High → Critical
Revision history for this message
John S. Gruber (jsjgruber) wrote :

See LP: #512432 for the history on when this was changed from the original behavior. (Bazaar revno 116)

Revision history for this message
Nathan Handler (nhandler) wrote :

I still don't think automatically switching tabs is the best approach. Some things that I would add to help with this issue include:
  * Having the tab actually flash when a new slide/URL is shown. Flashing tends to attract a bit more attention.
  * Utilize the status bar more to show that "Presentation has changed to slide #5" or "Now showing http://ubuntu.com/".
  * Have a preference/setting to allow the user to tell Lernid to automatically switch tabs. This allows the user to choose the behavior that they prefer.
  * Have the presentation always displayed (when there is one), regardless of what tab is displayed. The presentation is fairly small in size, so users who are working in the terminal should still have plenty of room. This doesn't help with the URL switching, but I think that is a bit less important than slide switching for Lernid.

Any combination of these ideas should make it easier to detect new slides/URLs.

Revision history for this message
Jono Bacon (jonobacon) wrote : Re: [Bug 793788] Re: Lernid does not bring focus to the slide view when a slide is shown

On Tue, 2011-06-07 at 15:23 +0000, Nathan Handler wrote:
> I still don't think automatically switching tabs is the best approach.

Why? The whole purpose of displaying slides is that the user sees them.
Today with Lernid if a slide change happens the user will likely never
see it. This is in my mind a serious usability flaw in the app - the
goal of Lernid is to provide a simple integrated experience that reacts
to events in the session and displays them (such as changing the web
browser when a link is detected, or displaying a slide).

If the user is looking at another tab when the slide is changed, I would
consider this an edge case. The user should really be looking at the
slides and engaging in the session.

I see no reason why we could not accommodate this edge case with a
configuration option that does not automatically focus on the tab that
requires attention, but I really think it would devalue the app if this
functionality is on by default as it is now.

> Some things that I would add to help with this issue include:
> * Having the tab actually flash when a new slide/URL is shown.
> Flashing tends to attract a bit more attention.

This is the modern equivalent of the <blink> tag. ;-)

> * Utilize the status bar more to show that "Presentation has changed
> to slide #5" or "Now showing http://ubuntu.com/".

I don't think users will notice this. Today the tab name bolds when a
slide changes and many users don't see this.

> * Have a preference/setting to allow the user to tell Lernid to
> automatically switch tabs. This allows the user to choose the behavior
> that they prefer.

As I said above, I agree with an option, but the automatic focus should
be switched on by default.

> * Have the presentation always displayed (when there is one),
> regardless of what tab is displayed. The presentation is fairly small
> in size, so users who are working in the terminal should still have
> plenty of room. This doesn't help with the URL switching, but I think
> that is a bit less important than slide switching for Lernid.

This could be an option, although I think it is pretty neat having the
webpage and the slide next to each other - it is useful if a session
leader wants to reference both (e.g. a slide to show the key points and
a web page with sample code).

 Jono

--
Jono Bacon
Ubuntu Community Manager
jono(at)ubuntu(dot)com
www.ubuntu.com : www.jonobacon.org
www.twitter.com/jonobacon : www.identi.ca/jonobacon

Revision history for this message
John S. Gruber (jsjgruber) wrote :

I certainly agree that we want to avoid having the user miss slides because they don't know they are changing. We must avoid that. It's even worse because they can't go back if they miss a slide. That's a significant failing of the current version, too. The current slide (and web page) change attention mechanism still isn't good enough. Flashing the title of the Session Tab is only marginally better than changing its text bold or a different color, although I'm not sure that's what Nathan was really suggesting. IIRC, blinking text is deprecated because it makes the very thing you want the user to read hard to read, and because users find it annoying.

Beyond those issues I get very nervous.

I'd like to mull this over. It deserves careful thought.

Changed in lernid:
status: Confirmed → In Progress
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers