Add Event tab

Reported by grofaty on 2011-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lernid
Wishlist
Unassigned

Bug Description

When I see on some blog or somewhere that there is interesting topic that I would like to learned about and when the time comes for a session, I usually forget the event name. I just know there is some event out there and THE session I would like to participate. So now I do the following:
1. start Lernid
2. connect to first event
3. wait to load all of the sessions
4. scrool down to the end of list to get past of all history sessions
5. bad luck, session is not in this event
6. disconnect
7. repeat steps 2 to 6 for each event to find out session I would like to participate.

In my humble opinion it would be simpler if there is something like Event tab where all of the events are listed (left window) and inside of events there is a scheduled sessions list (right window). All of this events and schedule list should be loaded at start-up, so clicking on events does not need user to wait for "connect/disconnect" actions.

There is one more thing that could be improved: history sessions. There could be a check-box to hide/show past sessions. The main problem is, there is a huge list of sessions already done and scrolling down/up is little bit annoying. Check-box could solve the problem.

Related branches

grofaty (grofaty) wrote :
Changed in lernid:
status: New → Confirmed
importance: Undecided → Wishlist
John S. Gruber (jsjgruber) wrote :

The blueprint wouldn't add another tab, necessarily, but should make it easier to find the session you heard about, I think.

Changed in lernid:
status: Confirmed → In Progress
Changed in lernid:
milestone: none → 0.8.2
Nathan Handler (nhandler) wrote :

I tend to agree that it could be easier to change events. If the user is switching to an event taking place in the same irc channels on the same network, there is no reason to disconnect either. At the same time, I don't think a tab is the best approach. Once a user finds the right event, there is little reason to change events again.

grofaty, is there something that could be done in the event announcements to make the event more clear? The event name is usually fairly prominent in the blog posts and email announcements. Personally, I would have thought that users would have a harder time finding the right session rather than the right event.

grofaty (grofaty) wrote :

Don't know if the tab is the best approach, but switching between events and sessions should be easier. What I though with Event tab is to join three elements: event, session and session history (check box to hide it). I just think it should be easier.

John S. Gruber (jsjgruber) wrote :

@Nathan and Grof,

Please see the related blueprint on the right. Most users won't have to worry about events anymore. We'll get rid of event calendars and just use one calendar per classroom. So we'll just have one linear list for organizers to keep track of (presumably one they already have), and one linear list can be presented to the user, pre-scrolled to the next session. There should be much less confusion and bother, I think. I also think that should take care of this bug.
It will also take care of people using Lernid who don't see slides or see web pages change because they chose the wrong event when connecting. If they are in the correct classroom (which they can now check) they, and the software will be following the correct sessions.

PS. Events are now added to schedule tab list. I don't imagine Nathan has seen this yet but Grof has. That addition can help users pick out future event sessions of interest, and helps clarify what sessions are about, and ties sessions to event promotion. I'm not saying that events won't be important, but they won't have to be specified by the student anymore, which I think will be a big win for them and for event organizers and should eliminate overall headaches. (Not my idea, by the way, but I think it's a great one).

John S. Gruber (jsjgruber) wrote :

You guys may be following over mail, so here's the URL: https://blueprints.launchpad.net/lernid/+spec/lernid-config-file-improvements

Changed in lernid:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments