Don't block UI when downloading slides

Bug #530119 reported by Michael Budde
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Lernid
High
John S. Gruber

Bug Description

When downloading big slides, the UI hangs and it may seems like Lernid has frozen.

Related branches

Michael Budde (mbudde)
Changed in lernid:
status: New → Triaged
importance: Undecided → High
milestone: none → 0.7
Michael Budde (mbudde)
Changed in lernid:
status: Triaged → Fix Committed
Michael Budde (mbudde)
Changed in lernid:
status: Fix Committed → Fix Released
Revision history for this message
John S. Gruber (jsjgruber) wrote :

This was reverted because threading being interfered with by the Adobe flash plugin. Re-doing this with gio asynchronous I/O.

Changed in lernid:
status: Fix Released → Confirmed
assignee: nobody → John S. Gruber (jsjgruber)
milestone: 0.7 → 0.8.2
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Again fixed in Lernid (0.8.2.2). Using gio

Changed in lernid:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers