Lens not showing any search results and doesn't open up with any.

Reported by Oyibo on 2012-09-16
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Cooking-Lens
Medium
Eduard Gotwig

Bug Description

I've got the lens installed however it doesn't seem to show me any results (even before I type in cookies for example), I checked using my system monitor to see if the lens was even active and it doesn't appear in the list (assuming it should show up as unity-lens-cooking ) however the lens is openable as shown in the attached screenshot. Thanks in advance for your help! (http://askubuntu.com/questions/189483/trouble-getting-cooking-lens-to-work is my post on AU if it happens to not be a bug, however I haven't found a solution as of yet)

Oyibo (oyib0) wrote :
Leon Marincowitz (lionthinker) wrote :

Never mind showing any results before typing a search string, with me it never show any results irrespective of what I type in. Currently the lens just takes up space.

Oyibo (oyib0) wrote :

Yeah I just retested it too, I've got exactly the same thing as you Leon, quite a shame, as the idea itself along with the lens is great when working!

Changed in lens-cooking:
status: New → Confirmed
Eduard Gotwig (gotwig) wrote :

Actually, I want to work on a full potential to Ubuntu 12.10, the current release.

However, I try to provide support for 12.04, too.

I am going to work on that.

Recently I converted the lens and scopes to Python 3.

Changed in lens-cooking:
importance: Undecided → High
assignee: nobody → Eduard Gotwig (gotwig)
Eduard Gotwig (gotwig) wrote :

Update unity-lens-cooking, restart PC, than retry. The recipe sites should have the wrong names, but at least all work for me.

Changed in lens-cooking:
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) wrote :

Oups, sry.. I just tested with Ubuntu 13.04 :-) I am going to investigate how to fix for 12.10 and 12.04.

Its strange that you can select the cooking lens, I dont see it at all under my 12.04 setup :/

Changed in lens-cooking:
status: Fix Committed → In Progress
Eduard Gotwig (gotwig) wrote :

This problem has to do with a buggy version of "Dee".
That problem got solved in 12.10, but not in 12.04.

With that bug, you are not able to develop your lenses and scopes for ubuntu unity with Python3 :(
I've already ported all the code to Python3. So to fix that, I would have to backport , or offer an older version.

I've gotta take a look into backporting in the holidays, I hope.

Changed in lens-cooking:
importance: High → Medium
status: In Progress → Triaged
Rick Harris (rickfharris) wrote :

How's the progress tracking on this ?

Hate to be a 'me too' but been having the same problem as Oyibo for some time now.
Have just done a checkout of trunk and the problem remains.

Haven't been able to get this to work on any Ubuntu release (tried Precise, Quantal, Raring).
If there is anything we can do to help debug at this end, don't hesitate to let us know.

Is there a special version of dee we should be using for this package ?
I have dee-1.0.14-0ubuntu1 installed with support for both python2 and python3 and different lenses that use both python2 or python3 only work fine.
eg. unity-lens-video uses python2, unity-lens-photos uses python3

Would love to see this lens take flight, keep us updated and thanks for your efforts so far :)

Rick Harris (rickfharris) wrote :

It works!!!

My mistake was relying on distutils using the source's supplied setup.py to install instead of using debian/unity-lens-cooking.install, so had messed up icon paths and was missing all the *.scope files.

The attached patch fixed this for me, big thanks ;)

Eduard Gotwig (gotwig) wrote :

I applied your patch, pushed it, and now an actual version with it is available in the Scope Packers PPA.

Does it work for you, and Ubuntu 12.04?

Changed in lens-cooking:
status: Triaged → Fix Committed
status: Fix Committed → In Progress
Rick Harris (rickfharris) wrote :

Thanks for applying, it works on Quantal and Raring.
Not able to test on Precise as have since moved on from this version.

Oyibo (oyib0) wrote :

Hey Eduard, I went into software updater and got the applied update, but it still doesn't work on Precise unfortunately.

Keep me posted if I can do anything to help your already amazing lens as I'm sure I'm not the only user who'd love to have it working on the current LTS. Many thanks.

Eduard Gotwig (gotwig) wrote :

Yeah, I also tested it.

But that is not my fault, but that of libdee & Unity I guess.

They don't support Python 3 normaly. I don't want to port my code back to Python2. Can you understand that?

Oyibo (oyib0) wrote :

Ah apologies, my fault: I didn't properly read the conversations earlier. I'll have to update Ubuntu release at some point.

Thanks for your help, I think this bug can be marked as solved for the time being no?

Eduard Gotwig (gotwig) on 2013-02-25
Changed in lens-cooking:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers