UnicodeEncodeError creating a team that contains non-ASCII on name via API

Bug #619180 reported by Ursula Junque on 2010-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lazr.restful
Critical
Unassigned

Bug Description

As seen on OOPS-1689S533:
  UnicodeEncodeError: 'ascii' codec can't encode character u'\\xfc' in position 16: ordinal not in range(128)

Steps to reproduce:
1) lp = Launchpad.login_with("test", "staging", version="devel")
2) lp.people.newTeam(name="úrsula", display_name="Úrsula's team")
3) Boom! UnicodeEncodeError: 'ascii' codec can't encode character u'\xfa' in position 15: ordinal not in range(128)

Related branches

Ursula Junque (ursinha) on 2010-08-17
tags: added: api
Curtis Hovey (sinzui) wrote :

I cannot reproduce this on the web site, the name is correctly reported as invalid and the user is asked to fix it. The display name is fine and it accepted. I think something is getting mangle in the API submission. This may relate to the issue where fields are not validated on certain operations.

affects: launchpad-registry → launchpad-foundations
Gary Poster (gary) wrote :

To state the obvious and the possibly irrelevant: if the validation is done in views, it won't be done in the API.

Changed in launchpad-foundations:
status: New → Triaged
importance: Undecided → Low
Changed in launchpad:
importance: Low → Critical
William Grant (wgrant) on 2011-01-28
affects: launchpad → lazr.restful
Changed in lazr.restful:
status: Triaged → Fix Committed
Changed in lazr.restful:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers