tox fails and doesn't support Python 3.6

Bug #1662701 reported by Barry Warsaw on 2017-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lazr.config
High
Barry Warsaw

Bug Description

Because of the namespace package in Python 3, and because of https://github.com/tox-dev/tox/issues/453 running tox now fails when importing lazr.delegates.

Also, we should add official support for Python 3.6 and drop official support for 3.2 and 3.3 (although the latter two will probably continue to work).

Related branches

Barry Warsaw (barry) on 2017-02-07
Changed in lazr.config:
milestone: none → 2.2
assignee: nobody → Barry Warsaw (barry)
importance: Undecided → High
status: New → In Progress
Barry Warsaw (barry) on 2017-02-09
Changed in lazr.config:
status: In Progress → Fix Committed
Barry Warsaw (barry) on 2017-02-09
Changed in lazr.config:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers