DataError: OFFSET must not be negative

Reported by Diogo Matsubara on 2011-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Brad Crittenden
lazr.batchnavigator
Critical
Brad Crittenden

Bug Description

As seen on OOPS-2049AW40 a DataError: OFFSET must not be negative was logged accessing the +translate page.

It seems like an URL hack given that the OOPSes have no referrer. In any case the page shouldn't oops or at least raise a UnexpectedFormData error

Another oops: OOPS-2054H61: ForbiddenAttribute: ('__len__', <storm.sqlobject.SQLObjectResultSet object at 0x1269f150>) was recorded when Brad tried to reproduce this bug.

Related branches

lp:~bac/launchpad/bug-826839
Merged into lp:launchpad at revision 13743
Benji York: Approve (code) on 2011-08-19
description: updated
Brad Crittenden (bac) on 2011-08-17
Changed in launchpad:
assignee: nobody → Brad Crittenden (bac)
Brad Crittenden (bac) on 2011-08-17
Changed in launchpad:
status: Triaged → In Progress
Brad Crittenden (bac) wrote :

I've tried to replicate the original problem by hacking the following URL to mimic what I see in the OOPS (note there is no 'memo' field):

https://translations.launchpad.net/transmission/trunk/+pots/transmission/vi/+translate?direction=backwards&start=180

There is no OOPS but the numbering of the items is incorrect as it shows "181 -> 186 of 476" but the first item is 471. See the attached screenshot

Brad Crittenden (bac) wrote :

Aha! The OOPS seems to be triggered by attempting to view a translations page with "show=untranslated" and "direction=backwards" when there are no untranslated messages. Probably would happen any time the filter does not match and a direction is given.

Brad Crittenden (bac) on 2011-08-19
Changed in lazr.batchnavigator:
status: New → Fix Committed
assignee: nobody → Brad Crittenden (bac)
importance: Undecided → Critical
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Brad Crittenden (bac) wrote :

https://translations.qastaging.launchpad.net/transmission/trunk/+pots/transmission/eu/+translate?start=0&batch=10&show=untranslated&direction=backwards

The Basque (eu) translation on qastaging has zero untranslated strings. Using the above URL to replicate the problem of going backwards in an empty result set did not OOPS. The problem is fixed.

tags: added: qa-ok
removed: qa-needstesting
Gary Poster (gary) on 2011-08-25
Changed in launchpad:
status: In Progress → Fix Released
Brad Crittenden (bac) on 2012-03-26
Changed in lazr.batchnavigator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers